OMV fails starting the web server

  • Hi community, i'm posting here becouse after more than 5 or 6 hours trying to install a NAS on my new Raspberry pi 3 b+ it's been impossible for me, let's see if you can help me.

    I've followed the instructions to install the OPM image on the raspberry: download the image, burn the image without decompressing with etcher on a 32GB SD card, connect an USB with ExFat format as HDD to the raspberry, connect the SD card, let the installation beggin after it automatically reboots.

    Once i get here, it tells me the ip to connect is but when i try i can not connect.

    I've done some ping to the ip to see its reachable and of course it is.

    During the installation, some errors occurred: Bluetooth service, and the following sentence:
    Failed to start a high performance web server and reverse proxy server. See 'systemctl status nginx.service' for details.

    I guess the problem may be the nginx service but since i can not connect due to ssh i don't know what to do.

    After searching on the forum i found a man who seems got the same error like me, but he solved it burning the image again:
    OMV fails to start a web server

    I hope someone will be able to help me becouse i'm getting a little bit crazy with this..

    Thank you so much in advance.

  • Have you checked the SHA1 or MD5 key after download to make sure the image is not corrupted?

    See 'systemctl status nginx.service' for details.

    What is the output of that?
    Edit: have just seen you have issues using SSH. But you have a diplay, so why not use a keyboard.

  • Well even the etcher told me that the burning was correct i'm going to check it. Not sure how but i'll take a look.
    About the systemctl statys nginx.service, i have keyboard and display, but when i try to login as admin/openmediavault it don't let me check anything about the systems; it just reload the main page, telling me again the ip where the GUI should but (but of course it is not) and ask me again for the user/password.

  • Well even the etcher told me that the burning was correct i'm going to check it. Not sure how but i'll take a look.

    Etcher tells you that the buring was correct. But it cannot tell you if the image was correct. For this you have to check the MD5 checksum.…of-any-file-in-windows-10

    for login:
    admin/openmediavault is for the GUI
    root/openmediavault is for terminal/console

  • macom:
    I've cheked the MD5 and it maches, so the file is correctly downloaded.
    On the other hand, i've logged in with the root user as you said and the output of the systemctl status nginx.service is (i attach the picture):

    You are right and thats what i wanted to say. Sorry for my english, maybe it was not too clear.

    Thank you so much for your help.

  • Same problem here. I've tried for hours but always the same thing. I've tried re downloading OMV, burning with etcher in 2 different sd cards, and always the same thing. @Ayv014 did you managed to solve this problem? The only thing i haven't done is connecting the hard drive, but i should be able to enter the omv pannel either way right? The raspberry pi has been conected to the internet the whole time. My apple Keyboard is the only one i have right now, and it doesnt look to work. Ssh doesnt work either, permission denied every single time when i put the default passwords. Any suggestions?

  • I figured this out. If you Google on that error it appears to be related to IPV6…ginx-erreur-it-didnt-open

    The suspect line is in


    You need to comment out the line show and add the simpler non-IPV6 version

    listen 80 default_server;
    # listen [::]:80 ipv6only=off;

    Doing this may very well disable IPV6 for OMV, but I suspect that is okay for most people.

    Make the change and reboot and the GUI will come up. Be sure you use a http URL and not https or it won't work either.

    I also ran into the fact that no version of balenaEtcher works to flash the SD card. I had to uncompress the file and then use win32diskimager.

    Once you do get that to work, you need to enable root access via SSH in the control panel to be able to SSH using the root credential.

  • I also ran into the fact that no version of balenaEtcher works to flash the SD card. I had to uncompress the file and then use win32diskimager.

    In other words: you ignore that your SD card is faulty (that's what Etcher is telling you!) and chose to burn a corrupted image to SD card which is simply weird.

    You will soon end up here: OMV 4 + RPI 2 = Crash

    I hope you're then able to understand that you can't run any software from broken storage.

    And wrt your 'fix'... that's none. Simply buy a new good A1 rated SD card, burn the image with Etcher, follow the readme.txt at download location and allow for Internet access on first boot and EVERYTHING WILL WORK OUT OF THE BOX. No need to waste your own time with 'fixes' since once you solve your hardware problems (broken SD card or burning) everything will be fine.

  • Thank you tkaiser.

    My SD card is a new 32 GB Sandisk Ultra A1 from Amazon. Based on your feedback I tried this again with three other new SanDisk Ultra A1 cards using balenaEtcher v1.5.5 with two different downloaded image files and all failed in the same way. After appearing to succeed (it shows burning from 1% to 99%) it displays the error "The writer process ended unexpectedly. Please try again, and contact the Etcher team if the problem persists".

    Just to make sure, I took the SD cards to a different laptop (an older Toshiba vs a newer Lenovo Thinkpad), and balenaEtcher v1.5.5 did successfully flash the image to the SD card. The resulting card worked in the Raspberry Pi without any modifications. So there must be some Windows 10 OS/firmware thing that balenaEtcher is sensitive to.

    I again tried the SD card flashed using win32diskimager on the Lenovo, and this time the install worked, so I suspect that I just didn't wait long enough and somehow interrupted the install process the first time.

    Bottom line is if balenaEtcher doesn't work, try another PC. Once the SD card is plugged into the Pi, don't touch it until it says "[OK] Started a high performance web server and a reverse proxy server."

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!