How to change resolution after OMV is already installed with a different monitor?

  • I originally installed OMV 4 using a different monitor connected to the OMV PC (I'm using the AMD64 install).
    I had installed with a larger higher resolution monitor. (Wife's).
    I purchased a smaller monitor with max resolution of 1366x768.
    After booting OMV the command line text is now offscreen (some).
    I tried editing the /etc/default/grub uncommenting the various resolution statements and changing to 1024x768 but
    it appears that OMV disregards that at some point in the boot process and changes the resolution to what was the
    original setup resolution.
    As it is now I am having to always use shellinabox to display the linux command screen correctly. I would like to change
    the OMV resolution so that I can also view the linux command screen correctly on the screen attached to the OMV PC.
    I've searched this forum and others places and can't find a solution other than reinstalling OMV.
    Can I change the resolution of OMV so I can view the linux command line correctly on this smaller lower resolution monitor
    without completely reinstalling OMV?? Thanks.

  • Strange never had that I installed mine using a 17" monitor but today I had a 15" only and it just auto negotiated...but you could try xrandr -s 1024x768 however I accept no liability :) this is an old option.

  • xrandr was not installed...


    i installed it...
    sudo apt-get update
    sudo apt-get install x11-xserver-utils


    Now when I run
    xrandr -s 1024x768


    I get can't open display...


    I also tried running xrandr --verbose...
    Same thing...
    can't open display

  • That's a standard vga so it should just auto negotiate on boot up, unless the monitor is not capable of that, is there not an option on the monitor to auto the resolution.
    The reason I say that is mine was installed with a 17", today I had to connect another monitor a 15" to access the bios, whilst the screen flickered and went on and off, it sorted itself.

  • I wish...Yeah it does have an auto negotitate and I've run it numerous times...It autonegotiates right back to the same screen.
    It's a Viewsonic 18 inch refurb...Can't return without paying return shipping which which would probably cost more than half
    of what I paid for it ($49.99)...It works fine for what I primarily bought it for (Boot Clonezilla CD to backup System at 800x600)...
    But I'd like to be able to run the command prompt screen from it as well without having to use shellinabox...
    Like I said I searched around before posting and didn't come up with a solution for OMV (other than possibly resinstalling)...

  • TBH I've never experienced or had such a problem, either there is an issue with the monitor or the output via the pc, I've seen the screen go so small I can't read it only for it to truncate when it goes larger then for it too settle to the correct size.

  • No problem...Like I said there may not be a solution (that's known) as I didn't come up with any anywhere else (Others had the same problem)...
    Somewhere in OMV4 setup they are setting the resolution and that overrides everything it seems and there may be no fix other than to resinstall
    and let it detect (or set it) during setup..


    I tried writing an xorg.conf...It didn't work...It get's overridden during boot.


    Section "Device" Identifier "Configured Video Device"EndSectionSection "Monitor" Identifier "Configured Monitor" HorizSync 30.0-62.0 VertRefresh 50.0-70.0EndSectionSection "Screen" Identifier "Default Screen" Monitor "Configured Monitor" Device "Configured Video Device" DefaultDepth 24 SubSection "Display" Depth 24 Modes "1024x768" "800x600" EndSubSectionEndSection

  • Been doing some searching, seems as if you can set this in /etc/default/console-setup this is the content of that file on my own machine


  • Of course...I'd still like to solve the issue if possible...
    Thanks for helping...I'm going to go reinstall (ugh) and see if that fixes
    it...If not then I know...I can always restore the system with a backup no problem.


    Thanks.

  • Well now I know...
    Even running a reinstallation I still have the same text off-screen situation...
    Oh well...Clonezilla CD works fine at 800x600 and that's what I'm going to go do now...Restore the system.

  • It's just a $h1T model...
    https://www.newegg.com/Product….aspx?Item=9SIAH5U7K20266
    Their tech support said they didn't work with Xbox either...
    Anyway it works with what I bought it for (Backing up and Restoring System Drive with Clonezilla) which works fine...


    You should be able to change/set the resolution in OMV. But I've seen nowhere that can be done (Although I'm sure it can be somehow)...
    Since 800x600 works fine with Clonezilla if I knew where and how to change the OMV resolution setup that resolution should work...
    But even the OMV installation is setting a resolution that the monitor can't cope with. I've seen this in other posts. I would have thought OMV-Firstaid would have
    this built into it to change resolution but it doesn't. Evidently it's assumed that most monitors should be able to sync to it. Anyway it's really just an annoyance.

  • Yeah...But when I went to save it with Nano it couldn't because console-setup is a directory not a file...At least it is on my installation...I checked...
    Just a bunch of files with .sh extension in it.

  • Yeah...But when I went to save it with Nano it couldn't because console-setup is a directory not a file...At least it is on my installation...I checked...
    Just a bunch of files with .sh extension in it.

    ?( I looked at mine via WinSCP from my windows machine and used notepad ++, but I've just done ssh from the same machine and executed nano /etc/default/console-setup and this was the output.


    console setup.PNG

  • I can't show you now as it's 2:12AM here...OMV Server is off and I'd have to wake the wife to turn it on...
    But I can assure you console-setup is a directory on my installation...It's in /etc.


    I'm just up late watching WWII in the Pacific in COLOR on the Smithsonian Channel.


    Autonegotiate doesn't do squat...Controls cannot compensate enough either.


    I'll check again in etc/default tomorrow....Thanks.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!