Why should you use or not use dockers

  • I don't know why I didn't finish porting it. Looking at my commits on github, it looks like it is mostly done. I will check it out.

    I know you and I have discussed this before, but please consider porting the OpenVPN plugin. Even if it's just by writing a wrapper script to call the shell script as we discussed earlier. :)
    I would do it myself, but school work is taking up all of my time.

  • I know you and I have discussed this before, but please consider porting the OpenVPN plugin. Even if it's just by writing a wrapper script to call the shell script as we discussed earlier

    How do we knew easyrsa3 works on Debian Buster?

    omv 5.6.6 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.1
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Doesn't this imply that it does? - pack

    That would imply that I use openvpn and can answer that. The plugin doesn't use that package and I have no idea what Debian changes in the script to create the package. Can you tell I don't like porting plugins I know nothing about?

    omv 5.6.6 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.1
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • I'm confused. What package creation are you talking about?

    You linked to the easy-rsa package from the buster repo. That is the package I am talking about. The openmediavault-openvpn plugin does not use that package. It downloads the easy-rsa script from the repo.


    I was not aware that you did not know anything about the plugin.

    Other than accepting pull requests and fixing minor things that people point out, I have never really worked on it. I think it was way too complicated for just setting up vpn. The wireguard plugin is much simpler and should be the way to go.

    omv 5.6.6 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.1
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • It is in the repo now.

    Thanks! I've given it a try and it looks to be broken -- in the same way it was on OMV4.


    I have a new OMV5 install, haven't done much to it other than update to OMV5.1, switch to pve kernel, install a ZFS and anacron plugins -- but I'm not seeing anacron appear in the WebUI under Scheduled Jobs (same as on OMV4).


    root@OMV:~# dpkg -l | grep anacron
    ii anacron 2.3-28 amd64 cron-like program that doesn't go by time
    ii openmediavault-anacron 5.0 all anacron plugin for OpenMediaVault.


    root@OMV:~# ls -l /var/www/openmediavault/js/omv/module/admin/system/cron/
    total 24
    -rw-r--r-- 1 root root 11850 Sep 3 03:15 Anacron.js
    -rw-rw-r-- 1 openmediavault-webgui openmediavault-webgui 10949 Apr 25 2019 Cron.js


    Any thoughts?

  • I've given it a try and it looks to be broken -- in the same way it was on OMV4.

    I have no idea what that means. I didn't know the OMV4 plugin was broken?? My test VM is working fine...


    omv 5.6.6 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.1
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • please consider porting the OpenVPN plugin

    It is ported enough that it installs and enables. I can't do any testing beyond that. It is in the testing repo. If anything is wrong beyond this, you will need to fix it.

    omv 5.6.6 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.1
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • It is ported enough that it installs and enables. I can't do any testing beyond that. It is in the testing repo. If anything is wrong beyond this, you will need to fix it.

    Okay, thank you for verifying. When the insanity of this semester settles, I will experiment with OMV5 and try to figure out what, if anything, is broken.

  • I mean that it is not appearing in the OMV WebUI, in the same way as it wasn't working on OMV4 in the thread I linked:
    Anacron plugin not displayed?

    I can't explain this one. I will post on the other thread.

    omv 5.6.6 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.1
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Hi guys,


    what’s the easy way to renew LetsEncrypt cert in Docker ?


    I think this is the solution:

    Code
    docker logs -f letsencrypt

    OMV v5.0
    Asus Z97-A/3.1; i3-4370
    32GB RAM Corsair Vengeance Pro

    Edited once, last by tinh_x7 ().

  • openmediavault-docker-gui - moved to omv-extras to install portainer

    Hi ryecoaaron,

    Just wanted to confirm what you meant by this?

    I want to upgrade from 4 to 5 but wondered what I should do with Docker... I have docker-gui installed and docker-ce ticked in omv extras repo.

    Not sure if your comment/statement means that I should do something with Docker before upgrading from 4 to 5? i.e. With the usual upgrade method suggested by yourself in the other OMV 5.0 Finally Out thread!

    Thanks so much! :-)

    Will.

    OMV 5. ASRock J5005-ITX, Crucial 8GB Kit (4 GB x 2) (DDR4, 2400 MT/s). Fractal Design Node 304. Crucial BX500 128 GB system drive. 4 X WD Red 6 TB. 2 X 8 TB external Western Digital Elements USB.

    Edited once, last by willsy555 ().

  • The upgrade script will uninstall the plugin and then you can install portainer from omv-extras once you are upgraded to OMV 5.x.

    omv 5.6.6 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.1
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!