Network not configurable for OMV4 on Raspberry Pi

  • Hi,


    I installed OMV on my Pi, and everything seems to work fine.
    But my network card does not show up on the networks page.
    And when I add it because I want to add static addresses for IPv4 and IPv6, then an error pops up when I press Apply:


    Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C; systemctl start 'networking' 2>&1' with exit code '1': Job for networking.service failed because the control process exited with error code.See "systemctl status networking.service" and "journalctl -xe" for details.


    No matter what I change, I always get this message until I delete the network card again.
    I tried both Ethernet and WLan, but it always ends up in getting this message.


    ?(?(?(

  • There's a couple of things to do if you haven't already done so; set the date and time...Time zone as per Time Zone enable ntp server>>>Time server pool.ntp.org then update now.


    Update management and select and install all updates....reboot when finished.

  • if you've downloaded the OMV raspberry pi image of sourceforge, the OS is armbian.
    Use the config tool on the commandline: armbian-config
    There you can set the IP.


    Another way to do it: assign the IP address in the DHCP server of your router, by MAC address.
    You'll have to reboot the raspberry pi (maybe even multiple times), before it picks up the new IP.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!