VirtualBox - can't import or export, error rc=0x80070057

  • Hi All,

    I just added the VirtualBox plugin to my OMV 4.1.12 machine in order to run a small Debian x64 VM. It seems ok but I can't import or export anything.

    Initially, I wanted to move a VM over from a VMWare server that I want to shut down, but VirtualBox wouldn't import the OVF, gave 'VirtualBox error: rc=0x80070057'. So I created a new VM and installed Debian 9.5 from scratch; that's up and running fine, but now I want to make a backup copy of it. I shut down the VM and tried to export it, but hit the same error 'VirtualBox error: rc=0x80070057'. :(

    I've attached the full error output (it's too big for a forum post); I can't work out from it what's causing the problem, but perhaps someone can...

    Has anyone run into problems with VBox on OMV 4?

  • Weird. I just installed VBox 4.2 on my Windows PC and imported that same VM without any problem. It's up and running fine there. Tried to export it from the Windows PC and load that OVF into the OMV VBox and it failed with the same error message as previously. There's definitely something odd about the OMV VBox installation. It's not permissions on the OVF, I checked those, and I can create VMs locally ok just not import or export.

  • I've found nothing online that helped.

    Further testing shows that:
    - VMWare VM will import to VBox on Windows but not on the OMV system;
    - VBox VM created in Windows won't import to OMV VBox;
    - VBox on OMV can create a VM but can't export it.

    If I get time, I'll boot up a physical Ubuntu machine and try to run VBox on that, see what happens. Will have to go looking for a VBox forum to ask on, too - seems like the OMV folks just packaged it up.

  • Ok, I got around it, at least the import part...

    I copied the VM files from VMWare directly into the VBox VMs folder, then rather than 'import', I used 'Add" to include them in VBox. That worked!
    I still can't export them to take a backup, but that's a different issue and as they're sitting on a OMV server, I guess I can just copy the raw files as a crude workaround.

  • Hey Jefft, I have done some research to help you out in fixing can't import or export, error rc=0x80070057. I guess you should just move the VirtualBox folder with the virtual machines to a new location with the help of File Explorer. Just find the VirtualBox folder in your Documents folder or in case you are not able to find it then check File > Preferences > General > Default Machine Folder. Make sure that the VirtualBox VM Manager is exited and all VMs are offline so you could move the VirtualBox folder to the new location with File Explorer. Try this site to get to know more. Here open the VM Manager and clear all VMs that are highlighted as unavailable. Press the CTRL key, tap all VMs, and then right-click and choose the option that says Remove. Now tap File > Virtual Media Manager and delete all hard drives, optical disks, and floppy disks. At the end just go for all the folders in the new VirtualBox directory in File Explorer and double-click the VBOX file to import the VM and change the Default Machine folder that is below File > Preferences > General.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!