Docker plugin - After the last update it does not start

  • Seeing this too :(


  • Managed to fix it by replacing "-H fd://" with "-H unix://" in /etc/systemd/system/docker.service.d/openmediavault.conf

    #metoo


    thanks for the tip. Could docker to run again :thumbsup:

    OMV-Server-HW: MoBo Fujitsu D3417-B2 (Intel-LAN), Intel Xeon E3-1245 v6 Kaby Lake (4x3.70GHz), 16GB-Ram ECC UDIMM, 1x512GB SSD Samsung 850 Pro (sda2 - 30GB system, 4GB swap, sda5/rest - for work), 1x 10TB WD Red Pro, 1x 3TB WD Red (both basic setup) - Digibit R1 Sat-IP-Server with SatIP-Axe-Firmware


    OMV-Server-SW: Debian Buster with Proxmox kernel (always up-to-date), OMV v5 (always latest), omv-extras-plugin (always latests), AutoShutdown-Plugin, Docker with PlexMediaServer, TVHeadend, any many more


    BackupServer: Synology DS1010+ with 4GB Ram, 9TB@SHR (different hdd's), DSM 5.2-5967-2

  • still error Failed to stop docker.socket: Unit docker.socket not loaded.


    DId the change but still getting the error:
    Can you please explain the whole steps like disable plugin, modify the line, enable plugin?


    Still getting:


    Source Code
    Edit Source Code

    • Error #0:
    • OMV\ExecException: Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C; systemctl stop 'docker.socket' 2>&1' with exit code '5': Failed to stop docker.socket: Unit docker.socket not loaded. in /usr/share/php/openmediavault/system/process.inc:182
    • Stack trace:
    • #0 /usr/share/php/openmediavault/system/systemctl.inc(86): OMV\System\Process->execute(Array, 5)
    • #1 /usr/share/php/openmediavault/system/systemctl.inc(153): OMV\System\SystemCtl->exec('stop', NULL, false)
    • #2 /usr/share/omvdocker/Utils.php(92): OMV\System\SystemCtl->stop()
    • #3 /usr/share/omvdocker/Utils.php(531): OMVModuleDockerUtil::stopDockerService()
    • #4 /usr/share/openmediavault/engined/rpc/docker.inc(1205): OMVModuleDockerUtil::changeDockerSettings(Array, 42005, '/srv/dev-disk-b...')
    • #5 [internal function]: OMVRpcServiceDocker->setSettings(Array, Array)
    • #6 /usr/share/php/openmediavault/rpc/serviceabstract.inc(123): call_user_func_array(Array, Array)
    • #7 /usr/share/php/openmediavault/rpc/rpc.inc(86): OMV\Rpc\ServiceAbstract->callMethod('setSettings', Array, Array)
    • #8 /usr/sbin/omv-engined(536): OMV\Rpc\Rpc::call('Docker', 'setSettings', Array, Array, 1)
    • #9 {main}


    openmediavaulkt.conf looks like:


    Source Code
    Edit Source Code

    • [Service]
    • EnvironmentFile=-/etc/default/docker
    • ExecStart=
    • ExecStart=/usr/bin/dockerd -H unix:// $DOCKER_OPTS \
    • $OMVDOCKER_API \
    • $OMVDOCKER_IMAGE_PATH


    Thanks for your help!

  • For me the problem the mentioned change fixed the issue that the service did not start.


    So now the docker service is OK again.


    The openmediavaut-docker-gui is still having problems but all my containers are running again.
    Maybe you have the same problem?


    For me after changing the conf-file I had to run:
    service stop docker
    systemctl daemon-reload
    service start docker


    And to check if that helped
    docker container ls

  • Thanks for your help but it's still not working:


    container ls:
    CONTAINER ID IMAGE COMMAND CREATED STATUS PORTS NAMES


    When enabling plugin i get:


    Code
    Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C; systemctl stop 'docker.socket' 2>&1' with exit code '5': Failed to stop docker.socket: Unit docker.socket not loaded.

    Is there a way to completly and clenly uninstall docker?

  • I did an uninstall and reinstall for the openmediavault-docker-gui via the "Erweiterungen" page in the omv-gui. Should be "Add-Ons" or similar.
    But that threw some errors for the openmediavault-docker-gui ("Bad Gateway").


    Maybe you could try it as well.
    Uninstall
    Reinstall
    "service docker stop"
    make the change to the conf-file
    "systemctl daemon-reload"
    "service docker start"
    "docker container ls" (after giving some time to start the containers and if no errors accured)


    At least this is what I did after getting the same errors as you before.
    But I am not sure what exactly helped here.

  • Getting this when reinstalling plugin:


    No luck with your steps :-(


    Thanks for your hint

  • Hi,


    I have the same problem.


    Docker is started, all containers are up and running. Docker can not be activated in the GUI.


    Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C; systemctl stop 'docker.socket' 2>&1' with exit code '5': Failed to stop docker.socket: Unit docker.socket not loaded.

  • Actually none of my dockers are running.


  • The same here, docker is up and running with all the containers but I cannot manage it with the GUI due to that error.


    It seems that omv cannot execute: systemctl stop 'docker.socket' but is ok if you try with systemctl stop 'docker' from cli

  • My test machine is still working. I will need to try to replicate this. No need to update that people's systems aren't working until I look into this more. No idea what update did this but it isn't the plugin.

    omv 5.5.2 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.3.3
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!