SMB share visible to Mac but contents not shown

  • Hello all,

    My SMB share folders are visible to my Macintosh (macOS Mojave 10.14.1) but the contents are not. I do not understand why and it's driving me mad! The same folders are visible from a Linux client without problems.

    To keep things simple, I've enabled Guest access to the SMB share. This removes the possibility or errors with setting folder permissions.

    On the Mac, the OMV4 server is visible on the network, as are all the SMB shares (including the newly-created Guest one). Navigating to the share (expecting to see files inside it) generates the following error:

    The operation can't be completed because the original item for <folder_name> cannot be found.

    I get the same error whether I navigate to the share via the Finder, or use Go > Connect to server > smb:ip_address

    I feel like I have tried everything, including the detailed steps described in this post, but am no closer to finding a solution.

    Is it possible that the format of the NAS hard drive could have something to do with this? It's EXT4 and I know that Macs will not usually read/write to this. I thought that SMB made the source disk format irrelevant to the client.

    Has any Mac user successfully shared NAS drive folders using OMV? If so, then how? OMV4 is running on a RaspPi3.


  • What are the actual filesystem permissions of the directory?

    Google is your friend and Bob's your uncle!

    OMV AMD64 5.x on ASRock Rack C2550D4I C0 Stepping - 16GB ECC - Silverstone DS380 + Silverstone DS380 DAS Box.

  • I have a similar issue connecting a SMB share with user restrictions.

    The setup:

    • OMV4 (4.1.26-1) with two ext4 formatted external USB3 connected HDDs
    • Four shared folders:

      • Two as Time Machine targets (each a separate partition/file system) on first HDD
      • Two SMB targets on the second HDD (one single partition/file system with two folders on root)
    • The Time Machine shares are accessible for everyone (guest write)
    • The SMB targets are accessible for everyone (only guests are allowed)

    The setup works perfectly fine, I am backing up two Macbook Pro via Time Machine. And I can access the SMB shares from Macs, iPhones and from a network printer.

    Now I wanted to extend the setup with an additional SMB shared folder on the second HDD (besides the existing SMB shares), but this time restricted to a single user. So I did the following:

    • Create a user via the OMV GUI (member of users)
    • Create the share via OMV GUI (default permissions for administrators [rw], users [rw] and others [r])
    • Set privileges (not ACL) of the new share to [rw] for the new user
    • Added the share to the SMB shares as non-public (no guests either)

    The new share is visible on my Mac, even if I connect as guest to the server. Of course guest cannot access, due to missing permissions.

    But even if I connect using the user credentials of the new user, I will not get access. I am getting the same error message as above:

    The operation can't be completed because the original item for <folder_name> cannot be found.

    I tried to add [rw] permissions for the new user at ACL but this will not change anything.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!