Plex installed through docker giving transcode error

  • Making the move from OMV plugins to docker after upgrading to 4.x and I've installed Plex however when I attempt to play media files I'm prompted with this error. Not too sure if this is related to fstab being nonexec instead of exec, but after attempting to edit /etc/openmediavault/config.xml with my miserable knowledge of Linux I'm left at a dead end. Am I missing something?



    Cheers

  • I like media servers they give so much information as to why something didn't work :D


    Do a forum search re the transcode and the fstab change, I know something requires a change in fstab, but you shouldn't need to edit the config.xml


    I see you have posted in here are you using windows or linux on workstation or laptop?

    Raid is not a backup! Would you go skydiving without a parachute?

    Edited once, last by geaves ().

  • Ssh'd into my server using nano /etc/openmediavault/config.xml found the nonexec entry deleted it and plex is now working as expected.


    HP Microserver running OMV 4.X

  • Ssh'd into my server using nano /etc/openmediavault/config.xml found the nonexec entry deleted it and plex is now working as expected.


    HP Microserver running OMV 4.X

    If you have done that you may need to do this from that other thread, as a reboot may just add it back to the config.xml

    Raid is not a backup! Would you go skydiving without a parachute?

  • Rebooted this morning the fix worked for plex however I still cannot get openvpn-as to start (running in docker) and as suspected cat /proc/mounts reveals that the noexec flag still exists for openvpn "shm /var/lib/docker/containers/92d26173f5b1ee6d8b79f0410fbc827eb43b3377bbeb95b4b41293f9e7e9edf1/mounts/shm tmpfs rw,nosuid,nodev,noexec,relatime,size=65536k 0 0"


    Can't find it using sudo /etc/openmediavault/config.xml


    any other way I would edit "shm /var/lib/docker/containers/92d26173f5b1ee6d8b79f0410fbc827eb43b3377bbeb95b4b41293f9e7e9edf1/mounts/shm tmpfs rw,nosuid,nodev,noexec,relatime,size=65536k 0 0" to remove the noexec?


    Cheers for all the patience with me :)

  • Can't find it using sudo /etc/openmediavault/config.xml

    That's correct, I have just watched @TechnoDadLife video regarding the noexec, there are clearly three options for this to work,


    1) Remove the noexec from config.xml
    2) From the cli omv-mkconf fstab
    3) Reboot


    Once completing 1, 2 is a must do otherwise the fstab will remain the same and therefore I'm surmising the tmpfs will generate the noexec flag.


    If you do cat /proc/fstab does noexec appear on any of your mounted drives? If it does then I would suggest start at 1 and work through.

    Raid is not a backup! Would you go skydiving without a parachute?

  • Werid removed the noexec as shown in his video but openvpn-as still refuses to load, searing /etc/openmediavault/config for any remaining noexec comes back with nothing.


    Tried to edit using nano /proc/mounts but it will not save.

  • # /etc/fstab: static file system information.
    #
    # Use 'blkid' to print the universally unique identifier for a
    # device; this may be used with UUID= as a more robust way to name devices
    # that works even if disks are added and removed. See fstab(5).
    #
    # <file system> <mount point> <type><options> <dump><pass>
    # / was on /dev/sdb1 during installation
    UUID=dba17307-0229-4ed5-8a06-eabc61835be7 / ext4errors=remount-ro 0 1
    # swap was on /dev/sdb5 during installation
    UUID=77c49c88-28b5-4b03-88ab-0118f12927fb noneswapsw0 0
    tmpfs /tmptmpfs defaults0 0
    # >>> [openmediavault]
    /dev/disk/by-label/Media /srv/dev-disk-by-label-Media xfs defaults,nofail,usrquota,grpquota,inode64 0 2
    # <<< [openmediavault]

  • Tried to edit using nano /proc/mounts but it will not save.

    It won't save because it's a tmpfs.


    Well the fstab is clear, the only thing I can suggest is to delete the container Openvpn-as and start again

    Raid is not a backup! Would you go skydiving without a parachute?

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!