Not Able to Configure Remote Nextcloud

  • I figured it out... I used another forms setup for letsencrypt, my certificate had www in it. Once I copied what Virgil screenshot in his previous post, I edited letsencrypt to not have www in the certificate and voila, works like a charm jesus, a whole 24 hours to get this up and running. booja, thanks for everyone previous posts, feels amazing to get this working. I was giving myself one more day, otherwise I was going back to my ubuntu manual setup for nextcloud.. lol
    Thanks guys!! Amazing work!!

  • Thanks so much, I could not get the config right from techno dad, read forum after forum. Kept on being met with the welcom screen of nginx.
    I redid everything, started from scratch setting up each container as per this thread by changing my OMV port, and setting up letsencrypt as host. Once I got my certificate right then all good all round.
    Thanks for the feedback, really appreciate it.

  • I follow the same video as most of you, i didnt do the --netowrk my-net but i connected the networks up top to my-net so that letsencrypt and nextcloud used same my-net i think, they are listed in the containers.. i added them if that makes sense. I forwarded the ports in router. Letsencrypt successfully makes certs, adds to key folder. My problem is i get the unsafe address page when i got to
    other than that i get the nextcloud login etc, but i have to click on the proceed anyways.. and site insecure.. jargon. what am i doing wrong ty.

  • macom yes ive tried allt hat, i even started over from scratch same result. not sure why the certificates keep showing with the wildcard in them when i inspect. Im guessing thats the issue? i ran it through the whypadlocked site it passed all checks except the middle 2 dealing with the ssl domain. I now am trying to not mess with the configs too much and just use

    I have the duckdns running in a docker, as well as letsencrypt and nextcloud. 3 seperate dockers. I have connected up top in docker under the network tabs, i made the bridge network by, docker network create my-net.. then i connected letsencrypt and nextcloud to said network. They are both listed.

    But i am still trying. I am new to all this docker and learning quite a bit though through your guys videos and knowledge base. TY all for what you do. This will be an awesome home server once im done with the software side of it haha

  • is your duckdns adress in the trusted domains section of the config.php ?
    Something like this?

    array (
    0 => '',
    1 => '',

    and also is letsencrypt defined as trusted proxy?
    'trusted_proxies' => ['letsencrypt'],

  • hey morlan thanks for the reply i do not have the letsencrypt set in will try that now. everything works as far as site pulls up i get the reverseproxy and all, it just gives the ssl warning not secure webpsite.. ive tested with whynopadlock and just says cert is self signed. ive dleted all of letsencrypt and started from scratch following video and then i connect it all works just that no padlock up top. I also went back to the subdomains=false and just and followed the video. except i found a few hints and all. i have no network for the containers. i did not do my-net this time. What i ended up doing was using host, and setting omv on a different port. as that had worked for someone else.

    this is what cert says.

    no difference when i set the trusted proxies. same result page loads liek normal i get login page and all just not secure.

    here is padlock now im getting another error.. about not forcing https.. that used to be green check mark. the 2 below have been persistent throughout.

    maybe its the domain mismatch im not understanding that.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!