Unofficial Plugin Repo for 0.5 Sardaukar, 1.0 Kralizec, 2.0 Stoneburner, 3.0 Erasmus, 4.0 Arrakis

  • It's not working for me also, if "installed" over WebGUI, with dpkg it's working. This could have some reasons:
    1. remove the /etc/apt/preferences.d/99omv-plugins-org file. Can add it to the next version of the script - or Volker does it in his next version.
    2. the upgrade-clean script moves the /etc/apt/sources.list.d/openmediavault-local.list because without it, the old plugin-debs showed up after upgrade. Maybe someone could look into the file and checks, whats the content. I deleted mine, after running 0.5.0.24 for two weeks without errors ;)

  • Quote from "ryecoaaron"

    I upgraded from 0.4 to 0.5 on a few systems but I didn't use omv-plugins.org on those systems. Can you show me the output of:


    ls -al /etc/apt/preferences.d/


    I'm thinking we might need the upgrade script to remove the /etc/apt/preferences.d/99omv-plugins-org file and run apt-get update afterwards.


    ls -al /etc/apt/preferences.d/


    Code
    total 16
    drwxr-xr-x 2 root root 4096 Aug 31 13:08 .
    drwxr-xr-x 6 root root 4096 Aug 15 20:00 ..
    -rw-r--r-- 1 root root 44 Oct 24 2011 99openmediavault-local
    -rw-r--r-- 1 root root 44 Aug 25 11:28 99openmediavault-local.pref
  • I guess I will have to do some more testing. I just ported the old plugin. So, they are doing the same thing. I will also have to check to see the difference between how OMV installs it vs dpkg.

    omv 5.5.2 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.3.3
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Hello I have migrated from 0.4 to 0.5.


    I try to use the pluggins and I have do the next:


    From console I execute

    Code
    root@openmediavault:/tmp# wget http://omv-extras.org/debian/pool/main/o/openmediavault-omvextrasorg/openmediavault-omvextrasorg_0.5.2_all.deb


    Code
    dpkg -i openmediavault-omvextrasorg_0.5.2_all.deb

    and its result




    I see in the http gui and the openmediavault-omvextrasorg 0.5.2 is installed but the OMV-Extras.org plugin is installed and empty (see attachment), and I can not see the extra plugging (transmission pluggin for example).


    I look the openmedia pakages with this command


    Do you know if I need to install any more to install extra pulgging?


    Regards,


    Julio.

  • The only plugin you should see besides omvextrasorg is openmediavault-processlist.


    Greetings
    David

    "Well... lately this forum has become support for everything except omv" [...] "And is like someone is banning Google from their browsers"


    Only two things are infinite, the universe and human stupidity, and I'm not sure about the former.

    Upload Logfile via WebGUI/CLI
    #openmediavault on freenode IRC | German & English | GMT+1
    Absolutely no Support via PM!


    I host parts of the omv-extras.org Repository, the OpenMediaVault Live Demo and the pre-built PXE Images. If you want you can take part and help covering the costs by having a look at my profile page.

  • Quote from "Solo0815"

    It's not working for me also, if "installed" over WebGUI, with dpkg it's working. This could have some reasons:
    1. remove the /etc/apt/preferences.d/99omv-plugins-org file. Can add it to the next version of the script - or Volker does it in his next version.
    2. the upgrade-clean script moves the /etc/apt/sources.list.d/openmediavault-local.list because without it, the old plugin-debs showed up after upgrade. Maybe someone could look into the file and checks, whats the content. I deleted mine, after running 0.5.0.24 for two weeks without errors ;)


    I'm not able to replicate the problem though. Hopefully it is fixed.

    omv 5.5.2 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.3.3
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • I wasn't able to install from the Web-UI. y setup is an upgrade from omv 4 that had the additional repo for omv 4. I had all the default plugins available to me, but I would download then install the new repo and it would not show up. I tried multiple times and tried updating as well. I checked, etc/apt/sources.list.d after the failed updates and omv-extras-org-sardaukar.list was not there just the default OMV one. Under etc/apt/preferences.d/ I did have 99omv-plugins-org.


    I ended up just downloading it and installed it through dpkg and it worked fine and then showed up in the Web-UI after a refresh.

  • I installed the 0.5.2 version by webUI and nothing apperared; i tried 0.5.4 and still nothing.


    I didn't unistall 0.5.2 before 0.5.4 because it's not in the plugin list. I did nothin by CLI.

  • Quote from "coogh"

    I installed the 0.5.2 version by webUI and nothing apperared; i tried 0.5.4 and still nothing.


    I didn't unistall 0.5.2 before 0.5.4 because it's not in the plugin list. I did nothin by CLI.


    Did you try this after the fix in your other thread?

    omv 5.5.2 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.3.3
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Have just upgraded to 0.5.8 from the latest 0.4 version and am having problems installing this plugin. I ran the 0.4 -> 0.5 clean up script immediately after the upgrade as I had problems displaying the gui but all seems fine now.


    Using Chrome on my Mac, I click upload and select the download plugin deb file, I see this path in the "Upload plugin"

    Code
    C:\fakepath\openmediavault-omvextrasorg_0.5.4_all.deb


    I hit OK and it says uploading plugin and checking but I see no new plugins. On Firefox + Windows, I just see this path after selection:

    Code
    openmediavault-omvextrasorg_0.5.4_all.deb


    and this error when hitting OK

    Code
    {"success":true,"responseText":null}window.onbeforeunload = function() {}


    I have cleaned the browser cache for both tests ..

  • Usually you run the script before the upgrade but you can run it after. For some reason, the plugin doesn't always install from the web interface. I'm still looking into it. I would try the following as root:

    Code
    reboot
    wget http://omv-extras.org/debian/pool/main/o/openmediavault-omvextrasorg/openmediavault-omvextrasorg_0.5.4_all.deb
    dpkg -i openmediavault-omvextrasorg_0.5.4_all.deb
    apt-get update


    Is everything working now?

    omv 5.5.2 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.3.3
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Quote from "ryecoaaron"

    Usually you run the script before the upgrade but you can run it after


    I forgot that virtualbox was not an official plug :(


    Quote from "ryecoaaron"

    For some reason, the plugin doesn't always install from the web interface. I'm still looking into it


    Is the issue related to the strange "fakepath" selected file name?


    Quote from "ryecoaaron"

    Is everything working now?


    All is fine now, I can see the OMV-Extras.org entry under System :)


    However, when I installed openmediavault-processlist, all I got when logging in was a white screen even after rebooting. I had to run apt-get remove openmediavault-processlist to get the GUI back to normal


    Many thanks for your help!


    You have no idea when VirtualBox may return to 0.5 do you?

  • Quote from "ianch99"

    Is the issue related to the strange "fakepath" selected file name?


    This is an extjs thing. Nothing to worry about.


    Quote from "ianch99"

    However, when I installed openmediavault-processlist, all I got when logging in was a white screen even after rebooting. I had to run apt-get remove openmediavault-processlist to get the GUI back to normal.


    Did you try clearing the browser cache or hitting refresh before removing it?


    Quote from "ianch99"

    You have no idea when VirtualBox may return to 0.5 do you?


    No. It is a very difficult plugin to port to 0.5. If you need it, I would stay on 0.4. I am staying 0.4 at home for the same reason.

    omv 5.5.2 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.3.3
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • There is not a MYSQL plugin for .5 yet. For people using a lot of plugins I would recommend waiting to upgrade to .5. There is only the processlist plugin currently for .5. We are close to autoshutdown and minidlan plugins. It will take time to port them all.

  • Quote from "thefunkygibbon"

    I'm using MySQL plugin for my XBMC database. Also running sickbeard/sabnzb/couchpotato.


    will i be affected by upgrading to 0.5?


    You can always manually install MySQL. It's a really easy install, just google for instructions.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!