Unofficial Plugin Repo for 0.5 Sardaukar, 1.0 Kralizec, 2.0 Stoneburner, 3.0 Erasmus, 4.0 Arrakis

  • If you are happy with the current install of OMV 0.4.xxx then I agree with tekebebe and suggest staying with it.


    Keep up with what is happening with 0.5 though.

  • Updated to 0.5 Sardaukar, and authorization in web climbed error =)
    Cleaned the system script from Solo, and ok work ;)Everything worked as it is necessary - and minidlna working with the transmission (but not displayed in the web INTERFACE).
    And the devil possessed me I do not need to remove forkeddaapd via Web INTERFACE - and then it is silently removed and minidlna and transmission. = (


    Set your repository in a ssh (via the Web INTERFACE he did not want to be installed) - but only appeared in plugins omvextrasorg , processlist and supportinfo.
    Swearing swearing ... picked through ssh as there was seen a list of applications including minidlna and transmission. eventually aptitude blizzard made them-_-.
    And only then noticed:


    Quote

    openmediavault-supportinfo - shows support information that moderators on this forum may ask you for (tab in System Information).
    openmediavault-minidlna - in progress
    openmediavault-autoshutdown - in progress


    Mark "in progress" in bold! :)

  • The minidlna plugin will be released in the next few days. It will be beta quality but it is the beginning of a slow process of porting the plugins.

    omv 5.4.7 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.3.3
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Quote from "ryecoaaron"

    The minidlna plugin will be released in the next few days. It will be beta quality but it is the beginning of a slow process of porting the plugins.


    If people really need DLNA and .5 for some reason... they can install Mediatomb (and use it's webUI) until DLNA for OMV is done. Same with Transmission... just use the webUI for transmission-daemon.. until it's done for OMV.


    Personally, .4 is running so well for me, I'd just assume not mess with it right now.. but I'll upgrade to .5 eventually

  • OMV 0.5 is or was the big preperation (porting the whole GUI to ExtJS4.2 etc. pp.) that Volker needed to do before he could migrate OMV to Debian Wheezy with 0.6. The Plugin API should now be stable and only a few things may need to be changed when porting to 0.6. So the transistion to 0.6 should go way faster then the one from 0.4 to 0.5.
    So please give the Plugin Developers time to port the plugins to 0.5 while Volker is already working on 0.6 and support us with testing when more and more Plugins get updated to 0.5


    Greetings
    David

    "Well... lately this forum has become support for everything except omv" [...] "And is like someone is banning Google from their browsers"


    Only two things are infinite, the universe and human stupidity, and I'm not sure about the former.

    Upload Logfile via WebGUI/CLI
    #openmediavault on freenode IRC | German & English | GMT+1
    Absolutely no Support via PM!


    I host parts of the omv-extras.org Repository, the OpenMediaVault Live Demo and the pre-built PXE Images. If you want you can take part and help covering the costs by having a look at my profile page.

  • I'm getting 404's when I try to get the plugin. This is what I get when I tried it thru a Putty session:
    root@OMV:~# wget http://omv-extras.org/debian/p…mvextrasorg_0.5.4_all.deb
    --2013-09-16 10:37:37-- http://omv-extras.org/debian/p…mvextrasorg_0.5.4_all.deb
    Resolving omv-extras.org... 75.100.121.227
    Connecting to omv-extras.org|75.100.121.227|:80... connected.
    HTTP request sent, awaiting response... 404 Not Found
    2013-09-16 10:37:38 ERROR 404: Not Found.


    root@OMV:~# dpkg -i openmediavault-omvextrasorg_0.5.4_all.deb
    dpkg: error processing openmediavault-omvextrasorg_0.5.4_all.deb (--install):
    cannot access archive: No such file or directory
    Errors were encountered while processing:
    openmediavault-omvextrasorg_0.5.4_all.deb
    root@OMV:~# apt-get update

    OMV 4.1.0-1 Arrakis running on:
    IBM System x3400 server
    Dual Xeon 5110 1.6Ghz CPUs
    4Gb RAM
    40Gb IDE System drive
    8-2Tb Data HDDs

  • See last post above! They changed version-number! This will work...


    To install:


    1 - Download the plugin to enable this repository here.
    2 - Go to the plugin tab in OMV's web interface.
    3 - Upload the file.
    4 - Select the newly uploaded plugin openmediavault-omvextrasorg
    5 - Click on Install.
    6 - Refresh page.
    7 - Go to the plugin tab and click Check.


    -or from command line as root-


    Code
    wget http://omv-extras.org/debian/pool/main/o/openmediavault-omvextrasorg/openmediavault-omvextrasorg_0.5.5_all.deb
    dpkg -i openmediavault-omvextrasorg_0.5.5_all.deb
    apt-get update
  • Quote from "Dennis"

    wget http://omv-extras.org/debian/p…diavault-omvextrasorg_0.5.4_all.deb


    ...is not working. We're at 0.5.5 - correct first post please.


    BTW: If there is a 0.6 with new api - will it be easy do deinstall or do we need another script???


    Forgot to change first post. Changed now.


    I don't know about 0.6. The change from 0.5 to 0.6 is supposed to be from Squeeze to Wheezy. The api is supposed to be stabilized now.

    omv 5.4.7 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.3.3
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Thanks Dennis. I couldn't seem to get it to work when using the Web Interface, but was able to do it from the command line.

    OMV 4.1.0-1 Arrakis running on:
    IBM System x3400 server
    Dual Xeon 5110 1.6Ghz CPUs
    4Gb RAM
    40Gb IDE System drive
    8-2Tb Data HDDs

  • Hello,


    Happy to see minidlna is back !


    For information, if it could help other, I had a little issue. After installing minidlna, 0.5.4, it was running but my share folder was gone. If I tried to add theim, I had this message :


    Code
    Erreur #3002: exception 'OMVException' with message 'Failed to set configuration' in /usr/share/openmediavault/engined/rpc/minidlna.inc:278
    Stack trace:
    #0 [internal function]: OMVRpcServiceMiniDlna->setShare(Array, Array)
    #1 /usr/share/php/openmediavault/rpcservice.inc(125): call_user_func_array(Array, Array)
    #2 /usr/share/php/openmediavault/rpc.inc(62): OMVRpcServiceAbstract->callMethod('setShare', Array, Array)
    #3 /usr/sbin/omv-engined(495): OMVRpc::exec('MiniDlna', 'setShare', Array, Array, 1)
    #4 {main}


    Even if I remove minidlna with the plugin management interface, and reinstall it, the problem was still present.


    So I completely remove it (in terminal mode) with :

    Code
    apt-get remove --purge minidlna

    (as root)


    After this I reinstall it on the web interface and I could restore my share folders !!


    Thanks a lot for your work on openmediavault, my NAS love you !!


    Yayel


  • The config is slightly different than the 0.4 version. So, that is why removing the old version completely works. Good to know though :)

    omv 5.4.7 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.3.3
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Quote from "AniPlus"

    Very need transmisisonbt


    Not an easy plugin to port and since I don't use it, it makes it tougher to port. It will take time...

    omv 5.4.7 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.3.3
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!