SMB copy speed not stable, Win7/Ubuntu18.10 to smb share on Odroid HC1

  • Dear community,


    I'm a omv newbie.


    I''ve setup an Odroid HC1, omv4 image on µsd card and a MX500 ssd.
    The HC1, Windows 7, Ubuntu 18.1 are connected to a gigabit switch (cat 5e/6 cables).


    I face the issue that the write speed from Win/Ubuntu is not stable, sometimes the files are transferred with 103MB/s an then just with some 1-10MB/s.
    Here's an example while copying a vmware vm, see attached jpg.


    I tried different setting in but nothing what fixed it, this is the current 'extra options'
    min receivefile size = 16384
    write cache size = 524288
    getwd cache = yes
    socket options = TCP_NODELAY IPTOS_LOWDELAY
    use sendfile = yes
    protocol = SMB2


    Next i tried to configure IRQs to big cpu and the govener to conservative/performance.
    Same issue sometimes the files are transferred like a charm and then like 10y ago. :(


    Any help or lead is really appreciated.
    I cannot judge if it's a hw/sw issue.



    omv_starter

  • Take a look at this post with common problems. Tuning Samba is item 5 but, as I understand it, Samba has been pre-tuned in SBC images.


    Where are you copying to/from? That appears to be a Windows VM..?
    If you're running tests, perhaps you should copy to/from a client running on real hardware. VM performance can be "iffy".

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!