Docker-gui error 3

  • I installed Docker-gui from web interface ,installed fine,but when i try to use it i get


    Error: "" - Code: 3



    Error #0:
    OMVModuleDockerException: Error: "" - Code: 3 in /usr/share/omvdocker/Utils.php:74
    Stack trace:
    #0 /usr/share/omvdocker/Utils.php(430): OMVModuleDockerUtil::doApiCall('http::/networks')
    #1 /usr/share/openmediavault/engined/rpc/docker.inc(1057): OMVModuleDockerUtil::getNetworkList()
    #2 [internal function]: OMVRpcServiceDocker->getNetworks(Array, Array)
    #3 /usr/share/php/openmediavault/rpc/serviceabstract.inc(123): call_user_func_array(Array, Array)
    #4 /usr/share/php/openmediavault/rpc/rpc.inc(86): OMV\Rpc\ServiceAbstract->callMethod('getNetworks', Array, Array)
    #5 /usr/sbin/omv-engined(536): OMV\Rpc\Rpc::call('Docker', 'getNetworks', Array, Array, 1)
    #6 {main}





    Any ideas?

  • Looks like it may not have completely installed and/or the service isn't running. Might need to clear your browser cache too.

    omv 5.5.17-3 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.4.2
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Not exactly the same problem but don't want to spawn another docker install topic.


    Got error during the install of openmediavault-docker-gui 4.1.1 from WebUI - guess some dependency check but I don't know how to fix it:

    Primary: Odroid-HC2 (ARM) + Seagate 6TB HD, OMV 4.1.17, omv-extras 4.1.13
    Backup: Odroid-HC2 (ARM) + Seagate 4TB HDD at remote location via Duplicati(??)


  • Running OMV 4.1.17-1 on Odroid HC2, omvextrasorg 4.1.13, stable omv-extras.org repo and Docker CE repo are enabled under OMV-Extras menu.
    Any help is appreciated, thanks!

    Primary: Odroid-HC2 (ARM) + Seagate 6TB HD, OMV 4.1.17, omv-extras 4.1.13
    Backup: Odroid-HC2 (ARM) + Seagate 4TB HDD at remote location via Duplicati(??)

  • W: GPG error: ppa.launchpad.net/kyle1117/ppa/ubuntu cosmic InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 3028C3C96AD57103

    and remove the ppa, if you want to avoid this warning

  • Looks like it may not have completely installed and/or the service isn't running. Might need to clear your browser cache too.

    i completly removed docker-gui..docker service enabled and running ,also cleared cache
    but there is one question..docker network interface should be shown in openmediavault-gui in network interfaces?

  • docker network interface should be shown in openmediavault-gui in network interfaces?

    No. It should show up on the dashboard network information because it has an IP address but it shouldn't be in the network setup tab.

    omv 5.5.17-3 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.4.2
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • remove the backports line from /etc/apt/sources.list and then

    apt-get update
    apt-get -f install openmediavault-docker-gui


    via Putty worked for me, thanks!



    plugin installation via OMV GUI goes in auto mode and selects N (default), I chose Y in Putty, Docker plugin now is in the list at OMV GUI and no errors pop-ups.

    Primary: Odroid-HC2 (ARM) + Seagate 6TB HD, OMV 4.1.17, omv-extras 4.1.13
    Backup: Odroid-HC2 (ARM) + Seagate 4TB HDD at remote location via Duplicati(??)

  • well..back to my problem :)
    i installed omv4 on usb to see if is working out of the box docker plugin
    well,is working
    if i am not wrong..i hope i am not,only thing i ve changed betwen these 2 instalations was curl
    one,on working system shows me
    curl 7.52.1 (x86_64-pc-linux-gnu) libcurl/7.52.1 OpenSSL/1.0.2q zlib/1.2.8 libidn2/0.16 libpsl/0.17.0 (+libidn2/0.16) libssh2/1.7.0 nghttp2/1.18.1 librtmp/2.3Protocols: dict file ftp ftps gopher http https imap imaps ldap ldaps pop3 pop3s rtmp rtsp scp sftp smb smbs smtp smtps telnet tftp Features: AsynchDNS IDN IPv6 Largefile GSS-API Kerberos SPNEGO NTLM NTLM_WB SSL libz TLS-SRP HTTP2 UnixSockets HTTPS-proxy PSL
    and the one wich isn t working is
    curl 7.63.0 (x86_64-pc-linux-gnu) libcurl/7.63.0 OpenSSL/1.0.2q zlib/1.2.8 librtmp/2.3Release-Date: 2018-12-12Protocols: dict file ftp ftps gopher http https imap imaps pop3 pop3s rtmp rtsp smb smbs smtp smtps telnet tftp Features: AsynchDNS IPv6 Largefile NTLM NTLM_WB SSL libz TLS-SRP UnixSockets HTTPS-proxy


    can curl version/features affect omv web interface or i am wrong..?


  • I have the same problem as x3m444. I did not understand how to fix it. Please help.


  • What is the output of dpkg -l | grep docker?

    ~# dpkg -l | grep docker
    ii docker-ce 5:19.03.4~3-0~debian-stretch armhf Docker: the open-source application container engine
    ii docker-ce-cli 5:19.03.4~3-0~debian-stretch armhf Docker CLI: the open-source application container engine
    ii openmediavault-docker-gui 4.1.5 all OpenMediaVault plugin for Docker

  • Looks correct.


    What is the output of systemctl status docker?


    Images are OK
    lsioarmhf/nextcloud, lsioarmhf/mariadb, httpd .....
    But when you create a container, the error message comes

  • Sorry, no idea how to solve the root problem. Some ideas as work aroung:

    • reinstall docker-gui
    • switch to portainer; you can use portainer in parallel to docker-gui, after installation it will show you current dockers, you can change them and add new ones

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!