Plex direct play keeps buffering / stuttering

  • I am using Plex media server (Version on OMV 4.1.17-1 Arrakis (on RockPro64) connected via ethernet (500Mbps connection)/ HDD plugged in via SATA. The setup was built recently and worked flawlessly for a week.

    Since today every movie i tried playing off plex be it on my Samsung Smart Tv / via the mobile app / streaming to Chromecast nothing seems to work. Playing the movies on my windows computer via VLC /win media player have no issues.

    The movie starts playing and after couple of minutes gets stuck with the loading/busy sign and does not resume.. Tried uninstalling / reinstalling the plex plugin , and setting up all database / libraries fresh and analyising etc and still facing the same issue.

    how should i resolve this , ive tried all the formats available in my library and all are having the same issue , checked the plex dashboard to see if the movies are being transcoded but its confirmed that they are being direct played.

    Spent the whole day figuring out if there is a solution ?

    Need some help pls..

  • As you describe it it would seem that there is some problem with how you connect to the TV. In what way does that differ from how you connect to your PC?

    One obvious problem could be that you use a slow WiFi connection to the TV. That might be fixed by upgrading your WiFi network or reconfiguring it. Possibly moving APs/routers/repeaters. However this has nothing to do with OMV.

    Be smart - be lazy. Clone your rootfs.
    OMV 5: 9 x Odroid HC2 + 1 x Odroid HC1 + 1 x Raspberry Pi 4

  • Just to clarify. You can stream the media fine from plex to the PC, but not from plex to the TV?

    If that is the case then there should be nothing wrong with the server or plex. The connection to the TV should be the problem. Check/swap cables and switches. And if possible reduce the length and number of cables/switches.

    Be smart - be lazy. Clone your rootfs.
    OMV 5: 9 x Odroid HC2 + 1 x Odroid HC1 + 1 x Raspberry Pi 4

  • How is your chrome cast connected? Is it Wi-Fi or Ethernet?
    I’ve always found buffering issues with plex and wifi enabled tvs (eg. For bluray remuxes).
    Also sometimes the tv doesn’t have all the correct decoders (I’ve had better success with Apple TV or raspberry pi over Ethernet ).

  • hi Chromecast is on wifi.. after several attempts (knowing that similar setup worked before without buffering, I decided to flash OMV fresh on my boot and redo the whole setup... and plex is surprisingly working fine again... on Chromecast, TV and all devices... i can't seem to understand what went wrong with my earlier setup... will keep using and post if I face the issue again.

    appreciate the tips :)

  • I have same issue, though using Plex in Docker, version is newer.
    It is still unclear whether the problem is in network, Plex or OMV. But since direct play via VLC via sftp works almost perfect, I believe it is problem with Plex itself.
    Will investigate further this weekend.

  • hi Robbin,

    since my last post on which I mentioned of a clean installation of the omv image, I have had no issues so far . plex has been working flawlessly ..

    you say you are on docker, trust the transcoding paths have all been configured correctly? I tried docker and gave up due to this reason of confusing customization of folders and transcoding issues I faced..had to revert to Plex plugin after searching through many forums on the topic..

    hope you have a solution soon mate..


  • I was very lucky with Google search today, one guy on Plex forums mentioned that he had the same problem due to HDD power management.
    Checked mine, everything was turned off. Set it to maximum performance and 60 minutes spindown time. Since then playback on 2 devices simultaneously works flawlessly (for 15+ minutes :))
    This is actually surprising as during problems with playback I had several torrents being downloaded. Can the HDD spindown between data writes? Sounds crazy to be honest, that's why I didn't suspect HDD.
    For reference, I'm using Nanopi M4 with old Seagate usb3 1tb HDD.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!