Error msg while installing docker plugin

  • log in on the console or via ssh as root


    apt-get update
    apt-get upgrade
    apt-get dist-upgrade


    when that's all done, apt-get -f install


    The docker plugin install was (not sure if it still is) was broken.


    That should fix the problem.

  • It worked !!!!! Thank you.


    Boy would I not been able to do this on my own...


    Since I'm new to this and not an linux pro: wouldn't it been possible to do this through GUI (remote access)? I thought I had update/upgrade OS and plugins before asking online...

  • It worked !!!!!
    Boy would I not been able to do this on my own...


    Since I'm new to this and not an linux pro: wouldn't it been possible to do this through GUI (remote access)? I thought I had update/upgrade OS and plugins before asking online...

    You can update through the GUI under the "updates" section in the webUI... but update will not run the apt-get -f install command (that has to be done manually). I just had you run the other commands to make sure your system was completely up to date before fixing the docker plugin.


    Personally, I always update over command line (using the first 3 commands). Not really sure why, I just do.. even on my desktop/laptops that run Linux, and they all have GUI tools to update as well.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!