6TB WD Red in HC2 - am I definitely going to have problems with spindown?

  • Hi there,

    I had an exciting weekend setting up my new HC2 with a 6TB Red and everything seems to be working fine.

    I set the hard drive to spin down after 20 minutes and, this morning, I noticed that it was still spinning.

    I remember reading on here that there is a problem with some WD Hard drives and that I should use a different method for spinning them down.

    Is there a way to tell whether my particular set up is suffering from this problem?

  • If the spin doesn't spin down, and you set it to spin down, then you can take that as a sign that you have a problem.

    But also check that you don't run automatic SMART tests all the time. That may prevent the disk from spinning down.

    If it is a problem with your HDD not being compatible with hdparm (and it seeems that way) then disable all settings for "Physical Disk Properties". OMV use hdparm to set the properties. Or at least tries to.

    You can still change the spin down time for your HC2 (or HC1) by reflashing the firmware for the USB/SATA bridge:


    Most likely you don't need to upgrade the firmware, you are probably running the latest. But when flashing the firmware you can also set the spin down time.

    I set the spin down on my HC2s to 30 minutes.

    I did a quick Google search for "hdparm WD RED" and it seems that others also have problems with hdparm and WD RED.

    Be smart - be lazy. Clone your rootfs.
    OMV 5: 9 x Odroid HC2 + 1 x Odroid HC1 + 1 x Raspberry Pi 4

  • Thanks Adoby.

    The weird thing is - I used exactly the same hard drive on my other x86-based OMV server and spin down seemed to work fine, then.

    Having moved it to the HC2, I wasn't sure whether there was am OMV setting that was slightly different, whether it was a software issue (I am now running Emby on the HC2, which I did not run on the x86 server) or whether it was a hardware issue.

    I am wondering whether it might just be easier to do what you have mentioned above, anyway, just to make absolutely sure.

  • Perhaps it's a combination hdparm, USB/SATA bridge and the HDD that cause the problems with spin down and Physical disk properties?

    I just happened to figure out that if I stay away from changing any of the Physical disk properties, my HC2s are fine with my HDDs. Without setting the spin down when reflashing the firmware my HDDs spun down after about 2-3 minutes. A bit too fast for me.

    Be smart - be lazy. Clone your rootfs.
    OMV 5: 9 x Odroid HC2 + 1 x Odroid HC1 + 1 x Raspberry Pi 4

  • Thanks Adoby - I am going to try this out tonight.

    I have had a look at that link you posted and I am slightly worried that I might do something wrong and brick my new HC2.

    Can I just check, that I need to do the following as root when connected via ssh:

    wget [url]https://wiki.odroid.com/_media/odroid-xu4/software/jms578fwupdater.tgz[/url]

    [b]tar[/b] xzf JMS578FwUpdater.tgz

    cd JMS578FwUpdater

    -d /dev/sda -f ./JMS578_Hardkernel_v173.01.00.01.bin -b ./backup.bin -t 30

    Is this correct?

  • It looks jumbled, EDIT: You fixed it while I was writing and eating dinner... ;)

    Note: You need to have a HDD attached.
    Note: It is assumed that this is run as root in the folder /root.

    Be smart - be lazy. Clone your rootfs.
    OMV 5: 9 x Odroid HC2 + 1 x Odroid HC1 + 1 x Raspberry Pi 4

  • Thanks Adoby - after all that, I still accidentally copied the wrong the line from the link and accidentally enabled SATA hot plugging (what a fool I am!).

    Took me a while to realise what I did and disabled it again and used the correct one - hard drive now successfully set to shutdown after 20 mins.

    I see what you mean about hdparm and WD Red drives.

    This was very interesting:


    Do you think the first issue would be a cause for concern? I recall that also have some WD Reds - did you check whether they have the latest firmware?

  • Check the SMART values to see if the Load Cycle Count increase after spin downs.

    I didn´t understand why this is a failure when the drive has spun down actually? In this case the heads should be unloaded to the parking position of course. I always thought the heads are unloaded while the drive is constantly spinning its platters. This then leads to a heavily increased load cycle count. The solution was to avoid high frequent head unloading while the drive is spinning.

    OMV 3.0.99 (Gray style)
    ASRock Rack C2550D4I C0-stepping - 16GB ECC - 6x WD RED 3TB (ZFS 2x3 Striped RaidZ1)- Fractal Design Node 304

  • I have to admit that I am not sure about exactly why increased Load Cycle Count is bad.

    However I know that it is possible to have the HDD spin down without increasing the Load Cycle Count.

    I assume that it is a little like the difference between a full shutdown and restart and a waking up from standby.

    I didn't find it difficult to get my HDDs to spindown without increasing the Load Cycle Count. All I had to do was update the firmware on my HC2.

    I am not at all sure that the arms are parked the same when my HDDs spin down or when they are powered off. In fact I assume that they are not. I assume that the arms are in a safer position when the HDD is powered off than when it has only spun down.

    Be smart - be lazy. Clone your rootfs.
    OMV 5: 9 x Odroid HC2 + 1 x Odroid HC1 + 1 x Raspberry Pi 4

  • I have to admit that I am not sure about exactly why increased Load Cycle Count is bad.

    Manufacturers usually give a hard drive a maximum number of load cycle counts (about half a million if I remember correctly) and they consider it bad to go above that rating.

    omv 5.5.5 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.3.5
    omv-extras.org plugins source code and issue tracker - github

    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Thanks TKaiser - very sensible advice.

    Unfortunately, further to my original post, I am still unable to get my disk to spin down.

    I successfully flashed the software, turned the HC2 off (and unplugged it for a good couple of minutes) and turned it back on.

    The green LED stayed constantly on (showing no HDD activity) but the HDD just never stops spinning. I tried flashing again and still the same.

    This is really peculiar - everyone else, who uses the firmware, seems to get immediate results.

    I was tempted to just leave things, but that sort of defeats the purpose of my getting the HC2 in the first place (i.e. to save energy).

    Is there anything else that "could" be stopping the firmware from allowing the disk to spin down?

  • Try turning off SMART monitoring and testing.

    Another (remote) possibility is that you by mistake specified 0 minutes spin down. If you used the -t flag wrong somehow. Or used conflicting flags.

    You should examine the output very closely when flashing.

    Be smart - be lazy. Clone your rootfs.
    OMV 5: 9 x Odroid HC2 + 1 x Odroid HC1 + 1 x Raspberry Pi 4

    Edited 2 times, last by Adoby ().

  • Thanks Adoby - I shall have another go with the SMART the monitoring and testing turned off, as suggested.

    I did check that the output was:

    Update Firmware [b]file[/b] name: ./JMS578_Hardkernel_v173.01.00.01.binBackup Firmware [b]file[/b] name: ./backup.binAuto spin-down timer: 20 min.Backup the ROM code successfully.Programming & Compare Success!!

    So the HDD is definitely set to spin down after 20 minutes.It must, as you say, be something else that is preventing it from doing so.I shall revert, after a bit more testing.

  • Typically it is some software or activity that keeps the hdd spinning. There is another thread here with similar problems. They renamed /sbin/parted. But I don't understand why that would make a difference.

    The only other possibility that I can think of, is that the hdd has some changed stored settings. It might be possible to send commands to the HDD to reset it to standard parameters. A long shot...

    Be smart - be lazy. Clone your rootfs.
    OMV 5: 9 x Odroid HC2 + 1 x Odroid HC1 + 1 x Raspberry Pi 4

  • I am running TVHeadend and Emby-Server on the HC2, so I am wondering whether one of those is causing the issue.

    Is there a way to see when a particular service has been accessing the hard drive?

    Out of interest, do you also happen to know what the flashing green led means? I thought it meant any hard drive activity, but it could just mean writing to the disk.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!