No space left on device, but share has over 900 GB of free space...

  • I recently tried to move a file from one share to another by using the mv command line as root in a terminal window, but was met with "No space left on device message" and the file wasn't moved. On my Mac, when I drag the same file from a share to another, the following message pop up: "The operation can’t be completed because the disk “Media” is full"

    OMV System Information>Performance Statistics>Disk Usage reports that I have 928 GB left on the share, the file I am trying to move is less than 1 GB.
    I have tried to delete a few files from the share to free even more space, but that space doesn't become available for some reason. All the other files on the share, mostly movies and music, are totally readable. The second share that I have works normally, I can move files to it with no problem.

    I googled the issue but don't seem to get anywhere. Has anyone ever experienced anything similar? I don't know how to fix this.
    The only changes that I made to OMV recently were to upgrade packages pushed though updates and create a few new Docker containers.

    A few info on my system:
    OMV 4.1.17-1
    The destination share is made of 2 drives of 2 and 4 TB respectively, both drives are pooled using Union Filesystems (create policy: Existing path, most free space, Minimum free space 550G, options: defaults,allow_other,direct_io,use_ino)
    The shares are SMB/CIFS and I haven't changed their settings for a long while.

    Thank you in advance for any suggestion you may have to help me solve this!

  • please revise your share on OMV.

    must be /yourdisk/yourmountoint/yuorshare,

    if you share /yourdisk/yourmountoint you have errors like described because free space is not the free space on your data drive is the free space on your boot drive.

    PD: Post more info and screen captures of your share to revise it.

  • Hi raulfg3,

    Thank you for your reply and trying to point me to a direction.
    I tried to rebuild the share (without deleting content from the drive) making sure it followed the pattern /mydisk/mymountoint/myshare, but it didn't solve the problem.

    I thought then the issue could be with the pool of drives under the Storage>Union Filesystems because 1 of the 2 drives I used in the pool had less space than the minimum free space I had in the settings originally. I tried to amend the minimum free space, but OMV returned an error message and did not apply the lower minimum free space.
    I then decided to rebuild the pool, by deleting the existing and creating a new one with a lower minimum free space. I got an error message again. I thought at this moment a reboot was going to help, but, after reboot, I wasn't able to connect to the OMV interface anymore...

    I had a backup which I restored with clonezilla. But the original issue was still there: there was no space left on device

    Is there an easy way to amend the minimum free space limit in Union Filesystems?
    I reinstalled OMV in the end, set up the Union Filesystems with a lower minimum free space limit and all is working fine now.
    So, I assume that my issue was likely to be the Union Filesystems minimum free space limit since the 2 hard-drives constituting the pool had the exact same content than with the older pool.

    Problem solved in the end. But the hard way...

  • Union Filesystem and other FS DO not balance data ( if one of your HD is full, do not move data to other with free space automatically), you need to balance by hand.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!