wrong raid5 size

  • hello everybody,
    some days ago a disk disappeared from my array.
    I physically unplugged and plugged the bay and the disk re-appeared.
    I've rebuild the raid but the size is strange: max size 50.94 TiB.
    It should be 56 TiB.
    Tnx for help.


    Here the details:


  • In the lines I see he speaks well of 8 disks but he also speaks of a spare disk, the problem would not come from there ?
    7 discs + 1 spare

    Code
    # definitions of existing MD arrays
    ARRAY /dev/md0 metadata=1.2 spares=1

    My configuration :



    AMD Ryzen 5 2400G on Asus TUF B450M-PLUS - 8Gb RAM - 3 * 3To RAID5 on LSI Megaraid SAS 9260-8i and 3 SSD in Fractal Design Node 804 Black
    OS: OMV 4.1.26-1

    Edited once, last by Methy ().

  • thanks methy.
    i've changed mdadm.conf

    Code
    # definitions of existing MD arrays
    
    
    #ARRAY /dev/md0 metadata=1.2 spares=1 name=pandora:pandora UUID=d0b3aec7:c1f299e7:73df4dd8:e3c26eba
    ARRAY /dev/md0 level=raid5 num-devices=8 metadata=1.2 name=pandora:pandora UUID=d0b3aec7:c1f299e7:73df4dd8:e3c26eba


    then


    Code
    update-initramfs -u && reboot

    same problem.
    I don't know... I've a lot of space available.
    I don't wont to make some mistake and lost data...

  • When you go in raid management do you have a spare disk ?



    If yes try to grow the raid.

    AMD Ryzen 5 2400G on Asus TUF B450M-PLUS - 8Gb RAM - 3 * 3To RAID5 on LSI Megaraid SAS 9260-8i and 3 SSD in Fractal Design Node 804 Black
    OS: OMV 4.1.26-1

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!