External SSD not detected!

  • Morning,

    So I've been struggling to get OMV running on my Pi 3 for a day or so now, various errors have been holding me back, but it seems I have finally gotten it some what working. The only issue now is that I have a samsung 850 evo 500gb SSD connected via a USB 3.0 external hub, and the drive down now display on OMV web interface. The power indicator light is on, so it's receiving power, and i'm using an ipad PSU for the cable (2.5A 5.2V) which i'm certain is of good enough quality to supply enough power, any ideas at all guys?

    thanks in advance, Doobie.

    USB hub is listed on amazon, not sure if i can post an amazon link on here so here is the listed name "Sabrent 2.5-Inch SATA to USB 3.0 Tool-free External Hard Drive Enclosure [Optimized For SSD, Support UASP SATA III] Black (EC-UASP)"

  • i'm using an ipad PSU for the cable (2.5A 5.2V)

    Which cable? And what's the hub for?

    In case you're able to login locally it would be great if you could provide output from armbianmonitor -u and a few lines output from raspimon while you unplug the external HDD, then wait 10 seconds and replug it again.

  • I have tried 2 different cable, a PS4 charger cable, and a Samsung phone charger cable, both decent quality with no damage.

    Output from armbianmonitor -u reads: http://ix.io/1xUW

    output from raspimon reads:
    Time Temp CPU fake/real Health state Vcore
    11:52:35: 50.5'C 1200/ 600 MHz 1010000000000000101 1.2V
    11:52:40: 50.5'C 1200/ 600 MHz 1010000000000000101 1.2V
    11:52:45: 49.9'C 1200/ 600 MHz 1010000000000000101 1.2V
    11:52:50: 50.5'C 1200/ 600 MHz 1010000000000000101 1.2V
    11:52:55: 50.5'C 1200/ 600 MHz 1010000000000000101 1.2V
    11:53:00: 50.5'C 1200/ 600 MHz 1010000000000000101 1.2V
    11:53:05: 51.5'C 1200/ 600 MHz 1010000000000000101 1.2V
    11:53:10: 50.5'C 1200/ 600 MHz 1010000000000000101 1.2V
    11:53:15: 50.5'C 1200/ 600 MHz 1010000000000000101 1.2V

    the above starts with the SSD plugged in, I then unplugged and re-plugged.

  • Also I'll list below the installation process I've followed up to yet if it may help you find the error.

    • Download latest ISO for raspberry pi
    • Extract using winrar
    • flash to SD using balenaEtcher
    • first boot and allow to restart
    • after restart login to web interface
    • change default password and auto logout disable
    • permit root login for SSH
    • in putty, connect to pi, run the following commands:
      • apt-get update
      • dpkg --configure -a (did not work first time, had to reboot due to an error, then it worked)
      • apt-get upgrade
    • Enable docker in OMV extras, then update button at top
    • install plugins shellinabox and docker
    • no packages listed in 'update management' so ignored doing this, even after 'check'
    • go to 'disks', only sd card listed no external drive.
    • removed external drive and plugged in regular USB drive, this is recognised in disks, although if i try and create a file system no disks come up in the drop down list.

    Think I have included my entire process here hopefully not missed anything.

  • 11:53:15: 50.5'C 1200/ 600 MHz 1010000000000000101 1.2V

    Your powering is not sufficient at all, you're CONSTANTLY (even with no load) undervolted (input voltage below 4.67V): New approach for Raspberry Pi OMV images

    Debug output shows this too (RPi folks added this warning fortunately a while ago): [ 2.071510] Under-voltage detected! (0x00050005)

    Problem: the RPi hardware is crappy (powering through Micro USB, all USB ports behind an internal USB hub), average SBC users don't want to understand Ohm's law and RPi manufacturer taking care that those users never will get it (they babble about amperage ratings but don't educate their users that cable quality and voltage drop is the important part).

    You need to fix powering first but I would better fix the whole RPi problem by replacing it with something more reliable and performant...

  • So it turns out if i unplug the stupid RGB keyboard I was using (I know stupid) it detects the drive, my only issue now is if i go to file system, and create a new one, when i click the drop down box no drives appear, any idea what may be wrong?

  • So it turns out if i unplug the stupid RGB keyboard I was using (I know stupid) it detects the drive

    Nope, that just changes the symptoms. You're suffering from undervoltage and as long as you do not solve this problem you'll never get any stable drive access.

    USB is one of the most horrible ways to access storage (especially with cascaded hubs in between like in your setup). If you then add powering problems it simply can't work.

    You need something more reliable than a Raspberry Pi or at least a stable power source (that includes the cable between PSU and device -- and only those PSUs with a fixed cable are known to provide a high enough voltage at the receiving end. Your iPad charger is most probably not the culprit but the Micro USB cable)

  • You have to mount the filesystem

    Then next stop will be 'filesystem corruption'. It's impossible to continue without fixing the powering problems first. And unfortunately input voltage can't be checked realiably on a RPi. It's some circuitry that should detect voltage drops below 4.67V (+/- 10% -- maybe it is 4.63V instead, don't remember exactly)

    So even if the undervoltage detection doesn't get triggered input voltage could be as low as 4.5V and such a setup is just insane given that USB consumers need 4.75V minimum (but they're fed with the input voltage and there's an additional voltage drop between DC-IN and USB power lines).

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!