No files shown in shared folders - but in SMB?

  • Hi,
    I have a strange problem.


    I have several shares.


    If I go on terminal to /sharedfolders all folders are shown.
    If I enter one of the folders and type ls, no file is shown.


    I installed filezilla like here:


    If I go to "storage" in filezilla everything is shown.


    The files which are in a SMB share are working as expected.


    If I delete a share in "access rights management" (only the share, not the data), and add it new, it is working for now. But after a reboot I have the same problem again.


    I think something is wrong with the right...but can not find a problem here.
    Handy help would be greatly appreciated.


    Thanks.
    Fabian

    MoBo: Fujitsu D3417-B
    CPU: Intel Celeron G3900
    RAM: Samsung DDR4 - 8 GB ECC
    Case: Fractal Design Node 80
    HDD: SSD 64GB (System), 2*3TB+1*4TB (Data) + 1*4TB (Parity). UnionFS + Snapraid
    OMV 4
    Router: Fritzbox 7590

  • The files which are in a SMB share are working as expected.

    Did your SMB share configuration points to the right shared folder? I would assume that it points to a different location than /sharefolders/yoursharefolder. Maybe it points to /storage instead.

    OMV 3.0.99 (Gray style)
    ASRock Rack C2550D4I C0-stepping - 16GB ECC - 6x WD RED 3TB (ZFS 2x3 Striped RaidZ1)- Fractal Design Node 304

  • Did your SMB share configuration points to the right shared folder? I would assume that it points to a different location than /sharefolders/yoursharefolder. Maybe it points to /storage instead.

    Yes. It is the same folder...If I open the SMB settings I can only chose what it selected as share - right? I did not do anything outside the GUI of OMV.


    Strange.
    Fabian

    MoBo: Fujitsu D3417-B
    CPU: Intel Celeron G3900
    RAM: Samsung DDR4 - 8 GB ECC
    Case: Fractal Design Node 80
    HDD: SSD 64GB (System), 2*3TB+1*4TB (Data) + 1*4TB (Parity). UnionFS + Snapraid
    OMV 4
    Router: Fritzbox 7590

  • You are right.
    In the fielzilla install I put the direct folders of the fielsystem in. This is in /srv/.


    So this is clear that filezilla is showing everything.


    But why do I not see all my data in the sharedfolders?


    Have a look here:terminal output.PNG


    First you see what is in /sharedfolders/Medien ->nothing
    after this you see /srv/6932c4ba-438f-4cd1-a508-7e36b648ea5b/Medien ->all folders are listed



    How comes.


    It was different a while ago.
    ???


    Thanks.


    Fabian

    MoBo: Fujitsu D3417-B
    CPU: Intel Celeron G3900
    RAM: Samsung DDR4 - 8 GB ECC
    Case: Fractal Design Node 80
    HDD: SSD 64GB (System), 2*3TB+1*4TB (Data) + 1*4TB (Parity). UnionFS + Snapraid
    OMV 4
    Router: Fritzbox 7590

  • Please check your share folders configuration. If you create an Samba share (or any other share) a shared folder has to be selected which must be created previously. This shared folder must point to your folder directory e.g. /srv/6932c4ba-438f-4cd1-a508-7e36b648ea5b/Medien
    The issue must be found here someplace.

    OMV 3.0.99 (Gray style)
    ASRock Rack C2550D4I C0-stepping - 16GB ECC - 6x WD RED 3TB (ZFS 2x3 Striped RaidZ1)- Fractal Design Node 304

  • The strange thing is that the Samba share is working great. No problem here!


    Only in terminal there is the problem if I go to /sharedfolders.


    Normally this should not be a problem. But I want to Backup all shares with USB-Backup using this method:
    USB Backup Plugin: Backing up multiple shares with one Job


    This was working great...but now the links do not see my data any more...

    MoBo: Fujitsu D3417-B
    CPU: Intel Celeron G3900
    RAM: Samsung DDR4 - 8 GB ECC
    Case: Fractal Design Node 80
    HDD: SSD 64GB (System), 2*3TB+1*4TB (Data) + 1*4TB (Parity). UnionFS + Snapraid
    OMV 4
    Router: Fritzbox 7590

  • To make it clear what is happening.


    I see the shares - so the root of the share -> "Medien". But I do not see the included folders/files in my shares. So I do not think it is a problem with the share itself but with rights of the data in the share.
    Does this makes sense?


    Thanks.
    Fabian

    MoBo: Fujitsu D3417-B
    CPU: Intel Celeron G3900
    RAM: Samsung DDR4 - 8 GB ECC
    Case: Fractal Design Node 80
    HDD: SSD 64GB (System), 2*3TB+1*4TB (Data) + 1*4TB (Parity). UnionFS + Snapraid
    OMV 4
    Router: Fritzbox 7590

  • Who should be the owner of all data in the shares if I want to use it flexible via Samba etc.?
    How should the rights be set?
    Thanks

    MoBo: Fujitsu D3417-B
    CPU: Intel Celeron G3900
    RAM: Samsung DDR4 - 8 GB ECC
    Case: Fractal Design Node 80
    HDD: SSD 64GB (System), 2*3TB+1*4TB (Data) + 1*4TB (Parity). UnionFS + Snapraid
    OMV 4
    Router: Fritzbox 7590

  • Here you see the problem quite well. This is from cloudcommander. Installed via docker with the tutorial from technodad.
    output cloud commander.PNGHope this helps.
    Left you see the /sharedfolders.
    Right you see the direkt link in the filesystem.
    Thanks.

    MoBo: Fujitsu D3417-B
    CPU: Intel Celeron G3900
    RAM: Samsung DDR4 - 8 GB ECC
    Case: Fractal Design Node 80
    HDD: SSD 64GB (System), 2*3TB+1*4TB (Data) + 1*4TB (Parity). UnionFS + Snapraid
    OMV 4
    Router: Fritzbox 7590

  • First you see what is in /sharedfolders/Medien ->nothing
    after this you see /srv/6932c4ba-438f-4cd1-a508-7e36b648ea5b/Medien ->all folders are listed

    Aah, there is some kind of sym link or bind mount between this two folders. I do not know cloudcommander nor the tutorial of technodadlife. Sorry.

    OMV 3.0.99 (Gray style)
    ASRock Rack C2550D4I C0-stepping - 16GB ECC - 6x WD RED 3TB (ZFS 2x3 Striped RaidZ1)- Fractal Design Node 304

    Edited once, last by cabrio_leo ().

  • So I tried to investigate more without using installed programs nobody knows ;-)
    The problem is this:


    I ad a new share via the GUI.
    I ad this share to the Samba shares.
    I copy some files to this share via Windows/Samba
    I can see the share and all data in this share via Windows and via SSH-Terminal as root.
    I reboot the system.
    After rebooting I see the share via Windows/Samba and SSH-Terminal.
    I see all data in the share via Samba/Windows.
    I see the share via SSH-Terminal as root
    I DO NOT SEE THE DATA IN THE SHARE VIA SSH-TERMINAL as root!!!


    So what is the problem here?!?!? I am lost!


    I create the share like this:
    Share.PNG
    And the Samaba Share like this:
    SMBShare.PNG


    Hope this helps to solve the Problem.
    Thanks.
    Fabian

    MoBo: Fujitsu D3417-B
    CPU: Intel Celeron G3900
    RAM: Samsung DDR4 - 8 GB ECC
    Case: Fractal Design Node 80
    HDD: SSD 64GB (System), 2*3TB+1*4TB (Data) + 1*4TB (Parity). UnionFS + Snapraid
    OMV 4
    Router: Fritzbox 7590

    Edited 2 times, last by FFrank ().

  • Hello,

    Has this issue ever been solved. Im running OMV 5 on a Raspberry Pi with similar issues - samba shares working fine until i reboot. Some shared folders do not appear and none are populated with data.

  • Hello,

    Has this issue ever been solved. Im running OMV 5 on a Raspberry Pi with similar issues - samba shares working fine until i reboot. Some shared folders do not appear and none are populated with data.

    Replying to a post that is well over a year old is generally not a good idea as much has changed in the software since then.


    If you are running OMV 5 (you should properly tag your posts) and you are looking in /sharedfolders/ any folders found there will not be populated. by default.

    --
    Google is your friend and Bob's your uncle!


    OMV AMD64 5.x on ASRock Rack C2550D4I C0 Stepping - 16GB ECC - Silverstone DS380 + Silverstone DS380 DAS Box.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!