Existing file on shared folder doesn't update ACL for new user.

    Found solution by myself.
    After re-read all function, I need to TURN ON Recursive function "Apply permissions to files and subfolders" on ACL Menu.

    Dear all,
    I'm new to OMV.

    I have issue on SMB function (Picture attached to give easier explanation).
    Originally, i set ACL for folder "QC-R2" to read only for some user, but NOT for user "omv-rnd" (still not configured at the beginning).
    There is already existing file named "Buku Laporan Refining II_2019.xlsx". It works & open normally to existing user with given ACL.

    At later time. I set permission for user "omv-rnd" to read only for the same shared folder.
    But, after giving that permission, user "omv-rnd" still cannot open the file mentioned above. Access is denied.
    However, he can see the folder and file list.

    After further investigation, it seems OMV doesn't update the ACL for already created file before on that shared folder. (see attached picture)
    I already test for check & uncheck the ACL setting for user "omv-rnd", hit APPLY / OK Button but still no effect.

    I have workaround to simply copy & paste file, then the ACL on new duplicated file is corrected for user "omv-rnd", BUT if there are already many file before, it will become a big issue for new user to access those file.

    Is it a bug ?
    Please give me solution to fix this issue.


Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!