Creating a second RAID makes the old one unrecognizable to omv

  • Hi there,


    I am having a weird problem. I had omv stoneburner installed and running for a long time with one mirror RAID on it and had no issues whatsoever. When i tried to add a second mirror everything went sideways. After the creation of this second array neither this new one or the old would show up in the omv webui. I managed to recover the data, it was still there just not showing up (i rebooted, reset to factory, nothing). I downloaded and clean installed the latest omv (arrakis) and rebuilt everything from scratch. After I initialized the second array.... both were gone, same as before. I logged in as root and tried to get mdadm to scan for any arrays. No result. I just get a new prompt as if I just pressed enter with no commands. If I do an --examine on the drives themselves it lists the array details with absolutely no errors but no --assemble attempt works. Tried swapping the drives between them, tried to do another clean install with the drives disconnected as per the upgrade tutorial hoping they would get recognized when I plugged them back in. No luck. My data is safely backed up so that's not an issue. I'm now just wondering whether to resign myself to using just one array or if there's some fix for this (providing it's not hardware related, not that I can figure how it could be)


    EDIT : actually, my problem looks a lot like this one : RAID gone from Webinterface after Updates/Adding new drive
    only, when i try to add the drives to any arrays i get an error stating that the drives are busy (yes, all of them) and rebooting doesn't help

  • Code
    Personalities : [linear] [multipath] [raid0] [raid1] [raid6] [raid5] [raid4] [raid10]
    md127 : inactive sdc[1] (S)
    2930135512 blocks super 1.2
    md0 : inactive sdb[0] (S)
    2930135512 blocks super 1.2
    unused devices: <none>

    I had to pull 2 drives, one from each array to keep a backup. My clean rebuild attempts were done with 2 loaned drives which I had to return in the meantime.


    What is wierd is that the md127 is the first array i built and which was identified as md0 at the time. The md0 you see now is the second array.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!