Windows 10 Build 1809 und OMV Shares sind in der Netzwerkumgebung verfügbar.

  • yes changing that policy setting now allows me access to the shares.

    I really hope you're aware what you did, why this setting is disabled by default and why it's called 'Enable insecure guest logons'.


    It's really sad that the Internet is full of such crappy tutorials recommending to weaken NAS security instead of doing the right thing and encouraging authenticated network share access instead. Microsoft clearly writes what a horribly bad idea this is:


  • Wie meinst du sollte installiert sein???
    Aktuell habe ich das Problem
    Per MiniDlna habe ich zugriff per fernseher und PC
    Per ip komme ins Menu des OMV
    Mit dem Laptop kann ich mit SMB zugreifen mit dem PC kommt Fehlermeldung:
    Es kommt die Meldung:
    Netzwerkpfad nicht gefunden
    Fehlercode 0x80070035

  • Du mußt dich per ssh mit der NAS verbinden. Unter Windows geht das z.B. mit cmd (standard terminal in windows) oder mit putty.


    In meiner SIgnatur ist der "user guide" verlinkt. Am besten darin nachlesen (nach Putty suchen).
    Der Guide ist ein guter Einstieg in OMV.

  • es ist halt komisch denn:
    Aktuell habe ich das Problem
    Per MiniDlna habe ich zugriff per Fernseher und PC
    Per ip komme ins Menu des OMV
    Mit dem Laptop kann ich mit SMB zugreifen mit dem PC kommt Fehlermeldung:
    Es kommt die Meldung:
    Netzwerkpfad nicht gefunden
    Fehlercode 0x80070035

  • There are many threads about issues to connect to SMB shares from Windows.


    Here is a fix that worked for me:
    Cannot access SMB shares


    If not, you might have to go through the rest of the thread and check if something else is helping.

  • Hi everyone (and happy new year) sorry to come back to this issue, please your input is very appreciated. I am not proficient in Linux but a power MacOS user and know my way around CLI a little but not expert in Linux commands.


    I read the thread (that's mostly in English) carefully and tested my setup before I am forced to ask your assistance.


    I just installed a clean version of OMV4 via USB boot image on my Core i3 mini PC, and then updated to latest 4.1.31 version prior to starting setting up anything than basic stuff was alreday. For now I am using DHCP until I decide the home static IP to use.


    Seems the later updates included the new wsdd service.


    During boot time and upon each reboot, before reaching the console login, I saw two errors: quotaon and wsdd.


    I was able to solve the quotaon problem but the wsdd keeps insisting failing upon boot. Funny thing is, after I login to console as root, if I run systemctl restart wsdd the service runs fine without exit error code; now systemctl status doesn't show "degraded" but "running".


    Any idea if this is due to the fact of not having a static IP yet? Perhaps the wsdd.service expects network to be up before running?


    My Beelink L55 mini PC has 2 LAN ports and the primary one (that's declared to OMV 4) is plugged to the router and working.


    If the DHCP temporary setting is not the cause for this effect described, is there a way to totally delay starting the wsdd.service ? Or perhaps run some kind of cron with parameters to run upon each reboot with a delay of say, 1 minute? I don't know exactly how Linux prioritises the services to run :-(


    Anyone can help me resolve this? If I reboot and don't run manually systemctl restart wsdd then it would remain as failed-to-start.


    Needless say that this nice wsdd service makes my MacOS detect on the network the OMV NAS immediately in Finder (i.e. the explorer) with a different icon, too. When I run it manually it appears instantly...


    Thanks


    EDIT: It seems with a local fixed IP in my home network, the wsdd service seems to launch just fine after each reboot; no errors recorded in the logs.

    OpenMediaVault OMV 4.1.34-1 on Beelink L55 - Intel i3-5005U - 8GB RAM - Crucial MX500 M.2 (2280) 1TB - Samsung 860 QVO (2.5") 2TB

    Edited 2 times, last by Konsti ().

  • I really hope you're aware what you did, why this setting is disabled by default and why it's called 'Enable insecure guest logons'.
    It's really sad that the Internet is full of such crappy tutorials recommending to weaken NAS security instead of doing the right thing and encouraging authenticated network share access instead. Microsoft clearly writes what a horribly bad idea this is:



    it was the only thing that would get it working. What else am I suppose to do I had asked the question before and on iirc and discord but no answers.

    OMV 3.0.58 - 64 bit - Nut, SABnzbd, Sonarr, Couchpotato
    HP N40L Microserver, 8gb Ram, 5 x 3TB HDD Raid5, 1 x 120GB 2.5" SSD (OS)

  • You might want to restate the problem. tkaiser is not posting on this forum anymore.

    basicslly couldn't access the shares from my windows 10 devices tried other suggestions from here and Google but nothing I tried would allow me to access till I changed the local policy mentioned.


    Oh did he leave the omv group?

    OMV 3.0.58 - 64 bit - Nut, SABnzbd, Sonarr, Couchpotato
    HP N40L Microserver, 8gb Ram, 5 x 3TB HDD Raid5, 1 x 120GB 2.5" SSD (OS)

  • till I changed the local policy mentioned.

    The Enabled policy is set by Enterprise and Education versions of W10, this prevents guest access to SMB shares within a Windows environment, to access the share the user is required to have an account on the machine hosting the SMB shares or in a domain environment the server is part of AD. In W10 Pro and Home it is set to Not Configured so should not be a problem.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!