Admin password stops working

  • So I have 4 different OMV boxes including two OMV 3.0.99 Dell Poweredge 840 boxes. 3.0.00 was the highest version that would work with their old Xeons.
    Anyway, one of these boxes, every so often when I try to logon it reports:

    Software Failure. Press left mouse button to continue. Incorrect username or password.

    They're local internal servers so I have the password saved in the browser, so I'm confident the password isn't wrong.

    At this point I can't recall whether restarting the system usually worked or if I end up going into omv-firstaid to reset the password (it's only been three times it's happened, separated by a month or more), but this time when I tried resetting the admin password in first aid it said:

    Updating control panel administrator password. Please wait ...
    ERROR: Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C; usermod --password '$1$5u.LtJx3$QwLg7JhxcPHj/.0wWVEr.0' admin 2>&1' with exit code '1': usermod: cannot lock /etc/passwd; try again later.

    Any idea what's going on? How to stop it perminently?? Is the password expiring or something and I'm just not getting notified or some other problem!?

    Thanks for any input or suggestions!

  • Have you tried changing the password for the user admin on the command line?

    Don't think that works... pretty sure you have to change it with omv-firstaid

    OP, using the command omv-firstaid (as root) at the command line, and then choose the "change control panel administrator password"

    Edit: Just read the rest of his post... I'd reboot the server then reset the password.

  • I just checked it:
    passwd admin works on the CLI

    But I was thinking along the same lines as well. (Reboot and immediately change the password.) Something may be locking or hanging up the admin account, that could be related to a GUI login attempt.

    Wow I never realized that regarding the password. (makes sense though).

    The password file is clearly locked for some reason, says so in the error...

  • Yea, I rebooted and it let me logon... within five minutes it said that the 'session credentials were invalid' or something like that and locked me out again. When I tried to log back on it gave me the original error. I looked at the server self and it showed disk errors, so I've pilled it and checked the drives, replaced the RAID card and giving it a new build. We'll see if it recurs.

  • This "seems" odd enough,, a successful login where credentials are invalidated afterward.
    The only items that comes close to this, in recent memory, were an unstable clock and an incorrect time zone selection in the browser, versus the OS - where an app session would time out, before it got started.

    One way or the other, please follow up and post again with the final result.

  • So I got OMV reinstalled and after the first successful boot up, I set the admin password and network settings via omv-firstaid, when I rebooted it showed three lines of errors (I/O errors) as it restarted. This the same physical server box, but a new RAID card for the drives, a new 16g USB stick for the boot drive and all hard drives checked and confirmed no bad blocks.
    Not knowing much about linux I'm assuming SD0 would be the USB stick? Maybe the USB port is bad? I uploaded a second screen cap from before the rebuild. This is what I had found when I went to look at the box after being locked out. These looked like actual disk errors, so I swapped out the raid card after finding no problems with the discs themselves.

    I did notice this time that the install did prompt me for whether I wanted to use UTC time, so I said yes, but don't know if it was just set to local time previously. That would explain the logon issue to some extent, and maybe I just have an additional unrelated issue with the usb?

    Anyway, if any of this makes any sense to anyone or adds up to something, please let me know!


  • Not knowing much about linux I'm assuming SD0 would be the USB stick?

    Your screenshots show IO errors with sr0 and sda1. Did you install from a SCSI CD-ROM drive (sr0)?

    BTW: 'session credentials invalid' as well as 'cannot lock /etc/passwd' might be the result of a damaged filesystem that has been set to read-only by the kernel to prevent further damage.

  • If the physical disks are OK, what could cause damage to the file system?

    Hardware (bad cabling, controllers going faulty, whatever). All hardware eventually dies.

    It's hard to diagnose anything from here since unfortunately the x86 OMV variants do not contain any debug tools that provide information (if you would run on an ARM based OMV installation I would've asked for armbianmonitor -u output now).

    I would look into dmesg output and /var/log/syslog and run various stress-ng and iozonetasks to identify weak spots.

  • In case things go weird again, please keep in mind that providing dmesg output here might enable others to help. Same goes for contents of /var/log/syslog. An easy way to provide both at an online pasteboard service is doing this:

    dmesg | curl -F 'f:1=<-'
    curl -F 'f:1=<-' </var/log/syslog

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!