Missing information from HDD

  • Hello. Please tell me what I can do. I have OMV 4.1.11.
    Yesterday I found out that information disappeared on 2 of 4 hard drives. On one completely all, the hard disk is empty, on the other there was only the information that was in the folders, everything disappeared from the root folder except the folders and the fact that inside them. ;(
    Can I somehow restore the information?
    Why could this happen? He did not exactly delete it.

  • There are (at least) two possibilities.


    1. The drive is no longer mounted. What you see is the just the empty mount point.


    Check in the GUI that all filesystems are mounted.


    If the HDD is bad or has errors it may not be mounted when the NAS is started.


    2. You are browsing the drive as a user that is not allowed to access the files.


    Install the plugin resetperms and run it on the offending shared folder from the Shared Folders tab.


    When I copy over files from some other source I often have to resetperms to make the files available for all users on the NAS.


    Normal settings are: User: root, group: users, rwx for owner and group. rx for others. (r=read, w=write, x=execute&open subfolders)

    Be smart - be lazy. Clone your rootfs.
    OMV 5: 9 x Odroid HC2 + 1 x Odroid HC1 + 1 x Raspberry Pi 4

  • Alas, not so simple.
    Mounted all drives. See all.
    And connecting through the SSH as a root, I see everything that is on them.
    But in the Web shell, and through Samba, I see terrabytes of free space appearing on the disks.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!