VLAN and static routes

  • I was able to finally get access to my VLAN interface on my OMV4 machine. Just for clarification, I placed OMV4 on my Proxmox host, and initially I was having issue creating the VLAN interface, but recently was able to ssh into the VLAN interface. The problem that I am having is getting a static route out. I have tried using the web interface as well as command line and no bueno.



    ens18 --> 192.168.30.50 [VLAN30] # Primary OMV4 interface
    ens18.40 --> 192.168.40.50 {VLAN40] # Docker VLAN



    I am able to ssh to the interface with no problems. But when connected to OVM, if I attempt to ssh to a host on my network, the command hangs. Also, I am not able to ping any host on my network. Interestingly enough, I can apt-get update and upgrade, so I am able to resolve names. I also noticed that my docker0 (172.17.0.1) interface is down as well. Granted that I would rather my docker containers worked on the 192.168.40.0/23 network, but it would be nice if the docker0 interface bridge worked as well. I have setup ip forwarding and iptables:



    Bash
    root@fs-01:~# sysctl net.ipv4.conf.all.forwarding=1
    net.ipv4.conf.all.forwarding = 1
    root@fs-01:~# iptables -P FORWARD ACCEPT

    But still no change. Any suggestions would be greatly appreciated.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!