physical disk properties Standby error

  • Hallo OMV,
    Ich betreibe OMV 4.1.19-1 auf einem RockPro64 mit der PCI-e to Dual SATA-II Interface Card und einer HDD Seagate IronWolf



    Mein Problem: Die Festplatte wechselt zu schnell in Standby Modus. Es dauert ca. 10/15 min. manchmal auch schneller 3/5 min. und die Festplatte wechselt wieder in Standby Modus obwohl 120 min. in physical disk properties eingestellt ist.


    Achte auf Datum / Uhrzeit. Festplatte sdb wechselt nach ca. 12 min. in Standbay Modus. :cursing:


    Andere Konsole Ausgabe:


    Bisherige versucht: Ein/Aus, wechselt der Spindown time in OMV physical disk properties auch immer wieder Neustart. KEIN ERGEBNIS.
    Somit wird die Lebensdauer verkürzt, wen der Festplatte immer wieder in Standbay Modus nach einer kurzer Zeit wechselt.
    Wo ist der Fehler, wie kann man es beheben? Bitte Hilfe!
    Vielen Dank.

  • Vielleicht gibt es auf der SATA-Karte eine Firmware, die die Platten in Standby schickt.

    Ich weiß es nicht, aber warum wird die zweite Festplatte > /dev/sda: WDC WD5000LUCT-63RC2Y0 mit fast den selben Einstellungen in physical disk properties nicht in Standby versetzt? Merkwürdig.


    Schau/frag mal im Pine64 Forum nach.

    Ein neues Thema / Anfrage im PINE64 Forum habe ich erstellt.
    Danke, ich hoffe es Antwortet jemand.

  • Falls keine bessere Idee kommt, könntest du noch hdparm deaktivieren und statt dessen hd-idle testen.


    Wie erwartet erhielt ich keine Antwort in dem "toten" Forum.
    Die einzige Antwort von einem guten Menschen vermutet das es am APM modes 127 liegt oder OMV Überwachens Tools was damit zu tun haben.


    Jetzt habe ich SMART für die Festplatte komplett deaktiviert und auf 128 gesetzt. > Keine Auswirkung gleiche Problem.


    Welches Tool steuert die Festplatten? Oder hat Seagate HDD seine eigene Regel zum steuern an/aus etc?
    Wenn das so weiter geht wird die Festplatte nicht mehr lange durchhalten.

  • Hallo,


    du könntest vielleicht mal versuchen, den APM-Mode auf einen Wert größer 127 zu stellen. Bis zu einem Wert von 127 bringt nämlich der APM-Mode die Platte in den Standby und zwar unabhängig von der konfigurierten Spin Down time. So verstehe ich das zumindest. Alle Werte größer 127 sind ohne Standby. Den Standby macht dann der hdparm.


    Das fand ich ganz interessant: Fix the hard drive killer APM

    OMV 3.0.99 (Gray style)
    ASRock Rack C2550D4I C0-stepping - 16GB ECC - 6x WD RED 3TB (ZFS 2x3 Striped RaidZ1)- Fractal Design Node 304

  • du könntest vielleicht mal versuchen, den APM-Mode auf einen Wert größer 127 zu stellen. Bis zu einem Wert von 127 bringt nämlich der APM-Mode die Platte in den Standby und zwar unabhängig von der konfigurierten Spin Down time. So verstehe ich das zumindest. Alle Werte größer 127 sind ohne Standby. Den Standby macht dann der hdparm.


    Test Nr1: Der wert wurde auf 128 gesetzt (128 = Minimaler Energieverbrauch ohne Bereitschaft (kein Spindown)) Spin Down Time deaktieviert. SMART ist deaktiviert. Neu Start.


    Kurze Suche nach 'ironwolf hdparm' meint, man solle hdparm -B 254 setzen, dann klappt's auch mit dem Ding und hdparm -S sollte funktionieren wie erwartet.


    Test Nr2: Der wert wurde auf 254 gesetzt (254 = Maximale Leistung, maximaler Energieverbrauch) Spin Down Time 30min. SMART ist deaktiviert. Neu Start.

  • Test Nr3: Der wert wurde auf 192 gesetzt (192 = Durchschnittlicher Energieverbrauch ohne Bereitschaft) Spin Down Time 30min. SMART ist deaktiviert. Neu Start.
    Auch hier ist Spin Down time Standard mäßig deaktiviert


    Egal welche Einstellungen man verwendet, hdparm befähle werden nicht angenommen oder verwendet.


    At least I would test directly with hdparm on the command line


    Auch das habe ich getestet. Kein unterschied. In /etc/hdparm.conf werden die Einstellungen korrekt Übernomen.


    and try to continue in English


    I will try to write in English with the help of google translator. Sorry.

  • So... I ran into problems with HC2s, Ironwolf 12TB and physical disk properties. If I changed any of the physical disk properties the IronWolves got unmounted and wouldn't mount after reboot. And I couldn't fix it without having to reinstall from scratch or restore a backup of the rootfs to the SD card. I belive this was caused by hdparm. Hdparm caused the IronWolves to malfunction. I fixed it by simply not changing ANY of the physical disk properties. The default settings of the IronWolves were OK. And I could set the spindown timer by reflashing the SATA USB bridge firmware of the HC2, instead of using hdparm. After this, not using hdparm at all, my HC2s with IronWolves became nice and very well-behaved and fast doggies. And we live happily ever after...


    The default spindown timer of the IronWolves was 2-3 minutes. By reflashing the SATA USB firmware of th HC2 I could set it to 30 minutes. Or whatever I wanted.


    It took a couple days to figure out that skipping the physical disk properties altogether was the solution. And many backups and restores of the SD card.


    I don't know if this is a general problem or only (or extra bad) with the combination of HC2 and Ironwolf. I have seen posts online where others report problems using hdparm with newer NAS drives. Like WD Red and Ironwolf. Perhaps some hdparm settings are OK to use? I never figured it out. And I don't feel like I need to anymore.

    Be smart - be lazy. Clone your rootfs. This help is Grateful™.
    OMV 4: 9 x Odroid HC2 + 1 x Odroid HC1 + 1 x Raspberry Pi 4

    Edited once, last by Adoby ().

  • After this, not using hdparm at all,

    Hello Adoby, thank you for your comment.
    What if I use a clean OMV without using hdparm. And immediately after mount the HDD, install or test OpenSeaChest / OpenSeaChest features. Accordingly, hdpart makes the problems and not PCI-e SATA-II Card.??
    or with another OS. (Which OS would be better suited?)?
    is this worth a try?

  • By reflashing the SATA USB firmware of th HC2 I could set it to 30 minutes. Or whatever I wanted.

    No idea what's going on.

    Den Standby macht dann der hdparm.

    Falls keine bessere Idee kommt, könntest du noch hdparm deaktivieren und statt dessen hd-idle testen

    Hello,
    A solution with standby - Spindown time settings I have not found unfortunately.
    My idea with the clearOS did not work either.
    The hard drive into a USB 3.0 external enclosure 3.5 and OpenSeaChest to instal after using OpenSeaChest features to control, also did not work.
    Whether problem at OMV, PCI-e SATA-II Card, or hdparm I can not determine.


    For me, I have now set the hdparm Advanced Power Management 192 option. (192 - Intermediate power usage without standby). This is the best setting for my needs. The hard drive automatically goes into standby mode after an "indefinite" time. Which time exactly I could not determine, but more than 30 min.
    It is very annoying that one can not adjust the Standby / Spindown time with hdparm.


    Maybe someone can tell me why I can not run OpenSeaChest, which blocks the usage. output>

    Many thanks for the support.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!