Samba refuses to start on OMV4

  • I just installed OMV4 and have everything configured, but when I try to enable CIFS/SMB, I get the following error in the GUI:


    Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C; systemctl start 'smbd' 2>&1' with exit code '1': Job for smbd.service failed because the control process exited with error code. See "systemctl status smbd.service" and "journalctl -xe" for details.


    When I check systemd (which sucks, by the way), I get the following message:


    Has anyone been able to get CIFS/SMB working on OMV4? How do I fix this problem?

  • So the problem appears to be LDAP. When I add the LDAP plugin and configure it to connect to my ldap server, then SMB breaks all over the place. Guess I'll comb the internet to find out why smb and ldap don't like playing together.


    This makes me really sad. What's the point of having LDAP users if OMV4 doesn't work properly with LDAP configured.


    If someone has LDAP and OMV4 CIFS/SMB running, please let me know how you got it to work.

  • Ok, this appears to be a bug and should be logged and fixed against OMV4. I've installed OMV3 and was able to configure LDAP and SMB access just fine.


    Unless there is a problem in the way the LDAP or SMB plug-ins are interacting with each other, it doesn't appear to be an OMV issue. If it's LDAP and SMB related.. it's not an OMV bug. It's either a bug w/ one (or both) of those packages, or it's a Debian 9 bug.


    Neither of which Volker is going to fix.


    If you disable the LDAP and SMB plugins in OMV, and set them up completely command line style, do the services work? If you still have this issue in that scenario, then it's not OMV.

  • is there any news on the fix for that?

    Fix for what? Omv4 connect to LDAP server


    Even if there is a bug somewhere it has to be properly reported ( @cschalk has been asked to provide testparm output to no avail). Only reproducable bugs can be fixed.


    LDAP integration is a complex topic so even for other users being able to help you setting things up you need to provide details about your installation first (that's at least testparm output and detailed logs if things don't work as expected. The latter most probably requires increasing Samba's 'Log Level' in the SMB/CIFS settings tab).

  • [quote='cschalk','There's no fix. If you want to run LDAP and OMV, you have to run OMV3. OMV4 does not work with SMB and LDAP. ']
    [/quote]So I've been struggling with SMB configuration along with OpenLDAP but it seems that it's not possible to be working with? Is it for sure ?

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!