Missing Devices RAID Management

  • Let me first say I'm coming from FreeNas, as this might have some input to what the problem could be. The installation went fine and wiped, quick wipe, 2 3TB drives. The OS is installed on a 1TB drive. The 2 3TB do not show up when trying to create a RAID device. Do I have to create a file system for these to show up? Thanks for any support.

  • Do I have to create a file system for these to show up?

    No, most probably you run into the same issue as this guy: Never more than 5 data disks for each OMV machine ? (some "signature" still present on the drives preventing them from showing up in the RAID UI).


    Asides that what you're trying to achieve (RAID with 2 disks) seems like a really bad idea to me. If you want to create a RAID1 with mdraid please read this first.

  • Let me first say I'm coming from FreeNas, as this might have some input to what the problem could be. The installation went fine and wiped, quick wipe, 2 3TB drives. The OS is installed on a 1TB drive. The 2 3TB do not show up when trying to create a RAID device. Do I have to create a file system for these to show up? Thanks for any support.

    Freenas uses zfs and if memory serves me correctly zfs will leave a signature at the beginning and the end of drive so a secure will erase that signature.


    What's the output of wipefs -n /dev/sd? (replace the ? with the drive letter a, b, etc.) this will display if there is a zfs signature on the drive.

    Raid is not a backup! Would you go skydiving without a parachute?


    OMV 6x amd64 running on an HP N54L Microserver

  • Freenas uses zfs and if memory serves me correctly zfs will leave a signature at the beginning and the end of drive so a secure will erase that signature.
    What's the output of wipefs -n /dev/sd? (replace the ? with the drive letter a, b, etc.) this will display if there is a zfs signature on the drive.

    Thanks tkaiser and geaves for replying.


    I just checked for zfs signature and it does have one for both drives that don't show up for raid.


    You mentioned that a secure erase will do to erase the zfs signature, enabling them to show up. How do I do this?


    Sorry, I'm new to all of this.

  • You mentioned that a secure erase will do to erase the zfs signature, enabling them to show up. How do I do this?

    You use the secure wipe Storage -> Disks, or you can use dd or wipefs from the cli.

    Raid is not a backup! Would you go skydiving without a parachute?


    OMV 6x amd64 running on an HP N54L Microserver

  • I have done the secure wipe option but no success.

    Odd as that removes everything on the disk, what's the output from one of the drives of wipefs -n /dev/sd? (replace ? with the drive letter)

    Raid is not a backup! Would you go skydiving without a parachute?


    OMV 6x amd64 running on an HP N54L Microserver

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!