URBackup Server NEWBIE

  • Did you get any error messages during install?
    Do you see UrBackup listed in the processes (diagnostics | system information | processes)


    UrBackup should be available when you enter this in the address bar of your browser ip.of.your.nas:55414 for example 192.168.0.1:55414


    Try restart of the server.

  • Actually did restart the server, looks like maybe a backup tried to run and that confused it since once I restarted....


    I'm getting this message on the URBackup admin page after rebooting: An error occured while accessing or checking UrBackup's internal database. This means this database is probably damaged or there is not enough free space. If this error persists, please restore the database (the files backup_server.db, backup_server_files.db, backup_server_links.db, backup_server_link_journal.db and backup_server_settings.db) from a backup. See log file for details.


    I don't see any indication of WHERE the database is let alone how to move it. I expect it installed to boot USB stick since the USB is suddenly almost full, rather than the 7TB of storage I have , and again, no indication of how to change that or tell it to install elsewhere. Is there no documentation specific to the OMV server version anywhere?

  • There is almost nothing OMV specific.


    In the GUI of urbackup go to settings. In |general|server| you can specify the path for the backup storage. Should be something like


    /srv/dev-disk-by-label-yyyy/backup


    http://www.urbackup.org/administration_manual.html

  • The database is in /var/urbackup. If you have not enough space for this on the root filesystem or if you are using a thumb drive or SD card you can move the /var/urbackup directory somewhere else and then bind mount or symlink it (ln -s /media/foo/urbackup /var/urbackup)


    Please note: the database contains just the meta data. The files which are actually backed up are in the path for the backup storage.

  • I think I have that set:
    /srv/dev-disk-by-label-7TBFileSystem/Backup/URBackup
    and it looks like that part is at least functioning to some extent because it now has a clients, urbackup_tmp_files, and 'myserver' folder inside it.


    Beyond that I picked OMV to have a reliable and robust NAS without having to know anything, so the 'move the /var/urbackup directory' instructions went over my head. That said, I just rebuilt the box, and I see that the boot USB only used 6g of the 16g available, so I may just rebuild it to fix that, that will give another 10g for the database and if that's all the problem I have left, maybe it will work if I get OMV to use the entire 16?


    Thoughts? (thanks!)

  • FYI, I wiped the box and started from scratch (since it was just rebuilt anyway) and it is working, and working well now. One strange thing though, wiped the USB stick and made sure that all 16g were available, but when I reinstalled OMV to it, it again created a 6g partition. and left the rest unusuable. Is this the biggest boot partition OMV will make? As I said, it's working now, but when I started my first backup there was 4g free, now there's 3.5, so I want to make sure I'm not going to lose the system when I add other backups to it...


    Thanks again all!

  • Maybe, when I put it on my windows PC to make sure the entirety of the USB was available, it showed what I assume was the boot partition and then the rest was 'free space'. In windows that space would normally show up as either a partition or 'unpartitioned' rather than 'free space', so I'm guessing that free space is what omv was using for swap. It wouldn't (and after the rebuild still won't) let me resize it.


    Ultimately, this time I've got all mys systems set to backup, an the USB was at 4.18g free, and after adding the three backups it's down to 3.64, but still far more than where we were before, and all is functioning well. I'm going to try on another box for a client and see what I get there.


    Thanks again for all the help!

  • resize the partion e.g. by using gparted.

    OK, now the 6g partition is full again, so I need to figure out a solution if I'm going to use this. I tried to install gparted but of course there's no space to install now. Any easy way to clean up a bit so i can do that and try to resize?


    Thanks again!

  • I think there are two topics:

    • knowing what is actually filling your root filesystem
      There are some threads in the forum how to do it; you need to use the CLI and change to the root cd / then list the size of each directory with du -xhd1 the first column of the output gives you the size; change to the largest directory and repeat the command; repeat until you know where all the space is used
    • resizing the root filesystem --> you can try to connect the drive to your windows PC and boot into gparted live or any other linux distro that includes gparted, but don't just delete SWAP
  • I have tried to use TDL's plex video to install Urbackup on OMV5 via Docker Hub. On my Portainer interface it says that UrBackup is running but I do not see it on OMV web interafce under Services and more importantly when I try to connect UrBackup web interface with port 55414, it says 'site cant be reached', so i guess i have done something wrong. any siggestions?

  • Generally speaking, programs running in a Docker are not going to show up in OMV's Services menu.


    It is difficult to suggest what you may have done wrong when you haven't provided any details about how you configured the container.

    --
    Google is your friend and Bob's your uncle!


    OMV AMD64 5.x on ASRock Rack C2550D4I C0 Stepping - 16GB ECC - Silverstone DS380 + Silverstone DS380 DAS Box.

  • Ok, so within Portainer, I click New Container and named it Ur Backup.


    the image I am using is uroni/urbackup-server.
    on Volumes, I click map additional volum and then bind. in the container, i enter /backups and then deploy container.


    it then says urbackup is running on my dashboard

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!