Creating bond failed, now I can't create one and when I try, 'bond0' is listed in the available nics

  • Weird problem. I recently rebuilt my Dell Poweredge 840 omv4 sever. It's got its built in broadcom gigabit nic and an addin intel quad gigabit nic.

    I tried to create a bond as I've done before and it failed, saying something about the bond having slaves, though I didn't note it as I thought I'd just checked something wrong and retrying would fix it... I saw that the bond was listed, but when I tried to save the settings it failed. I deleted the bond and today got back to it and when I went into the network settings to try to add the bond again, I hit add, select bond and the list of available nics appears. At the top of the list is 'bond0'. So OMV apparently thinks it's still there, even though it's not listed in the installed 'interfaces'.
    If I try to just create the bond again selecting all the available nics (other than the 'bond0') it lets me create it and then when i 'apply changes' it takes that and created bond1. Then I go in and enable ipv4 and set a static IP address and apply again and it sits at 'applying for about 30 seconds and then says 'error' An error has occurred. and then everything I do after that causes that error to come up until the it just goes off line.
    The attached terminal reports the bond couldn't be created because each of the nics are already in use and can't be enslaved.
    What is the easiest way to remove that bond0 so that I can retry it clean, or get it to show up in the list in OMV so I can just remove it in the web interface properly?

    Any recommendations or input is appreciated!

  • I faced a similar issue few days ago.

    Start from single - eth0, give it a ipv4 static ip (use "omv-firstaid" command).

    Once it's successful created, reboot the system.

    Now that you have only one NIC active with static ip use that to access your webUI and follow the below instruction.

    1. Go to Network
    2. Delete all the Ethernet i.e. eth0 if you're planning use it in your bonding.
    3. Click on Create - Bond make sure all the adapter settings are deleted which you're planning to use.
    4. Fill in the details as per your convince and tick the Nik's which you want to bond.
    5. Give your bond a ipv4 static ip
    6. Hit apply & wait foe couple of seconds.

    Your bond is ready to be used

  • And this time when I tried to add the 4 intel gigabit nics (from the quad Nic), it set, but when I applied it it gave me an error:

    "Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C.UTF-8; systemctl start 'networking' 2>&1' with exit code '1': Job for networking.service failed because the control process exited with error code. See "systemctl status networking.service" and "journalctl -xe" for details."

    Not sure what it's telling me...?

    Thanks again guys!

  • ultimately the goal would be performance

    Rather impossible to achieve with a 'bond'. Only exception: when establishing some sort of point-to-point connection between two Linux hosts and using either balance-rr or balance-alb on both ends.

    But with usual NAS scenarios a bond is useless unless you have tens or hundreds of clients and chose the appropriate algos to distribute the individual links on the bond members.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!