Reasons to Upgrade

  • Hi:


    I am using the OMV, now on version 3.0.89 and I only use it for a NAS server do Backup my stuff and most of the time the machine (is a old X86 PC) is power off. I power on once a week. As i state the function here is just to have a Cold Backup if I can use this word.


    So, the question will be, taking the use that I give to him have any sense in upgrade to version OMV 4.x, witch could rise some issues or for this I just stay on version 3.


    As far I can see I did not find any log change of features between 3 and 4 and see I would like to have this or I must upgrade because of this.


    With my best regards


    Carlos

  • My opinion, you should always stay on the current release. Everything works, until it doesn't... then if you're 3-4 versions behind it makes your upgrade path much more difficult if not impossible.


    There's a reason that distro's call themselves "End of Life".. that's not really a suggestion.


    You have a couple of options:


    1. Fire up OMV 4 in Virtualbox and test whatever you need to test.


    2. Assuming your NAS can boot a flash drive... Disconnect your data drives and OS drive (the one that currently has OMV 3), install OMV 4 to flash drive, boot it, install flash memory plugin, attach storage drives (but not omv 3 OS drive), and complete any tests, etc. If something goes FUBAR, it's just a matter of shutting down, unplug the flash drive, reconnect your OMV 3.0 OS drive and you're back up and running.

  • Hi:


    Thanks. Your suggestion of using a USB (it's possible, is a 10 years PC) it's a good suggestion.


    I will program that one of this days just to see, but, as you say. for me it's working as I want. I do not need nothing more so I will wait some more time.


    Carlos

  • As far I can see I did not find any log change of features between 3 and 4

    OMV 3 is based on Debian 8 which is "obsolete stable", support ended in June 2018
    OMV 4 is based on Debian 9 which is "current stable"


    So if you want to have an up-to-date and secure system you should be on OMV4.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!