RAID5 disappeared

  • Hello,


    Sorry for my english, i'm french.


    I run on OMV 4.1.21-1 and I have several disks including a RAID 5 of 3 disks 2 TB.
    One of the disks failed, I replaced it, but I can not put this disk in the raid management because the raid has disappeared.


    Could you help me please.


    Thanks in advance.
    Michael

  • Thinks for your answers


    Code
    root@NAS:~# cat /proc/mdstat
    Personalities : [linear] [multipath] [raid0] [raid1] [raid6] [raid5] [raid4] [raid10]
    md127 : inactive sdc[3](S) sdb[4](S)
    3907027120 blocks super 1.2
    unused devices: <none>



    Code
    root@NAS:~# blkid
    /dev/sda1: LABEL="Surveillance" UUID="477137df-7f7e-44b8-893b-5f2ed6c8fbd9" TYPE="ext4" PARTUUID="2049d577-639c-4b3a-9a5a-4d3034bf7b60"
    /dev/sdb: UUID="f7093f38-a653-0b7f-2f4b-306f818ce6cf" UUID_SUB="d860f486-e04a-bf13-f05a-30082711bc72" LABEL="NAS:raid5" TYPE="linux_raid_member"
    /dev/sdc: UUID="f7093f38-a653-0b7f-2f4b-306f818ce6cf" UUID_SUB="90a1f1a1-a119-3715-f728-1c6808ecbf91" LABEL="NAS:raid5" TYPE="linux_raid_member"
    /dev/sdd1: UUID="8d47b635-3f13-4a48-81b2-c7086cf50599" TYPE="ext4" PARTUUID="0007700b-01"
    /dev/sdd5: UUID="da8466fc-068e-4e77-9589-714d0ade56ee" TYPE="swap" PARTUUID="0007700b-05"
    /dev/sde1: LABEL="DD1500" UUID="40cfb129-6726-4146-8eb4-201f517c3918" TYPE="ext4" PARTUUID="782958b0-31d8-4daa-89d9-c6dbfcb247cc"
    Code
    root@NAS:~# fdisk -l | grep "Disk "
    Disk /dev/sda: 2,7 TiB, 3000592982016 bytes, 5860533168 sectors
    Disk identifier: 9FEA1A4A-3675-42D7-BC63-88CBB5F823C6
    Disk /dev/sdb: 1,8 TiB, 2000398934016 bytes, 3907029168 sectors
    Disk /dev/sdc: 1,8 TiB, 2000398934016 bytes, 3907029168 sectors
    Disk /dev/sdd: 149,1 GiB, 160041885696 bytes, 312581808 sectors
    Disk identifier: 0x0007700b
    Disk /dev/sdf: 1,8 TiB, 2000398934016 bytes, 3907029168 sectors
    Disk /dev/sde: 1,4 TiB, 1500301910016 bytes, 2930277168 sectors
    Disk identifier: BE1BC9E8-BBE0-446B-8CD4-EFC3592FF49A
    Code
    root@NAS:~# mdadm --detail --scan --verbose
    INACTIVE-ARRAY /dev/md127 num-devices=2 metadata=1.2 name=NAS:raid5 UUID=f7093f38:a6530b7f:2f4b306f:818ce6cf
    devices=/dev/sdb,/dev/sdc
  • Hello.
    Thank you for your message.
    I just tried with the link you gave me but I can not find my RAID.


    Please could you help me.


  • Thank you for your reply.
    Here is the return. And I finally found in the openmediavault interface my raid with 2 disks.
    I will try a reconstruction of the raid with my new disk.
    Thank you very much for your answer, I'll let you know the result

    Code
    root@NAS:~# mdadm --assemble --verbose --force /dev/md127 /dev/sd[bc]
    mdadm: looking for devices for /dev/md127
    mdadm: /dev/sdb is identified as a member of /dev/md127, slot 0.
    mdadm: /dev/sdc is identified as a member of /dev/md127, slot 1.
    mdadm: Marking array /dev/md127 as 'clean'
    mdadm: added /dev/sdc to /dev/md127 as 1
    mdadm: no uptodate device for slot 2 of /dev/md127
    mdadm: added /dev/sdb to /dev/md127 as 0
    mdadm: /dev/md127 has been started with 2 drives (out of 3).
  • Finally I'm sorry to come back to you, but I have my RAID that is back but when I want to recover and add my new disk it does not appear in the list.
    Yet the disc is present in "disks"


    edit
    Sorry I wrote too fast.
    I had to format the disc

  • Thank you all for your messages.


    From the beginning I had almost the solution but in fact I was trying the command

    Code
    mdadm --assemble --verbose --force /dev/md127 /dev/sd[bcf]

    when it was necessary to do

    Code
    mdadm --assemble --verbose --force /dev/md127 /dev/sd[bc]

    Nevertheless I have a big problem since and I opened a new post.
    OMV does not start anymore


    I am disgusted...



    Sincerely
    Michael

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!