omv-release-upgrade failed (apt-get update failed, too)

  • Hi,


    omv-release-upgrade failes.



    /etc/apt/sources.list:





    Does anybody know what i can do?

  • Get rid of any line with jessie in it in /etc/apt/sources.list

    Hi ryecoaaron, I have a similar problem and I'd just like to upgrade from OMV 3.0.99 to OMV4 as a kind user suggested me, but I'm not sure on the procedure...


    Here is the error occurred when I try to do apt-get update:



    Sorry, i'm from Italy... In english should be something like:



    Code
    W: Impossible to reach http://httpredir.debian.org/debian/dists/jessie-updates/InRelease Immpossible to find "main/source/Sources" in Release file (wrong sources.list or damaged file.
    E: Impossible to download some files with address: they will be ignored or older versions will be used.


    Is there a way to fix the problem with upgrade? Thank you so much in advance :)

  • Is there a way to fix the problem with upgrade?

    This should fix up your sources so you can run omv-release-upgrade:
    sed -Ei "s/(stable|oldstable|jessie)/stretch/g" /etc/apt/sources.list.d/* /etc/apt/sources.list

    omv 5.5.11 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.3.6
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • This should fix up your sources so you can run omv-release-upgrade:sed -Ei "s/(stable|oldstable|jessie)/stretch/g" /etc/apt/sources.list.d/* /etc/apt/sources.list

    Thanks a lot! The manually update worked fine via SSH but web interface still doesn't work, should I upgrade to OMV4 with "apt-get dist-upgrade"? Sorry if I ask the obvious but I want to be sure of what I do... Thanks again!

  • should I upgrade to OMV4 with "apt-get dist-upgrade"? Sorry if I ask the obvious but I want to be sure of what I do... Thanks again!

    No. Look at my message :) "So you can run omv-release-upgrade"

    omv 5.5.11 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.3.6
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Howdy ryecoaaron,


    I am in the same case as CarfRip.
    After execute
    sed -Ei "s/(stable|oldstable|jessie)/stretch/g" /etc/apt/sources.list.d/* /etc/apt/sources.list
    aptitude update shows

    Code
    553 mises à jour restantes [+553], 14358 nouveaux paquets [+14352].




    should I run aptitute upgrade before omv-release-upgrade ?
    OR only omv-release-upgrade ?


    Sorry, it's not clear for me. I don't know what omve-release-upgrade really do.
    Is there an howto for upgrade OMV 3.x.x to OMV 4.x.x ?

  • This should fix up your sources so you can run omv-release-upgrade:sed -Ei "s/(stable|oldstable|jessie)/stretch/g" /etc/apt/sources.list.d/* /etc/apt/sources.list

    Hi,


    this line sed -Ei "s/(stable|oldstable|jessie)/stretch/g" /etc/apt/sources.list.d/* /etc/apt/sources.listworks on my 3.0.99 OMV system, which displayed error when i ran omv-release-upgrade.


    then after, i just ran omv-release-upgrade and the "3.x -> 4.x upgrade" is in progress.
    Thanks ryecoaaron :love:

  • I did
    aptitude update && aptitude upgrade.
    Some updates were made in spite of errors message.
    I did not insist and run omv-release-upgrade.


    Now, welcome to OMV 4.x.x.


    Thanks for posts.

  • Hi all,


    i added some text in SMB Global Options, for my old networked multimedia players:
    ntlm auth = yes


    to allow smb v1.


    my 1st OMV 4.x system is now ok.
    2nd, upgrade/update in progress.
    another one (3.0.99) is broken, after a click on managment update (web interface), something was wrong, i can't start it... i ll check it next week



    ps: what i see on this forum, is a single fact: nothing is displayed about how to upgrade or update a version. The only way is to use search bar to see a user post talking about update. Why does a pinned post not exist ? or why do i not find it ? lol

  • ps: what i see on this forum, is a single fact: nothing is displayed about how to upgrade or update a version. The only way is to use search bar to see a user post. why does a pinned post not exist ? or why do i not find it ? lol

    https://openmediavault.readthe…pt.html?highlight=upgrade

  • sorry, that 's why i said that. Not really evident.


    7th question ??? nothing about upgrade or update


    never mind, it is what i feel about this forum, a lot of things very very nice, a excellent OMV solution, but to find out something straightly, it is not sure.


    not my 1st and not my last raid system. i like omv, and i use a lot of omv.


    it is same for omv-extra, openmediavault home page (not forum), links are not displayed or highlighted, if they are important. My feelings. Maybe i am alone in this case, i am unique :D


    try this in TAG section, use "upgrade"... results: omv upgrade is not displayed first... nothing about it.


    but now, thanks to you, i will remember this discussion and how finding this way to update/upgrade when needed :)

  • If I run omv-release-upgrade I receive "Command not found" :(


    On 3 OMV systems, exactly same setups, one upgrade was successfull, one not, but after modifying sources.list, works, and another one, my OMV3.0.99 crashed.


    For this last one, impossible to reinstall, remove, purge omv-extra. and all omv-xxxx commands were not present.


    So, i got the ssd (ssd for OS), plug into Windows10, diskpart then select disk, then clean. No volume, no partition on the ssd, and then i reinstall from scratch, OMV4.x. from a usb stick.


    of course all my datas are safe, because i use a raid card, and its logical volume is still available. OMV did not delete it.


    Very strange, the errors about "/etc/apt/sources.list".
    Very strange, omv commands disappeared.


    From Web interface, in update managment, it was like OMV 3.0.99 wanted to update all its modules on itself.


    I did not keep logs. 2 on 3 upgrades were bad. Same guy :D oups.

  • The openmediavault package must be uninstalled. What is the output of: dpkg -l | grep openm

    Code
    root@CarfRip-NAS:~# dpkg -l | grep openm
    rc openmediavault 3.0.99 all Open network attached storage solution
    ii openmediavault-keyring 1.0 all GnuPG archive keys of the OpenMediaVault archive
    rc openmediavault-omvextrasorg 3.4.32 all OMV-Extras.org Package Repositories for OpenMediaVault
    rc openmediavault-openvpn 3.0.6 all OpenVPN plugin for OpenMediaVault.
    rc openmediavault-plexmediaserver 3.8.2 all OpenMediaVault Plex Media Server plugin
    rc openmediavault-sensors 3.0 all Provides a cpu temperature monitor

    Thanks a lot for your support, I'd like to keep my NAS plugins settings safe (like Plex) but if you think that SSD formatting is the only way I'll do it.


    Thanks again!

  • Try the following lines (as root):


    sed -Ei "s/(stable|oldstable|jessie)/stretch/g" /etc/apt/sources.list.d/* /etc/apt/sources.list
    apt-get update
    apt-get install proftpd-basic=1.3.5-1.1+deb8u2
    apt-mark hold proftpd-basic
    apt-get install openmediavault
    omv-release-upgrade


    After reboot:


    apt-get update
    apt-mark unhold proftpd-basic
    apt-get dist-upgrade


    Then read:
    No access after update

    omv 5.5.11 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.3.6
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

    Edited 2 times, last by ryecoaaron ().

  • Try the following lines (as root):

    Errors:


    - apt-get update



    - apt-get install proftpd-basic=1.3.5-1.1+deb8u2


    Code
    root@CarfRip-NAS:~# apt-get install proftpd-basic=1.3.5-1.1+deb8u2
    Lettura elenco dei pacchetti... Fatto
    Generazione albero delle dipendenze
    Lettura informazioni sullo stato... Fatto
    E: Version "1.3.5-1.1+deb8u2" per "proftpd-basic" non trovato (not found)

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!