docker make services crash or server unreachable

  • Hi,


    I'm trying to install haugene/transmission-openvpn. I've already installed on another server, but i have a problem on this one. I followed the video made by TechnoDadLife .


    When i start the container, all seems ok in logs (docker logs xxxxx) but i can't use the openmediavault web gui, transmission web gui or the SSH ... seems the server is unreachable or services crash ...


    Thanks for the help

  • well, i've made a 2nd try : i initiate another container from scratch ... same issues.


    When i save the parameters, all network's services (omv web gui, samba, ssh,rynsc server .. ) become unreachable. The only solution is to log on the server, stop the container and reboot but the container doesn't work then ...
    to avoid a IPV6 error, i've found 2 commands lines (but no idea how to make them perma and what they do) :
    sysctl -w net.ipv6.conf.default.disable_ipv6=0
    sysctl -w net.ipv6.conf.all.disable_ipv6=0
    the server answer when i ping it, it can ping my pc in the same network.


    The log of the container is :


  • i've read something about mergeFS ... on my other NAS, i've got a ext4 out of the mergeFS .. on this one, i don't have, so i'm using the mergeFS for the data and the config ... is it a problem ?
    If yes, do i should move on the main HD (system of omv) or add another HDD to use the transmission openvpn docker ?


    Thanks

  • up , please, i need help

    I can't help with your problem as I don't use that particular docker but @TechnoDadLife videos usually just work, but I can give you some insight which might help.
    I use mergerfs and snapraid and I've found that some docker configs will not work if placed on a share within a mergerfs pool, but they work if deployed on a share on a standalone drive.


    i've tryed to put volumes to another disk in ext4 out of the mergeFS

    I'm not sure if I understand the above, is this a standalone drive? To give you an example on my system I have a drive with the label docker it has one single share AppData (TechnoDadLife uses that folder to store/locate any docker configs).
    One of things I do if I find something does not work is to ensure I know exactly where the config and other volume bind mounts are or where they are going to be installed, stop the running container, then delete it, delete the image, if there any left over config files delete them as well, then start again.

  • thank you very much for your answer.


    Yes, i made a standalone drive to avoid to use the mergeFS ...
    I followed your advices, deleted all, remake the container. ... when i start it, all still crash , can't access anymore through SSH, samba, web interface of OMV .... and log of the containers seems ok ...


    I really don't understand, the same container works with almost same parameters on my other NAS ... (i want to transfert it because all the network services use the openVPN ... and i don't want that, i have plex and some others ... so i make my backup NAS with transmission/openvpn in docker and the main with all my services...)


    i'm totally lost :/

  • I really don't understand, the same container works with almost same parameters on my other NAS

    When you say almost have you compared the two i.e. compared the settings on the one that will not work with the one that does.


    i want to transfert it because all the network services use the openVPN ... and i don't want that,

    Ok, I'm trying to understand the above, I understand that as you have openVPN running but you want to use transmission-openvpn as per the video.

  • i'm sorry, as many frenchies , i'm bad in english ... thank you for your time !


    About openvpn, on the main NAS, it work (in a container, haugene/transmission-openvpn) but, because of it, i can't use plex or nextcloud or others services when i'm not at home, that's why i'd like to move it to the other NAS ... it's easier to understand ?(sry again ... )


    i said almost .. but it's the same parameters, i've set the new container on the 2nd NAS with alot of copy/paste ;) ... My VPN (hydemyass) accept many VPN connections ...


    Do you want the logs or thoses i've posted are ok ? They are the same atm , they say (as far as i undestand) all is ok ... but this container break all until i stop it manually and reboot the NAS ... and i can't access to the transmission web :/
    The weird thing is i never had this bug on the main NAS ... i use some others containers (nextcloud, mariadb, and ofc haugene transmission OpenVPN) allways works with videos tutorials and time :( .... that never crashed like that

  • i've set the new container on the 2nd NAS with alot of copy/paste

    TBH I'm not going to be able help solve the problem, I usually work things out by a process of elimination, but the above I can tell you can be a problem by using a copy/paste rather typing in the settings. Why? don't know but found the solution by typing in the settings.
    Watching that video any misconfiguration will prevent from working the way it should, the fact that you cannot access anything (gui, ssh etc.) would suggest that.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!