Docker letsencrypt times out trying to display generic web page

  • Installed docker letsencrypt as per Techno Dad's Life video. The install went ok, and I was able to create the certificates. However when I went to https://<mydomain>.duckdns.org to view the generic web page... it just times out displaying nothing.


    Here are all the particulars.
    From the docker letsencrypt log:


    GID/UID
    User uid: 1000
    User gid: 100
    -------------------------------------
    [cont-init.d] 10-adduser: exited 0.
    [cont-init.d] 20-config: executing...
    [cont-init.d] 20-config: exited 0.
    [cont-init.d] 30-keygen: executing...
    using keys found in /config/keys
    [cont-init.d] 30-keygen: exited 0.
    [cont-init.d] 50-config: executing...
    Variables set:
    PUID=1000
    PGID=100
    TZ=America/Chicago
    URL=fun1sys.duckdns.org
    SUBDOMAINS=
    EXTRA_DOMAINS=
    ONLY_SUBDOMAINS=false
    DHLEVEL=2048
    VALIDATION=http
    DNSPLUGIN=
    EMAIL=doogleaelf@yahoo.com
    STAGING=



    2048 bit DH parameters present
    No subdomains defined
    E-mail address entered: doogleaelf@yahoo.com
    http validation is selected
    Certificate exists; parameters unchanged; starting nginx
    [cont-init.d] 50-config: exited 0.
    [cont-init.d] done.
    [services.d] starting services
    [services.d] done.
    Server ready



    PortsLetsEncrypt.pngdockerLetsEncrypt.pngLetsEncryptConfig01.pngLetsEncryptConfig02.png


    I'm also getting a bad gateway message which I suspect is the real issue...


    BadGateway.png


    I know in the video there was no tweaking of the nginx.conf file. I played around with it but it didn't help so ended up leaving it the way it was.


    Any help would be greatly appreciated.
    Kevin


    any help would be greatly appreciated.

  • Sometimes when you modify the container it looses the port forwardings.Try again to modify the container, choose network mode 'bridged' and delete the host name. Then click save.
    Just to eliminate this common problem.

  • well, I tried that and you were right. I did lose the forwards. The network changed but no forwards. The generic site failed to load. I suppose the only option is to delete the container and do it from scratch?

  • Does this shed any light... it looks to me like its having trouble writing something, but still enters the forwarding state.


    Apr 25 15:37:26 dellomv kernel: [31730.848549] br-31110d631cb0: port 1(vethf5add4a) entered disabled state
    Apr 25 15:37:26 dellomv systemd-udevd[2252]: Could not generate persistent MAC address for vethf5add4a: No such file or directory
    Apr 25 15:37:26 dellomv containerd[1079]: time="2019-04-25T15:37:26.514988441-05:00" level=info msg="shim containerd-shim started" address="/containerd-shim/moby/73bddc582dce304e88b5fdab98492d582129c2ae005dec46b546917af660934d/shim.sock" debug=false pid=2290
    Apr 25 15:37:27 dellomv kernel: [31731.831289] eth0: renamed from veth7693bbb
    Apr 25 15:37:27 dellomv kernel: [31731.847274] br-31110d631cb0: port 1(vethf5add4a) entered blocking state
    Apr 25 15:37:27 dellomv kernel: [31731.847278] br-31110d631cb0: port 1(vethf5add4a) entered forwarding state
    Apr 25 15:39:01 dellomv CRON[2759]: (root) CMD ( [ -x /usr/lib/php/sessionclean ] && if [ ! -d /run/systemd/system ]; then /usr/lib/php/sessionclean; fi)
    Apr 25 15:39:01 dellomv systemd[1]: Starting Clean php session files...
    Apr 25 15:39:01 dellomv systemd[1]: Started Clean php session files.

  • Well, I'll be danged... so it's just internally I'm having a problem. dunno what to make of that. I went and tried it on my cheesy cell phone and it did work...
    :thumbsup:

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!