Newbie with slow ethernet speeds

  • Hi

    I installed omv just a few days ago. But I have various problems getting everything to work properly. Not just eth speeds, but I'll stick to that in this sub.
    First off. I'm a Linux newbie as in "I've used Windows All My life until last week" so please use descriptive language even if you think it's too simple and condecending.

    I have omv set up on an old hp pavilion slimline s5130. Chucked in a few more disks and went exploring.

    But for the life of me I cannot figure out why I only get speeds of about 1.5 Mb/s and often it trickles off to nothing. 5 gigs tænkes anywhere from 30 mins to 2 hours. I feel like I've gone back to the early 2000 era speed wise. :)

    What do you great People need to know in order to help a poor Linux convert?

  • Are you transferring small files?
    Are the speeds write or read or both?
    What kind of disks?
    What kind of switch is it plugged in to?
    I assume the client is Windows?
    If you are connecting via smb/cifs, have you read the threads in Problem #5 here - https://forum.openmediavault.o…tions-to-common-problems/

    omv 5.5.6 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.3.5 plugins source code and issue tracker - github

    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • 1 - Some, but even opening a picture from shared (about 5Mb) takes about 5-10 seconds.
    2 - Both write and read is equally slow.
    3 - Fuji 750 Gb sata.
    4 - Generic sagecom ISP router/modem
    5 - Yes. I'm trying out Linux on my main next. Wanted to have a nas up and running first for backup.
    6 - No, but I will and will post back if it helps.


  • So! I'm back.

    I tried tuning samba as suggested above, with mixed results.

    As I was already considering swtching to Linux, I tried a live usb, and poof. Speed doubled from 2 to 4mb/s on wireless. Haven't tried ethernet yet, but suspect similar results.

    Why doesn't this surprise me? I'm becoming rather disillusioned with Windows.

  • That's roughly a 40Mbps transfer.

    What model is the router exactly?

    There should be an app called Terminal easy to find in some way in the Linux flavor you are using.
    What is the output of this command in Terminal?
    lspci | grep Eth

    Mac mini Late 2012 / macOS Catalina / Docker Desktop for Mac
    Intel Core i7-3615QM CPU @ 2.30GHz - 16GB RAM - 4 external disks via USB3.0 - Gigabit Ethernet - 20 docker containers via docker-compose ;)
    omv 5.2.1-1 (Usul) - Bevy NUC thanks to TechnoDadLife (NUC5CPYB)
    Celeron N3050 @ 1.60GHz - 8GB RAM - 2 external disks via USB3.0 - Gigabit Ethernet - 21 docker containers via docker-compose :)

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!