Cannot Log in using Web Gui

  • For some reason I am locked out of the Web Gui on this machine. I have this scenario.

    I can login to OMV via the command line.
    I can su to root.
    Using omv-firstaid as root does not change anything.

    I cannot bring up the Web Gui using Firefox.
    On one computer I have an older linux running. It runs on another hard drive. When I boot into this system I was able to see the Web Gui and log in. Very confusing.
    However any attempt to Connect to the Web Gui on my main machine using Firefox fails with "Unable to connect" Tried to log in with Chromium browser but found the same result.

    Any ideas. I have looked at the Host-Deny file but nothing appears out of place. Not sure where to go with this.

  • Update: Managed to copy down this error detail after a failed log-in. Hope it may help with resolving this.

    Error #0:
    OMV\Rpc\Exception: Failed to connect to socket: No such file or directory in /usr/share/php/openmediavault/rpc/
    Stack trace:
    #0 /var/www/openmediavault/rpc/ OMV\Rpc\Rpc::call('UserMgmt', 'authUser', Array, Array, 2, true)
    #1 [internal function]: OMVRpcServiceSession->login(Array, Array)
    #2 /usr/share/php/openmediavault/rpc/ call_user_func_array(Array, Array)
    #3 /usr/share/php/openmediavault/rpc/ OMV\Rpc\ServiceAbstract->callMethod('login', Array, Array)
    #4 /usr/share/php/openmediavault/rpc/proxy/ OMV\Rpc\Rpc::call('Session', 'login', Array, Array, 3)
    #5 /var/www/openmediavault/rpc.php(45): OMV\Rpc\Proxy\Json->handle()
    #6 {main}

  • A lot has happened since this post.

    Hope this may help someone. A firewall was blocking my IP. Unfortunately this was not clear to me for a long long time. I had to Google my way through this.
    The Firefox console ( ctl>shift>k) was blank when I tried to open the WebGUI. Ok it did not seem to be a missing file or config issue.
    More searches on Debian and firewall blocking/unblocking were done. I could access OMV on the command line.

    I started with Iptables. Iptables listed the webgui --- good that is an issue for me.

    sudo iptables -n -L

    Chain INPUT (policy ACCEPT)
    target prot opt source destination
    f2b-omv-webgui tcp -- multiport dports 80,443

    ******more importantly********
    Chain f2b-omv-webgui (1 references)
    target prot opt source destination
    REJECT all -- reject-with icmp-port-unreachable

    Also searched more on f2b or fail2ban. I may have installed this thinking I needed a firewall. . . . not sure.

    sudo fail2ban-client status
    |- Number of jail: 1
    `- Jail list: omv-webgui

    So there we have it - - my GUI was blocked.

    To remove this block I had to issue the command

    sudo fail2ban-client set omv-webgui unbanip

    Good that seemed to work.
    sudo iptables -n -L now shows my IP is no longer blocked. Immediately I reloaded the OMV- gui in firefox. Nothing works.
    Hah! I may need to reload something. Back to the command line.

    sudo fail2ban-client reload

    Surely the OMV-gui will load. But no. I cleared the Firefox Cache again, but this did not alter things. No OMV-gui

    Ok lets restart the system

    sudo /sbin/shutdown -r now

    Upon rebooting I tried to load OMV in Firefox .. nothing appeared.

    Iptables did not have my IP listed. It should work.

    Ok I will run the omv-firstaid again and select the webgui.

    After doing this the Log in Page loaded and I was able to log in to OMV as admin. Yay!

    Your mileage may vary ----- good luck!

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!