Getting an error message when attepting to make changes from the OMV web GUI.

  • Recently started to get errors when trying to make changes with the GUI. When I click on apply I get the following error message:


    Code
    ERROR:
    Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C; omv-mkconf halt 2>&1' with exit code '127': /usr/share/openmediavault/mkconf/halt: 57: /etc/default/openmediavault: 4c8bc97f-1a07-4e3b-ba6b-7f3aea225fd1: not found


    I should also mention that at the same time I'm not able to update from the update management on the GUI. Example below:


    Would greatly appreciate if anyone could point me in the right direction to find a solution. Would like to upgrade to OMV 4, but thinking I should have to resolve this problem first or risk losing data on the raid array.

  • should have to resolve this problem first or risk losing data on the raid array.

    Before you upgrade to OMV4 you should remove all plugins which are not more available in OMV4 if any.


    Before upgrading I further recommend to clone the boot drive and to make a full backup of your raid array data. The latter is mandatory.

    OMV 3.0.99 (Gray style)
    ASRock Rack C2550D4I C0-stepping - 16GB ECC - 6x WD RED 3TB (ZFS 2x3 Striped RaidZ1)- Fractal Design Node 304

  • Thanks for the reply cabrio_leo.


    My problem is that I can't make any OMV changes from the Web GUI, including uninstalling (or installing) plugins. Just keep getting the errors detailed above. Maybe possible from the CLI?


    Good advice to clone the boot drive and backup raid array data. I will certainly do that.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!