Bitwarden over Internet

  • Hi All,
    i have some trouble installing Bitwarden on my OMV 4.x
    i followed TDL Bitwarden guide and worked for me! Thank you for the guide!
    Side note: that costed me a lot of time... if you install it on a ARM-CPU just add the Tag for your architecture. In my case, with a NanoPi M4 was the Tag "aarch64"


    I can't get the Bitwarden to work as i'd like. what i want is when i call https://mybitwarden.ddns.com that work with SSL.

    URLRESULT
    mybitwarden.ddns.comunable to connect
    mybitwarden.ddns.com:88works without SSL
    https://mybitwarden.ddns.com:88Source Connection failed
    https://mybitwarden.ddns.com502 bad gateway with SSL



    My Setup:
    - Running a Letsencrypt Container with ReverseProxy capability
    - NC Container
    - MariaDB Container for NC
    - Gitea non docker (on the docker i could not get it to work)


    NC and Gitea can i reach from the internet over No-IP free DynDNS. So far so good, every thing works fine.


    What i've done to make Bitwarden work:
    On my router i have the port 88 forwarded to 88 for Bitwarden. On the container i map -p 88 : 80
    i tried also to map the network from Bitwarden container to the the Letsencrypt container with the param --network my-net
    i enabeled the bitwarden.subdomain.conf on the Letsencrypt Container:
    /sharedfolders/AppData/Letsencrypt/nginx/proxy-confs/bitwarden.subdomain.conf
    The only change where made is to change the server_name to mybitwarden.*


    the help is really apreciated!
    regards
    fraxor

  • I got it to work more or less... but not as i wish i could.
    i followed this guide: https://github.com/dani-garcia…en_rs/wiki/Enabling-HTTPS
    and this is the final docker run command:

    Code
    docker run -d --name bitwarden --restart always \
    -e ROCKET_TLS='{certs="/ssl/live/mybitwarden.ddns.com/fullchain.pem",key="/ssl/live/mybitwarden.ddns.com/privkey.pem"}' \
    -v /sharedfolders/AppData/Letsencrypt/etc/letsencrypt/:/ssl/ \
    -v /sharedfolders/AppData/Bitwarden/:/data/ \
    -p 88:80 \
    mprasil/bitwarden:aarch64


    finally i can reachBbitwarden with SSL from Internet on Chrome (but not with the Chrome extension), iPhone.
    this is the final URL: https://mybitwarden.ddns.com:88/#/


    if some one has a hint how to avoid the port param, is very apreciated!
    i could not put the 443 port, because other aps are listening to this port, and if so configured, i got a 502 bad gateway error.

  • Hi,
    can you please post your configuration for bitwarden? Did you used the plugin or you made you via cli?
    I wanted to use it too, but I want to have it only inside my LAN.

    Intel G4400 - Asrock H170M Pro4S - 8GB ram - Be Quiet Pure Power 11 400 CM - Nanoxia Deep Silence 4 - 6TB Seagate Ironwolf - RAIDZ1 3x10TB WD - OMV 5 - Proxmox Kernel

  • Hi Blabla,
    downloaded the aarch64 docker from mprasil/bitwarden.
    made a shared folder: /sharedfolders/AppData/Letsencrypt/


    then over the CLI i run the command:
    Replace on row 2 the mybitwarden.ddns.com with your hostname
    Replace on row 5 the port with your desired one (in my case is the port 88

    Code
    docker run -d --name bitwarden --restart always \
    -e ROCKET_TLS='{certs="/ssl/live/mybitwarden.ddns.com/fullchain.pem",key="/ssl/live/mybitwarden.ddns.com/privkey.pem"}' \
    -v /sharedfolders/AppData/Letsencrypt/etc/letsencrypt/:/ssl/ \
    -v /sharedfolders/AppData/Bitwarden/:/data/ \
    -p 88:80 \
    mprasil/bitwarden:aarch64


    edited the File : /sharedfolders/AppData/Letsencrypt/nginx/proxy-confs/bitwarden.subdomain.conf.sapmle and saved as bitwarden.subdomain.con

    Restarted Letsencrypt Container and then you can follow the rest of @TDL Guide seting up Bitwarden.


    Hope could helped you out.
    cheerz

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!