OMV in KVM (proxmox) - passthrough disk not visible for shared folders

  • Hi All,

    I'm planning to move my OMV server into a VM on a larger server, under KVM/QEMU/Proxmox. I have several ext4 disks on the physical OMV serer, full of data, and I'd like to use them directly with the OMV VM for performance and recoverability reasons (if all else fails, pull the disk out, read it in another PC!)

    I've set up a VM to test it and edited the qemu vm conf file to add the host path for an ext4 disk:

    virtio2: /dev/disk/by-id/ata-WDC_WD15EADS-00R6B0_WD-WCAVY0822713,size=1465138584K

    When I start OMV in that vm, it shows the disk - /dev/vda - and the filesystem - /dev/vda1. However, when I try to define a shared folder, there are no devices in the list to select from.

    I've tried defining the disk by various forms of its path, as a partition and as a whole disk, and as vm device virtio2, scsi1, ide1. None of the combinations has made OMV show the disk for shared folder creation. Looking at the OMV VM from the shell, I don't see any entry in /etc/fstab or any mount point under /media for the passthrough disk.
    I've tried running "omv-mkconf fstab" but that didn't change the fstab file. Something in OMV's config database doesn't seem to know that the disk exists, although parts of the UI do know.

    What's gone wrong here? How can I get that disk to be properly available in OMV?



  • I don't pass threw disks to proxmox so I can't speak to performance. I manage the disks in proxmox because it gives more options. It's easy to increase the size and zfs is far more stable in proxmox if you want to use that. I am sure there are other advantages too.

  • @votdev - Do you mean mount the disk in the VM, or in proxmox? OMV in the VM sees the filesystem and OMV manages the contents of fstab... I didn't expect to have to mount things manually and if I did, surely omv-mkconf would undo my changes next time the config is updated?

    donh - thanks, but I have specific reasons for not wanting all my data in a virtual disk file.

  • D'oh! Why did I not notice that button wasn't greyed?! Not one of my smarter days! Thank you!

    However... mounting it is throwing up an error when I apply the new config:

    Looks like it mounted, though; it's now there in the device list for shared folder creation.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!