OMV4 install on Raspberry Pi 3B+ No Network Interface(s) found

  • Apologies in advance for any shortcomings, I am a beginner with Raspberry Pi and this is my first attempt at setting up OMV on an ARM device (having done it several times though with full laptops or computers)
    I followed an installation process, which seems very similar to many others I have found since. These steps were performed with Raspberry Pi 3 B+, which I believe from the boot log info is ARMv7


    download this image - OMV_4_Raspberry_Pi_2_3_3Plus.img.xz
    burn it to SD card with Etcher
    pop it in the Pi and boot the board (after all cables connected)
    wait for install process to complete and Pi to reboot


    However, I noticed straight away none of the Ethernet link lights were showing, and on reboot I see "No Network Interface(s) found".
    I thought maybe I had gotten a bad device. But, I was able to burn Raspian to another SD card and boot the board with no issues, all ethernet and Wifi controllers worked fine.


    thanks in advance

  • I found some of your other posts, and I think maybe this issue was me trying to connect a monitor during the boot/install.
    I just flashed the SD card again and I am about to try the suggested "connect nothing but ethernet and power" approach. I will let it run through the install and update process and then verify if I am able to ping via DNS name.

  • This could be just a timing issue. What does happen if you use another machine in your network and do there a simple ping raspberrypi and ping raspberrypi.local?

    I let this install alone for several hours. When I ping raspberrypi, it appears my router has assigned an address of 192.168.*.*, but the ping test fails with timeout

  • using host name and not IP address

    Just to elaborate on this:

    • ping raspberrypi relies on the router's 'DHCP with dynamic DNS updates' feature (every modern router should be capable of today). Raspberries should always get the same MAC address when booting different OS images since the RPi kernel uses the SoC's serial number (which is not unique BTW but generated by a random number generator during production) to generate the MAC address
    • ping raspberrypi.local is not relying on any router features but on ZeroConf service discovery which works only in the local network using multicasts to announce/discover hosts and services. Unfortunately Microsoft implemented this just recently in Windows 10 so it can't work with older Windows versions (only with 3rd party software)

    So without knowing the Windows version in question it's hard to diagnose what's going on since relying on DNS entries in the router can fail and ZeroConf will only work reliably with Win10 :(

  • Try to ping using the two commands provided by @tkaiser
    i.e. using host name and not IP address.

    I did ping using raspberrypi and not an IP address. What I was saying is that the initial ping response was that it seemed to resolve to an IP address of 192.168.*.* in the range of my local network. Then I got a string of timeout errors.
    As for the source machine as @tkaiser mentioned, the ping to the raspberry pi was from a Mac running OSX Yosemite.
    The ping to raspberrypi.local was even less successful, I am not at the machine now, but I believe the error was along the line of "not found"

  • the ping to the raspberry pi was from a Mac running OSX Yosemite. The ping to raspberrypi.local was even less successful

    Then OMV is really not reachable. It's not only about not being able to access OMV's UI but the host is simply not present in the network.


    A major difference between OMV and Raspbian is that OMV sets the network interface manually to work with 100 Mbits/sek while Raspbian allows negotiating Gigabit Ethernet (which is broken BTW with the specific USB network adapter on the RPi 3B+). So in case your switch or router (the device the RPi is connected to via network cable) is not allowing Fast Ethernet (AFAIK then violating GbE specs) everything is as expected.

  • Then OMV is really not reachable. It's not only about not being able to access OMV's UI but the host is simply not present in the network.
    A major difference between OMV and Raspbian is that OMV sets the network interface manually to work with 100 Mbits/sek while Raspbian allows negotiating Gigabit Ethernet (which is broken BTW with the specific USB network adapter on the RPi 3B+). So in case your switch or router (the device the RPi is connected to via network cable) is not allowing Fast Ethernet (AFAIK then violating GbE specs) everything is as expected.

    So you are saying, with this, it may be worthwhile to review the settings on my router? Or, is it just a case of it won't work?

  • So you are saying, with this, it may be worthwhile to review the settings on my router?

    Yep. If you can adjust port settings there and they're not 'auto' switch them back to 'auto'.


    If you have both Ethernet and wireless on your MacBook you could also do a test with your MacBook playing the router. System Preferences --> Sharing --> Internet Sharing --> Share 'wireless' with computers using 'Ethernet'. Then connect the RPi directly via Ethernet cable to the MacBook, start it and try again a ping raspberrypi.local after a minute.

  • thanks for the help. The ethernet ports were set to auto on my router. I tried with a few different settings, setting them to auto, 100, 10, etc. but never any activity from the ethernet port on the RPi.
    I am moving on from OMV. I probably made a bad choice, from what I have read, trying to use a RPi and OMV for my NAS instead of some better SBC. I am just going to set up Raspian and a file share, that should serve my purposes. I am not happy, as I like OMV and the admin console aspect. But I don't want to cobble together some unsupported or esoteric solution to get OMV to work with the RPi. I feel like I would forever be troubleshooting some issue(s). I will probably eventually get a better SBC and a go forward with OMV from there. Thanks for all your help and the support you provide here @tkaiser

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!