Removed filesystem from a disk, data still on the disk

  • Hi everyone


    Say hello to the dumb guy of the day.
    I have OMV installed on a PI (not recommended, i know), 3 disks on it (no raid). I did it this way because i already had all the parts laying around, and wanted to "test" having a NAS at home.


    Anyway, it worked great for a year, but i recently decided to buy bigger drives, and build a dedicated server for it. The pi will be used as backup for my most important files.


    But first, i wanted to make a copy of all the files on one of the new drives, in case i break anything (...)
    The pi having a slow network connection (enough for my day to day needs, but not to copy entire drives other the network), i took one of the drives out of the pi, and plugged it on my main computer (w10).
    First, i found it strange that the drives wasn't recognized by my computer. I go to the disk manager, and there it appears, i can see it, but almost all the options are greyed out.
    I then decide to click on the only available one... (wait for it) ... "Delete the volume".


    And at this moment, i realize why my computer couldn't see the drive. It is an ext4 drive, and i don't have anything on my computer to read this filesystem.
    Well, it was an ext4 drive, because now even when i plug it back on my nas, it isn't recognized as the same drive as before. If i try to mount it back, it tells me that it will format the drive...which i would like to avoid at all cost.


    So, basically, my question here is this : can i access back the data on this drive ?
    I "think" i only deleted the filesystem on it, but all the data should still be on it, as i haven't written anything back on it since. In fact, i haven't done anything with it, since i clicked on "Delete the volume" in windows disk manager.


    I hope i'm in the right section here, don't hesitate to tell me if i'm not.


    Thank you for reading, any help would be greatly appreciated...

  • Thank you very much for the quick answer. It worked !
    (i hoped it was farily "easy" to fix, as the files had to still be there on the disk and it was more of a software "problem")
    For the record, i installed testdisk and followed this guide (changing ntfs to ext4, obviously)


    I'll mark the thread as solved.
    Thank you again !

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!