502 bad gateway nginx OMV 4 Rock64

  • Hi,
    I have running since few weeks properly my NAS on Rock64, today I tried found is not running. When I tried to log wia GUI i get a message 502 bad gateway nginx. I tried to update, bothing changed.


    Honestly, this is not the first time, I've taken the installation again from the beginning. It happened a few times, maybe because the quality of the SD card is low?


    root@NAS:~# omv-release-upgrade


    Get:1 file:/var/cache/openmediavault/archives InRelease
    Ign:1 file:/var/cache/openmediavault/archives InRelease
    Get:2 file:/var/cache/openmediavault/archives Release
    Ign:2 file:/var/cache/openmediavault/archives Release
    Get:3 file:/var/cache/openmediavault/archives Packages
    Ign:3 file:/var/cache/openmediavault/archives Packages
    Get:4 file:/var/cache/openmediavault/archives Translation-en
    Ign:4 file:/var/cache/openmediavault/archives Translation-en
    Get:3 file:/var/cache/openmediavault/archives Packages
    Ign:3 file:/var/cache/openmediavault/archives Packages
    Get:4 file:/var/cache/openmediavault/archives Translation-en
    Ign:4 file:/var/cache/openmediavault/archives Translation-en
    Get:3 file:/var/cache/openmediavault/archives Packages
    Ign:3 file:/var/cache/openmediavault/archives Packages
    Get:4 file:/var/cache/openmediavault/archives Translation-en
    Ign:4 file:/var/cache/openmediavault/archives Translation-en
    Get:3 file:/var/cache/openmediavault/archives Packages
    Ign:3 file:/var/cache/openmediavault/archives Packages
    Get:4 file:/var/cache/openmediavault/archives Translation-en
    Ign:4 file:/var/cache/openmediavault/archives Translation-en
    Get:3 file:/var/cache/openmediavault/archives Packages
    Ign:3 file:/var/cache/openmediavault/archives Packages
    Get:4 file:/var/cache/openmediavault/archives Translation-en
    Ign:4 file:/var/cache/openmediavault/archives Translation-en
    Get:3 file:/var/cache/openmediavault/archives Packages
    Get:4 file:/var/cache/openmediavault/archives Translation-en
    Ign:4 file:/var/cache/openmediavault/archives Translation-en
    Hit:5 http://security.debian.org stretch/updates InRelease
    Hit:6 http://ppa.launchpad.net/ayufan/rock64-ppa/ubuntu xenial InRelease
    Hit:7 http://packages.openmediavault.org/public arrakis InRelease
    Get:9 http://deb.ayufan.eu/orgs/ayufan-rock64/releases InRelease [1339 B]
    Hit:11 https://openmediavault.github.io/packages arrakis InRelease
    Ign:12 https://dl.bintray.com/openmed…plugin-developers/arrakis stretch InRelease
    Ign:8 http://cdn-fastly.deb.debian.org/debian stretch InRelease
    Get:14 https://dl.bintray.com/openmed…plugin-developers/arrakis stretch Release [4389 B]
    Hit:14 https://dl.bintray.com/openmed…plugin-developers/arrakis stretch Release
    Hit:10 http://cdn-fastly.deb.debian.org/debian stretch-updates InRelease
    Hit:13 http://cdn-fastly.deb.debian.org/debian stretch-backports InRelease
    Hit:15 http://cdn-fastly.deb.debian.org/debian stretch Release
    Fetched 1339 B in 12s (104 B/s)
    Exception ignored in: <function WeakValueDictionary.__init__.<locals>.remove at 0xf66f5468>
    Traceback (most recent call last):
    File "/usr/lib/python3.5/weakref.py", line 117, in remove
    TypeError: 'NoneType' object is not callable
    Exception ignored in: <function WeakValueDictionary.__init__.<locals>.remove at 0xf66f5468>
    Traceback (most recent call last):
    File "/usr/lib/python3.5/weakref.py", line 117, in remove
    TypeError: 'NoneType' object is not callable
    Reading package lists... Done
    W: Target Packages (main/binary-armhf/Packages) is configured multiple times in /etc/apt/sources.list.d/omv.list:1 and /etc/apt/sources.list.d/openmediavault.list:1
    W: Target Packages (main/binary-arm64/Packages) is configured multiple times in /etc/apt/sources.list.d/omv.list:1 and /etc/apt/sources.list.d/openmediavault.list:1
    W: Target Packages (main/binary-all/Packages) is configured multiple times in /etc/apt/sources.list.d/omv.list:1 and /etc/apt/sources.list.d/openmediavault.list:1
    W: Target Translations (main/i18n/Translation-en) is configured multiple times in /etc/apt/sources.list.d/omv.list:1 and /etc/apt/sources.list.d/openmediavault.list:1
    W: Target Packages (main/binary-armhf/Packages) is configured multiple times in /etc/apt/sources.list.d/omv.list:1 and /etc/apt/sources.list.d/openmediavault.list:1
    W: Target Packages (main/binary-arm64/Packages) is configured multiple times in /etc/apt/sources.list.d/omv.list:1 and /etc/apt/sources.list.d/openmediavault.list:1
    W: Target Packages (main/binary-all/Packages) is configured multiple times in /etc/apt/sources.list.d/omv.list:1 and /etc/apt/sources.list.d/openmediavault.list:1
    W: Target Translations (main/i18n/Translation-en) is configured multiple times in /etc/apt/sources.list.d/omv.list:1 and /etc/apt/sources.list.d/openmediavault.list:1
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Calculating upgrade... Done
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgrade

  • maybe because the quality of the SD card is low?

    Have you tested the card with H2testw on Windows or f3 on Linux?

    root@NAS:~# omv-release-upgrade

    This is the command to upgrade from one version to another. For example from OMV3 to OMV4.


    The command to update is omv-update. However as you are already on OMV4 and there is currently no newer version, the result is the same.

  • Have you tested the card with H2testw on Windows or f3 on Linux?

    This is the command to upgrade from one version to another. For example from OMV3 to OMV4.
    The command to update is omv-update. However as you are already on OMV4 and there is currently no newer version, the result is the same.

    No, I didn`t tested...


    Is the output of omv-firstaid, after choose 2 option, it ask about port (80) i pressed OK and then:


    ERROR: Failed to connect /var/lib/openmediavault/engined.sock: [Errno 111] Conne ction refused
    root@NAS:~#

  • Yes, see below


  • Since the nginx plugin is installed, I'm guessing there is some bad config in the server tab of that plugin. This is a good reason to use docker. What is the output of: sudo nginx -t (there really isn't a config test for php-fpm which may be the problem).

    omv 5.5.2 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.3.3
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Great. I didn't think nginx was the problem. So, it must be your config for fpm. I can't see your config though...

    omv 5.5.2 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.3.3
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Hmm, Is it any way You can help me?

    I have minimal time but I can't help you if you don't post any of your config.


    Of course I can install again, but I don`t like to do it every 5-6 weeks...

    Why would you have to reinstall? Just uninstall the nginx plugin and move it to docker if you ever plan on using OMV 5 - Why should you use or not use dockers

    omv 5.5.2 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.3.3
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • You have nothing configured in the nginx plugin. So, that isn't causing the problem.


    What about (as root)


    rm /var/run/php-fpm-openmediavault-webgui.sock
    systemctl restart php7.0-fpm.service

    omv 5.5.2 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.3.3
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Code
    root@NAS:~# rm /var/run/php-fpm-openmediavault-webgui.sock
    rm: cannot remove '/var/run/php-fpm-openmediavault-webgui.sock': No such file or directory
    root@NAS:~# systemctl restart php7.0-fpm.service
    Job for php7.0-fpm.service failed because a fatal signal was delivered to the control process.
    See "systemctl status php7.0-fpm.service" and "journalctl -xe" for details.
    root@NAS:~#

    Btw. which version of OMV release is the best for Rock64 ? Which is the most stable version?

  • which version of OMV release is the best for Rock64 ? Which is the most stable version?

    4.x is the best for all supported devices including the rock64. This seems like a bad SD card. Is it new and good quality?

    omv 5.5.2 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.3.3
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • 4.x is the best for all supported devices including the rock64. This seems like a bad SD card. Is it new and good quality?

    To be honestly I`m afraid is a low quality of SD card...I will buy a newone. Some like below it is fine?


    https://sandisk-store.pl/pl/p/…U3-Karta-Pamieci/23078068


    https://sandisk-store.pl/pl/p/…10-UHS-I-ADAPTER/23078283



    Is it important which release? ayufan v armbian?


    I see link for image is not active:
    OMV for ROCK64 (and other RK3328 devices soon)

  • Some like below it is fine?

    Should be ok. A1 or A2 rated cards from good manufacturer.


    Is it important which release? ayufan v armbian?

    Use the Rock64 image from here - https://sourceforge.net/projec…ngle%20Board%20Computers/

    omv 5.5.2 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.3.3
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!