[HowTo] WireGuard with OMV Super-Easy

  • Ok so I removed all of the WG packages, did update and upgrade, rebooted, and finally the script ran until the end!


    I have forwarded the port on my router and the iOS client connects via the QR code although I can't get any internet or local traffic while connected.


    Slowly getting there...

  • I tried with the Mac client, same result. It says its connected but nothing passes though. No difference when I run wg as well.


    I'm beginning to think it may be my shitty isp router. I had a IPsec VPN docker working for ages but one day all my devices stopped sending data even though they were connected, all except my android phone for some strange reason. Its the only reason I have been looking for another option.


    In any case here is the log from the Mac.


  • Got this reply with an email but its not in the forum


    ---------------------------------
    Zitat: „no known endpoint for peer

    Is there an Endpoint specified under Peer in the conf of your iOS machine? Should be the external of your router or a dyndns address + the port (e.g. http://my.domain.com:51820)


    ---------------------------------


    I added xx.xx.xx.xx:51820 to the iOS settings but it made no difference

  • I have been messing around with the IP addresses in the script, so this isn't the same a before, but it has the same outcome - I can connect fine but no data transfers


    On OMV;



    Code
    [Interface]
    Address = 192.168.1.0/24 SaveConfig = true
    ListenPort = 51820 PostUp = iptables -A FORWARD -i wgnet0 -j ACCEPT; iptables -A FORWARD -o $
    PostDown = iptables -D FORWARD -i wgnet0 -j ACCEPT; iptables -D FORWARD -$
    PrivateKey = APdxxx=
    [Peer]
    PublicKey = qlRxxx=
    AllowedIPs = 192.168.1.0/24

    On the iPad;


    [Interface]


    Public key = qlRxxx=
    Addresses = 192.168.1.0/24


    [Peer]
    Public Key = LB9xxx=
    Allowed IPs = 0.0.0.0/0

  • The IP configs look incorrect cause now both machines have the same IP. Try these confs. I reverted the IP adresses, cause they worked for me without changing them. To understand the workings of Wireguard I also suggest reading the main introduction on wireguard.com



    and on the iPad:

    Code
    [Interface]
    Public key = qlRxxx=
    Addresses = 10.192.122.2/24
    [Peer]
    Public Key = LB9xxx=
    Allowed IPs = 0.0.0.0/0
    Endpoint = yourserverip:51820
  • Unfortunately no luck with that.


    Thanks for your help with this but I am going to give PiVPN a go. I will also see if I can somehow replace my router, this is the 3rd VPN that I cant get to work, so surely it must be a router problem or a problem with my system...


    Is there a recommended was to uninstall everything?

  • So I really like Wireguard as I have used it on my Unraid server where it is implemented beautifuly and performs really well.
    I tried the script but couldn't get it to work, I get the same errors as @aykaydub.
    At first I also didn't set my network device.
    Then I uninstalled everything like this (don't know if correct):

    • rm -r /etc/wireguard
    • apt purge wireguard
    • apt purge qrencode
    • apt purge miniupnpc
    • rm /etc/apt/sources.list.d/unstable-wireguard.list
    • rm /etc/apt/preferences.d/limit-unstable
    • apt autoremove

    Then I run the script again with the correct network device, but I still couldn't get the script to finish...


    I also tried @ryecoaarons plugin but this says there are unmet dependencies.
    Doesn't mention which but I figured it might be the wirguard-tools from @Morlans post.
    I am running OMV5 on amd64 though...
    So I tried uploading wireguard-tools_0.0.20190702-3_amd64.deb but it says its not matching the naming convention.


    So I would be really happy for some advice :)


    Edit:
    Tried to install wireguard tools manually:
    apt install /sharedfolders/data/wireguard-tools_0.0.20190702-3_amd64.deb
    Then tried to install the plugin again, but still no luck...

  • How did you get the plugin? If you enabled the beta repo (has to be done from command line), then the dependencies are there. If not and you just downloaded the plugin .deb, you will need to download the wireguard .deb packages as well. Download wireguard, wireguard-tools, wireguard-dkms from https://bintray.com/openmediav…ugin-developers/usul-beta

    omv 5.5.17-2 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.4.2
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!