HardDisk gets automatically unmounted

  • Hi,

    I have a setup with Raspberry Pi 3, connected to a WD Purple 1 TB internal hard disk, via a hard disk enclosure. The setup is generally stable. I am able to stream videos via DLNA / FTP. I am able to keep the setup running for days together, and all is good.

    However, when I have data writes happening, the hard disk automatically gets unmounted. OMV keeps running, so the share is still accessible, but filesystems within that share go missing. The only solution I have, is to login into the portal, and remount the specific hard disk.

    I've tried different combinations of the spin down configurations, and they do not seem to help. I know OMV isn't affected, since it keeps running. Only the hard disk gets unmounted, and I am trying to isolate the problem. I think its the hard disk auto spin down, or some problem with the external hard disk enclosure?

    Any inputs help.


  • Have an update.

    I see some time after the drive has been manually mounted, a new entry for a new disk gets created under "File System", with the old one turning to status "Missing". The new one says, "Online". After a few seconds, the "Missing" entry disappears, and the only one active is the new entry that says "Online".

    Now the new entry is not yet mounted, so that needs to be mounted manually.
    That's a little more detail into the problem.

    Would help if anyone throws a bit of light on whats happening here.

  • Ok.. another update. I connected the same hard disk, with its enclosure, to a desktop running USB.. and had constant writes happen for a over a day... things seemed normal.. so I am sure this is not a hardware issue..

    The issue now boils down to either,

    • The Raspberry Pi - Unable to keep a externally powered hard disk enclosure connected, for some reason.
    • Raspbian - Inadvertently unmounts my disk for some reason
    • OMV - Unable to consistently connect to the mounted drive

    Feels like OMV is the least of the culprits here.
    Hoping this is similar to the issue mentioned in,

    * Still hope someone joins me on the thread :)

    - Immanuel

  • It might be a lack of power issue, the pi power adapter might not be powerful enough. Try to connect the HDD to a USB powered hub. I've faced the same problem with external HDD, with 1 connected worked just fine, but when I plugged a second one it got disconnected when working on it.

  • I wonder if this relates to the newly released bug/fix:

    openmediavault 5.5.17

    WARNING … This update might cause problems on systems that are using USB hardware based on JMicron controllers.

    • Update locales.
    • Issue #842: Fix bug in UDEV rules to workaround a JMicron bug. If your USB controller reports the vendor ‘JMICRON’, then you might be affected by this issue. After installing this package your mounted filesystem configuration might be broken. To fix that, you need to unmount and remount the filesystems that are connected via this USB controller. If the filesystem contains any shared folders, you can’t unmount it, because of that you need to delete all shared folders that are located on the filesystem to be unmounted. Make sure to choose the right menu to only delete the shared folder configuration WITHOUT the content. You can only delete shared folders they are not used by any service, so make sure this applies to these shared folders. After you’ve unmounted these filesystems in the UI, apply the changes, reboot the system and then mount the filesystems again. After that you can reconfigure your shared folders and services from scratch. Sorry for this inconvenience.
    • Issue #846: Fix locking issue in SMB recycle bin cleanup and iptables scripts.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!