OMV 5.0 - finally out! :-)

  • It was a DNS resolve problem and i couldn't resolve the problem.


    So first i will restore a backup from OMV 4.x i made yesterday.


    Then i will start the upgrade again.


    When i run into problems, i will post them here again.


    Btw:

    Is it a problem to make the upgrade via SSH?


    Hylli

  • Is it a problem to make the upgrade via SSH?

    Every upgrade I have done is via ssh.

    omv 6.0.8-1 Shaitan | 64 bit | 5.15 proxmox kernel | omvextrasorg 6.0.5 | kvm plugin 6.0.3
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • OK, let the upgrade game begin. ;)


    First command and after i confirmed the keyboard layout (actual keyboard layout), i get the following error:


    I get the same error, when changing weakref.py with this workaround:

    RE: Upgrade Debian 9 and 4.x


    Error:

    Hylli

  • Ich würde vorschlagen erstens auf Englisch um zu schalten.

    You don't have to switch to english, at least it worked for me without changing the language.

    [LibreELEC @ 2x RPi3, CoreELEC @ S12 Octa Core]

    [ NAS OMV 5.xx (Usul) @ NanoPI M4 ]

    [ Nextcloud 18.0.4 @ ODROID C2 ]

    [ Motioneye @ RPi4]

  • I get the same error, when changing weakref.py with this workaround:

    It is a warning and isn't needed for OMV 5.x. You can ignore that.

    omv 6.0.8-1 Shaitan | 64 bit | 5.15 proxmox kernel | omvextrasorg 6.0.5 | kvm plugin 6.0.3
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • ...and the error with base-files?

    Quote

    Fehler traten auf beim Bearbeiten von:

    base-files

    E: Sub-process /usr/bin/dpkg returned an error code (1)

    Can i ignore that and go to the next steps?

    reboot

    apt-get purge openmediavault-omvextrasorg resolvconf

    ...


    Hylli

  • Can i ignore that and go to the next steps?

    Nope. That means a file didn't install or uninstall correctly. You have to post all output for people to help with that.

    omv 6.0.8-1 Shaitan | 64 bit | 5.15 proxmox kernel | omvextrasorg 6.0.5 | kvm plugin 6.0.3
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • It was in his post #307.

    No, it did not have all of the output I was looking for. The pastebin had exactly what I was looking for.

    What's the next step?

    There is something wrong with your base-files package. I would try to re-install it with apt-get install --reinstall base-files then apt-get -f install then download and run the upgrade script again (I made a couple of improvements based on your output).

    omv 6.0.8-1 Shaitan | 64 bit | 5.15 proxmox kernel | omvextrasorg 6.0.5 | kvm plugin 6.0.3
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Hm, reinstall of package base-files is not possible:

    Hylli

  • reinstall of package base-files is not possible

    You may have to revert to backup and start over.

    omv 6.0.8-1 Shaitan | 64 bit | 5.15 proxmox kernel | omvextrasorg 6.0.5 | kvm plugin 6.0.3
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Hello,

    I'm running omv4 w/pve kernel as a guest on proxmox 6. Can I use this script to upgrade to 5? Does it matter that I originally installed debian and then OMV on top of it? Since I'm running a VM, I assume if anything gets screwed up I can just restore the VM from backup. Even so I might clone the VM and try running the upgrade on the clone first. Although the clone won't be using the pci passthrough HBA card. The only plugins i'm using are resetperms, unionfilesystems, and snapraid. Finally, do I need to unmount all the data drives before running the upgrade?


    Thanks

  • Can I use this script to upgrade to 5?

    Yes


    Does it matter that I originally installed debian and then OMV on top of it?

    It shouldn't as long as the install isn't too custom.


    Since I'm running a VM, I assume if anything gets screwed up I can just restore the VM from backup.

    Just take a snapshot. If the upgrade fails, revert to snapshot. It won't snap the passthrough drives though.

    omv 6.0.8-1 Shaitan | 64 bit | 5.15 proxmox kernel | omvextrasorg 6.0.5 | kvm plugin 6.0.3
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • I reverted to backup and started over again.


    Before i started the upgrade i changed the weakref.py as mentioned in this workaround:

    RE: Upgrade Debian 9 and 4.x


    After reboot i reinstalled base-filessuccessfully without any errors or warnings:

    Then i started the upgrade with...

    wget -O - https://github.com/OpenMediaVault-Plugin-Developers/installScript/raw/master/upgrade4to5 | sudo bash

    ...but the error with base-files still exists. Here is the full log:

    https://pastebin.com/PKnPijvX


    Last lines of the full log:

    Reinstallation of base-files gives me same error as earlier today:

    Because of this

    Quote

    dpkg: error processing package base-files (--configure)

    i executed this command:

    dpkg -- configure -a

    This was successful!


    So i reinstalled base-files again with:

    apt-get install --reinstall base-files

    Now the reinstallation worked succesfully:


    Now i started the upgrade script again and i thought it worked correctly. But at the end i got the following errors:


    Full log:

    https://pastebin.com/ZA7iQCAJ


    So i executed another time this:

    dpkg --configure -a


    Log:

    Can i now go to the next steps Reboot and Purge OMV-Extras...


    Hylli

  • Before i started the upgrade i changed the weakref.py as mentioned in this workaround:

    Why? It is just a warning.


    Are these errors OK?

    NO. I don't know why you are still getting prompts for upgrade decisions and it errors at every one of them. I changed the script to be non-interactive so it wouldn't prompt but it still is. Maybe the locale? Not sure.

    omv 6.0.8-1 Shaitan | 64 bit | 5.15 proxmox kernel | omvextrasorg 6.0.5 | kvm plugin 6.0.3
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!