RPI4 OMV WiFi

  • Hi,


    I am trying to setup OMV on RPI4 for NAS.
    I need to use Onboard WiFi that RPI4 has.
    How to enable it in OMV?


    In OMV WebGui under interfaces it does not show wlan adapter.
    Also in ssh command line 'nmtui' only lists wired connection.


    Please help!
    Thanks,
    Sam

  • Upon further debug-


    1. Tried to boot from a clean SD card (new etcher install, etcher reported success)
    2. Added a user as sudo
    3. ssh with this user, and did dmesg | grep brcm. It shows-


    $ dmesg | grep brcm
    [ 0.217768] brcm-pcie fd500000.pcie: could not get clock
    [ 0.217824] brcm-pcie fd500000.pcie: host bridge /scb/pcie@7d500000 ranges:
    [ 0.217860] brcm-pcie fd500000.pcie: MEM 0x600000000..0x603ffffff -> 0xf8000000
    [ 0.281578] brcm-pcie fd500000.pcie: link up, 5.0 Gbps x1 (!SSC)
    [ 0.281824] brcm-pcie fd500000.pcie: PCI host bridge to bus 0000:00
    [ 0.845561] brcmstb_thermal fd5d2200.thermal: registered AVS TMON of-sensor driver
    [ 4.913222] brcmfmac: F1 signature read @0x18000000=0x15264345
    [ 4.923550] brcmfmac: brcmf_fw_alloc_request: using brcm/brcmfmac43455-sdio for chip BCM4345/6
    [ 4.923887] usbcore: registered new interface driver brcmfmac
    [ 4.938906] brcmfmac mmc1:0001:1: Direct firmware load for brcm/brcmfmac43455-sdio.txt failed with error -2
    [ 5.941662] brcmfmac: brcmf_sdio_htclk: HT Avail timeout (1000000): clkctl 0x50


    Please help!


    Thanks,
    Sam

  • Another update-
    I followed steps in this thread and the driver/firmware seems to work-
    https://www.linuxquestions.org…nic-not-found-4175627137/


    Now the output of dmesg is-
    root@raspberrypi:/usr/src# dmesg | grep brcm
    [ 0.217743] brcm-pcie fd500000.pcie: could not get clock
    [ 0.217799] brcm-pcie fd500000.pcie: host bridge /scb/pcie@7d500000 ranges:
    [ 0.217834] brcm-pcie fd500000.pcie: MEM 0x600000000..0x603ffffff -> 0xf8000000
    [ 0.271557] brcm-pcie fd500000.pcie: link up, 5.0 Gbps x1 (!SSC)
    [ 0.271802] brcm-pcie fd500000.pcie: PCI host bridge to bus 0000:00
    [ 0.825373] brcmstb_thermal fd5d2200.thermal: registered AVS TMON of-sensor driver
    [ 3.190740] brcmfmac: F1 signature read @0x18000000=0x15264345
    [ 3.199930] brcmfmac: brcmf_fw_alloc_request: using brcm/brcmfmac43455-sdio for chip BCM4345/6
    [ 3.200543] usbcore: registered new interface driver brcmfmac
    [ 4.331921] brcmfmac: brcmf_sdio_htclk: HT Avail timeout (1000000): clkctl 0x50
    [ 5.341649] brcmfmac: brcmf_sdio_htclk: HT Avail timeout (1000000): clkctl 0x50



    However even with this, cannot use WiFi-


    iwconfig
    eth0 no wireless extensions.


    lo no wireless extensions.


    nmtui does not show wireless yet.


    I also tried connecting external USB3.0 rtl8812au WiFi Dongle, it gets detected and drivers are installed. But iwconfig / nmtui does not show WiFI.


    Something seems wrong in OMV 4 for RPI?
    Why is this happening?
    Please help!

  • Hello,


    I was having the same problem as you regarding WiFi on the RPI4, but just managed to get it to work.


    The steps shown in https://www.linuxquestions.org…nic-not-found-4175627137/ are correct, with one exception: all references to the firmware-brcm80211_20161130-3+rpt3_all.deb file ('wget' and 'ar') must be changed to firmware-brcm80211_20190114-1+rpt2_all.deb.


    Another difference in my case is that I copied all the files extracted under 'lib/firmware/brcm/' to the RPI's '/lib/firmware/brcm/' directory, not just the three files mentioned in the link. This probably doesn't change the end result, but doesn't seem to hurt either.


    Hope this works for you!

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!