Docker update and all broken :(

  • Dunno what happened, but I had some docker updates, ran them and well docker is gone.
    Got this error:


    I ran apt-get install docker-ce as it didnt work on UI.
    docker-ce is already the newest version (5:19.03.0~3-0~debian-stretch).


    Yet I still cannot install docker-gui and well kinda sucks managing dockers without the gui.
    Dockers still seem to be up and running.


    Any way I can get GUI back, or is there something OMV-Extras needs to update?

  • I can second savellm. Same for me. Docker is running, containers are working fine. But in the omv gui docker is completely gone.


    Installation of openmediavault-docker-gui 4.1.4 results in the above error messages.

    HP Microserver Gen8 - 16GB RAM - 1x Kingston 120 GB SSD - 4x 3TB WD Red / ZFS - OMV 5.2.x bare metal - Docker running Plex, TimeMachine - Synology DS214 with 2x 4TB WD Red for rsync backup

  • This update is causing the Pi-Hole container to crash (and restart) every 4.5 to 5 minutes. It also makes the Pi-Hole GUI inaccessible.

    Did you try deleting the image and re-running? I'm not having any issues with any other images.

    omv 5.5.11 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.3.6
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • I'm kinda stuck here too.... Docker in GUI gone, trying to install openmediavault-docker-gui again gives me the error:
    >>> *************** Error ***************Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C.UTF-8; export DEBIAN_FRONTEND=noninteractive; apt-get --yes --allow-downgrades --allow-change-held-packages --fix-missing --allow-unauthenticated --reinstall install openmediavault-docker-gui 2>&1' with exit code '100': Reading package lists...

    Building dependency tree...

    Reading state information...

    Some packages could not be installed. This may mean that you haverequested an impossible situation or if you are using the unstabledistribution that some required packages have not yet been createdor been moved out of Incoming.The following information may help to resolve the situation:

    The following packages have unmet dependencies: openmediavault-docker-gui : Depends: openmediavault-omvextrasorg (>= 4.1.15) but 4.1.13 is to be installedE: Unable to correct problems, you have held broken packages.<<< *************************************


    Cannot install version 4.1.5. What now?

  • I'm gonna have to agree w/ @savellm . That should solve the problem. That said, I've been using Portainer on my OMV 5 test and am really starting to like it as compared to the omv docker plugin. No disrespect to anyone who's worked on the docker plugin, I'm just really liking Portainer. I've put Portainer on my OMV 4 stable box now and am seriously considering removing the webUI plugin.

    Air Conditioners are a lot like PC's... They work great until you open Windows.


    Edited once, last by KM0201 ().

  • Why not just apt-get install docker-ce (so that its the latest version) and then then the docker-gui should install fine.
    OR otherwise apt-get install openmediavault-docker-gui try that.

    Code
    root@LianLi:~# apt install docker-ce
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    docker-ce is already the newest version (5:19.03.0~3-0~debian-stretch).
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

    Tried it but again failed - docker-ce is already the latest, I just cannot install docker-gui. I've already rebooted the machine, no change getting the same error.

  • Portainer has a whole dedicated team, and github support.
    So yeah I think it would just naturally get better and more support, as well it has tons more devs.


    But maybe in OMV5 they can use/include it as default instead?

    ryecoaaron mentioned in a long thread here somewhere that is the plan for OMV 5. I believe the intent is to install it in the webUI, and then either launch it manually or have a shortcut type link in the webUI that will launch Portainer.

  • pretty much nothing...


  • That is weird. I had a problem the other night like everyone else, but when I upgraded again it went to 4.1.15 w/o issue.


    Personally, I'd embrace the horror and purge the docker-gui plugin, install Portainer, and learn it now..... Everything is headed that direction anyway. Once you get the hang of it, it is extremely easy and very versatile.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!