ZFS missing after update

  • Hello,


    after i updated my OMV to 4.1.23-1 my ZFS Plugin is lost and i cannot reinstall it.
    Message:
    openmediavault-zfs: Depends: zfsutils-linux but is not going to be installed and Depends: zfs-zed but it is not going to be installed


    If i try install zfsutils by using apt it says:
    zfsutils-linux : Collides with: insserv (< 1.18) but 1.14.0-5.4+b1 must be installed


    Any idea how i can fix this Problem?



    Best regards
    Daniel

  • 1. Cleaning apt cache files...



    2. Clearing available dpkg packages...



    3. Removing apt lists...
    removed '/var/lib/apt/lists/_var_cache_openmediavault_archives_Packages'
    removed '/var/lib/apt/lists/dl.bintray.com_openmediavault-plugin-developers_arrakis-docker_dists_stretch_Release'
    removed '/var/lib/apt/lists/dl.bintray.com_openmediavault-plugin-developers_arrakis-docker_dists_stretch_Release.gpg'
    removed '/var/lib/apt/lists/dl.bintray.com_openmediavault-plugin-developers_arrakis-docker_dists_stretch_main_binary-amd64_Packages'
    removed '/var/lib/apt/lists/dl.bintray.com_openmediavault-plugin-developers_arrakis-testing_dists_stretch_Release'
    removed '/var/lib/apt/lists/dl.bintray.com_openmediavault-plugin-developers_arrakis-testing_dists_stretch_Release.gpg'
    removed '/var/lib/apt/lists/dl.bintray.com_openmediavault-plugin-developers_arrakis-testing_dists_stretch_main_binary-amd64_Packages'
    removed '/var/lib/apt/lists/dl.bintray.com_openmediavault-plugin-developers_arrakis_dists_stretch_Release'
    removed '/var/lib/apt/lists/dl.bintray.com_openmediavault-plugin-developers_arrakis_dists_stretch_Release.gpg'
    removed '/var/lib/apt/lists/dl.bintray.com_openmediavault-plugin-developers_arrakis_dists_stretch_main_binary-amd64_Packages'
    removed '/var/lib/apt/lists/download.docker.com_linux_debian_dists_stretch_InRelease'
    removed '/var/lib/apt/lists/download.docker.com_linux_debian_dists_stretch_stable_binary-amd64_Packages'
    removed '/var/lib/apt/lists/httpredir.debian.org_debian_dists_stretch-backports_InRelease'
    removed '/var/lib/apt/lists/httpredir.debian.org_debian_dists_stretch-backports_contrib_binary-amd64_Packages'
    removed '/var/lib/apt/lists/httpredir.debian.org_debian_dists_stretch-backports_contrib_i18n_Translation-en'
    removed '/var/lib/apt/lists/httpredir.debian.org_debian_dists_stretch-backports_main_binary-amd64_Packages'
    removed '/var/lib/apt/lists/httpredir.debian.org_debian_dists_stretch-backports_main_binary-amd64_Packages.diff_Index'
    removed '/var/lib/apt/lists/httpredir.debian.org_debian_dists_stretch-backports_main_i18n_Translation-en'
    removed '/var/lib/apt/lists/httpredir.debian.org_debian_dists_stretch-backports_non-free_binary-amd64_Packages'
    removed '/var/lib/apt/lists/httpredir.debian.org_debian_dists_stretch-backports_non-free_i18n_Translation-en'
    removed '/var/lib/apt/lists/lock'
    removed '/var/lib/apt/lists/mirror.1und1.de_debian_dists_stretch-updates_InRelease'
    removed '/var/lib/apt/lists/mirror.1und1.de_debian_dists_stretch-updates_main_binary-amd64_Packages'
    removed '/var/lib/apt/lists/mirror.1und1.de_debian_dists_stretch-updates_main_i18n_Translation-en'
    removed '/var/lib/apt/lists/mirror.1und1.de_debian_dists_stretch-updates_main_source_Sources'
    removed '/var/lib/apt/lists/mirror.1und1.de_debian_dists_stretch_Release'
    removed '/var/lib/apt/lists/mirror.1und1.de_debian_dists_stretch_Release.gpg'
    removed '/var/lib/apt/lists/mirror.1und1.de_debian_dists_stretch_main_binary-amd64_Packages'
    removed '/var/lib/apt/lists/mirror.1und1.de_debian_dists_stretch_main_i18n_Translation-de'
    removed '/var/lib/apt/lists/mirror.1und1.de_debian_dists_stretch_main_i18n_Translation-de%5fDE'
    removed '/var/lib/apt/lists/mirror.1und1.de_debian_dists_stretch_main_i18n_Translation-en'
    removed '/var/lib/apt/lists/mirror.1und1.de_debian_dists_stretch_main_source_Sources'
    removed '/var/lib/apt/lists/openmediavault.github.io_packages_dists_arrakis_InRelease'
    removed '/var/lib/apt/lists/openmediavault.github.io_packages_dists_arrakis_main_binary-amd64_Packages'
    removed '/var/lib/apt/lists/packages.openmediavault.org_public_dists_arrakis_InRelease'
    removed '/var/lib/apt/lists/packages.openmediavault.org_public_dists_arrakis_main_binary-amd64_Packages'
    removed directory '/var/lib/apt/lists/partial'
    removed '/var/lib/apt/lists/security.debian.org_dists_stretch_updates_InRelease'
    removed '/var/lib/apt/lists/security.debian.org_dists_stretch_updates_contrib_binary-amd64_Packages'
    removed '/var/lib/apt/lists/security.debian.org_dists_stretch_updates_contrib_i18n_Translation-en'
    removed '/var/lib/apt/lists/security.debian.org_dists_stretch_updates_contrib_source_Sources'
    removed '/var/lib/apt/lists/security.debian.org_dists_stretch_updates_main_binary-amd64_Packages'
    removed '/var/lib/apt/lists/security.debian.org_dists_stretch_updates_main_i18n_Translation-en'
    removed '/var/lib/apt/lists/security.debian.org_dists_stretch_updates_main_source_Sources'
    removed '/var/lib/apt/lists/security.debian.org_dists_stretch_updates_non-free_binary-amd64_Packages'
    removed '/var/lib/apt/lists/security.debian.org_dists_stretch_updates_non-free_i18n_Translation-en'
    removed '/var/lib/apt/lists/security.debian.org_dists_stretch_updates_non-free_source_Sources'



    4. Purging internal cache ...

  • 4. Purging internal cache ...



    5. Removing OpenMediaVault cache packages...
    removed '/var/cache/openmediavault/archives/Packages'





    6. Creating new OpenMediaVault packages file...





    7. Updating apt...
    Get:1 file:/var/cache/openmediavault/archives InRelease
    Ign:1 file:/var/cache/openmediavault/archives InRelease
    Get:2 file:/var/cache/openmediavault/archives Release
    Ign:2 file:/var/cache/openmediavault/archives Release
    Get:3 file:/var/cache/openmediavault/archives Packages
    Ign:3 file:/var/cache/openmediavault/archives Packages
    Get:4 file:/var/cache/openmediavault/archives Translation-en
    Ign:4 file:/var/cache/openmediavault/archives Translation-en
    Get:3 file:/var/cache/openmediavault/archives Packages
    Ign:3 file:/var/cache/openmediavault/archives Packages
    Get:4 file:/var/cache/openmediavault/archives Translation-en
    Ign:4 file:/var/cache/openmediavault/archives Translation-en
    Get:3 file:/var/cache/openmediavault/archives Packages
    Ign:3 file:/var/cache/openmediavault/archives Packages
    Get:4 file:/var/cache/openmediavault/archives Translation-en
    Ign:4 file:/var/cache/openmediavault/archives Translation-en
    Get:3 file:/var/cache/openmediavault/archives Packages
    Ign:3 file:/var/cache/openmediavault/archives Packages
    Get:4 file:/var/cache/openmediavault/archives Translation-en
    Ign:4 file:/var/cache/openmediavault/archives Translation-en
    Get:3 file:/var/cache/openmediavault/archives Packages
    Ign:3 file:/var/cache/openmediavault/archives Packages
    Get:4 file:/var/cache/openmediavault/archives Translation-en
    Ign:4 file:/var/cache/openmediavault/archives Translation-en
    Get:3 file:/var/cache/openmediavault/archives Packages
    Get:4 file:/var/cache/openmediavault/archives Translation-en
    Ign:4 file:/var/cache/openmediavault/archives Translation-en
    Get:5 http://security.debian.org stretch/updates InRelease [94.3 kB]
    Get:8 http://packages.openmediavault.org/public arrakis InRelease [12.8 kB]
    Ign:6 http://mirror.eu.oneandone.net/debian stretch InRelease
    Get:7 http://mirror.eu.oneandone.net/debian stretch-updates InRelease [91.0 kB]
    Get:9 http://mirror.eu.oneandone.net/debian stretch Release [118 kB]
    Get:11 http://mirror.eu.oneandone.net/debian stretch Release.gpg [2434 B]
    Get:10 http://cdn-fastly.deb.debian.org/debian stretch-backports InRelease [91.8 kB]
    Get:12 https://openmediavault.github.io/packages arrakis InRelease [12.8 kB]
    Get:13 https://download.docker.com/linux/debian stretch InRelease [44.8 kB]
    Ign:14 https://dl.bintray.com/openmed…plugin-developers/arrakis stretch InRelease
    Ign:15 https://dl.bintray.com/openmed…evelopers/arrakis-testing stretch InRelease
    Ign:16 https://dl.bintray.com/openmed…developers/arrakis-docker stretch InRelease
    Get:17 https://dl.bintray.com/openmed…plugin-developers/arrakis stretch Release [4389 B]
    Get:18 https://dl.bintray.com/openmed…evelopers/arrakis-testing stretch Release [5214 B]
    Get:19 https://dl.bintray.com/openmed…developers/arrakis-docker stretch Release [3540 B]
    Get:20 https://dl.bintray.com/openmed…plugin-developers/arrakis stretch Release.gpg [821 B]
    Get:21 https://dl.bintray.com/openmed…evelopers/arrakis-testing stretch Release.gpg [821 B]
    Get:22 https://dl.bintray.com/openmed…developers/arrakis-docker stretch Release.gpg [821 B]
    Get:23 http://security.debian.org stretch/updates/non-free Sources [1216 B]
    Get:24 http://security.debian.org stretch/updates/contrib Sources [1384

  • Nothing changed


    Reading package lists...
    Building dependency tree...
    Reading state information...
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:


    The following packages have unmet dependencies:


    >>> *************** Error ***************
    Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C.UTF-8; export DEBIAN_FRONTEND=noninteractive; apt-get --yes --allow-downgrades --allow-change-held-packages --fix-missing --allow-unauthenticated --reinstall install openmediavault-zfs 2>&1' with exit code '100': Reading package lists...


    Building dependency tree...


    Reading state information...


    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:


    The following packages have unmet dependencies:
    openmediavault-zfs : Depends: zfsutils-linux but it is not going to be installed
    Depends: zfs-zed but it is not going to be installed
    E: Unable to correct problems, you have held broken packages.
    <<< *************************************




    Gesendet von meinem Mi 9 SE mit Tapatalk

  • Strange... What is the output of the following commands:


    apt-cache policy zfsutils-linux zfs-zed
    apt-get -f install

    omv 5.5.5 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.3.5
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • I'm having the exact same behavior/issue. Kind of a showstopper for me. Using OMV 4.1.23-1. After most recent update, suddenly no ZFS, and exact same symptoms/errors as D.Wagner89 above.


    My results for the two requested commands above:


    root@nas2:/primary# apt-cache policy zfsutils-linux zfs-zed
    zfsutils-linux:
    Installed: (none)
    Candidate: 0.7.12-2+deb10u1~bpo9+1
    Version table:
    0.7.12-2+deb10u1~bpo9+1 500
    100 http://httpredir.debian.org/debian stretch-backports/contrib amd64 Packages
    0.7.12-1~bpo9+1 -1
    100 /var/lib/dpkg/status
    zfs-zed:
    Installed: (none)
    Candidate: 0.7.12-2+deb10u1~bpo9+1
    Version table:
    0.7.12-2+deb10u1~bpo9+1 500
    100 http://httpredir.debian.org/debian stretch-backports/contrib amd64 Packages
    0.7.12-1~bpo9+1 -1
    100 /var/lib/dpkg/status
    root@nas2:/primary# apt-get -f install
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

  • More "college try" stuff:


    root@nas2:/primary# apt-get -f install zfsutils-linux zfs-zed
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:


    The following packages have unmet dependencies:
    zfsutils-linux : Conflicts: insserv (< 1.18) but 1.14.0-5.4+b1 is to be installed
    E: Unable to correct problems, you have held broken packages.
    root@nas2:/primary# apt install insserv
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    insserv is already the newest version (1.14.0-5.4+b1).
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

  • Got the other one fixed. Somehow something in the /etc/apt/sources.list.d got lost and I had to recreate the omv-extras-org.list file by hand. Once I did that the zfs plugin showed back up and after a little more fiddling I'm good now.

  • I had to recreate the omv-extras-org.list file by hand

    You should never have to do that. omv-mkconf omvextras will do that. Making any change in the omv-extras plugin would do that as well (ie enable then disable a repo).

    apt install insserv

    I don't know why insserv would cause the problem.

    omv 5.5.5 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.3.5
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Googled around and found this page: https://forum.proxmox.com/thre…to-5-3.52622/#post-243591
    which implies I just needed to purge stuff. I've done that and I'm past the behavior above. I got one of my two boxes back up. The other one I'm having trouble seeing the ZFS plugin, but I assume once I get that back somehow (I'll upload the plugin manually if it comes to that) I should be good.


    I did this like they write:



    apt -f installapt purge insserv sysv-rc initscripts


    openrcapt update && apt full-upgrade


    After that i tried installing ZFS again but it didnt worked.
    I rebooted my NAS and reinstalled zfsutils-linux manually


    apt install zfsutils-linux


    After that openmediavault-zfs automaticly show up again and i was able to impoort my pools
    Thanks for your support guys

  • Hi,


    apt purge insserv sysv-rc initscripts openrc
    definitely helped as now I don't get complains about the "insserv" version any longer.


    When I try to install "openmediavault-zfs" though, it fails with the below:


    my current kernel:


    # uname -aLinux willy 4.18.0-0.bpo.1-amd64 #1 SMP Debian 4.18.6-1~bpo9+1 (2018-09-13) x86_64 GNU/Linux



    Any idea on what might be going wrong please?


    Regards,
    Andrea

  • Any idea on what might be going wrong please?

    The plugin requires the linux-headers-amd64 package and that package is a meta package point to the 4.19 kernel headers. So, using the 4.18 won't work. Either upgrade to the 4.19 kernel or switch to the proxmox kernel.

    omv 5.5.5 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.3.5
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • thanks for the prompt response!


    What's the safest approach? also thinking about further future upgrades please...


    and, is upgrading to kernel 4.19 just a matter of running the below?
    apt-get install linux-image-4.19.0-0.bpo.5-amd64

  • What's the safest approach?

    I run the proxmox kernel on most of my systems.


    is upgrading to kernel 4.19 just a matter of running the below?

    Technically, that will do it but if you have backports enabled (you can do that in omv-extras), it should just show up as an update unless you removed the linux-image-amd64 package.

    omv 5.5.5 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.3.5
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!